summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-08-01 17:46:30 +0200
committerVladimír Čunát <vcunat@gmail.com>2016-08-07 20:46:37 +0200
commit950feb70b2e43e300bd0f285eb6e3ad446ca0722 (patch)
treef245993b24df468364c224dc9f3a3b29cb2539f4 /pkgs/applications
parent9a072482e69ab90c09ce2ca464a4316fb07c4a45 (diff)
downloadnixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.tar
nixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.tar.gz
nixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.tar.bz2
nixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.tar.lz
nixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.tar.xz
nixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.tar.zst
nixlib-950feb70b2e43e300bd0f285eb6e3ad446ca0722.zip
treewide: fixup various mysql ocurrences after re-split
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/amarok/default.nix2
-rw-r--r--pkgs/applications/gis/grass/default.nix5
2 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/applications/audio/amarok/default.nix b/pkgs/applications/audio/amarok/default.nix
index f70974427444..0cf939a85c63 100644
--- a/pkgs/applications/audio/amarok/default.nix
+++ b/pkgs/applications/audio/amarok/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ automoc4 cmake perl pkgconfig ];
 
   buildInputs = [
-    qtscriptgenerator stdenv.cc.libc gettext curl libxml2 mysql.lib
+    qtscriptgenerator stdenv.cc.libc gettext curl libxml2 mysql.server/*libmysqld*/
     taglib taglib_extras loudmouth kdelibs phonon strigi soprano qca2
     libmtp liblastfm libgpod qjson ffmpeg libofa nepomuk_core
     lz4 lzo snappy libaio pcre
diff --git a/pkgs/applications/gis/grass/default.nix b/pkgs/applications/gis/grass/default.nix
index c373f8b9e272..5773718b0a4c 100644
--- a/pkgs/applications/gis/grass/default.nix
+++ b/pkgs/applications/gis/grass/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation {
   };
 
   buildInputs = [ flex bison zlib proj gdal libtiff libpng fftw sqlite pkgconfig cairo
-  readline ffmpeg makeWrapper wxGTK30 netcdf geos postgresql mysql.lib blas ]
+  readline ffmpeg makeWrapper wxGTK30 netcdf geos postgresql mysql.client blas ]
     ++ (with pythonPackages; [ python dateutil wxPython30 numpy sqlite3 ]);
 
   configureFlags = [
@@ -22,7 +22,8 @@ stdenv.mkDerivation {
     "--with-netcdf"
     "--with-geos"
     "--with-postgres" "--with-postgres-libs=${postgresql.lib}/lib/"
-    "--with-mysql" "--with-mysql-includes=${mysql.lib}/include/mysql"
+    # it complains about missing libmysqld but doesn't really seem to need it
+    "--with-mysql" "--with-mysql-includes=${stdenv.lib.getDev mysql.client}/include/mysql"
     "--with-blas"
   ];