summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2015-04-24 11:51:05 -0500
committerJohn Wiegley <johnw@newartisans.com>2015-04-26 22:29:15 -0500
commit9402a566206f855234f3bdd90983974ea96f6e07 (patch)
tree8b28d6fa77924157923f3f0441cdd9192efb68b2 /pkgs/applications
parent39d8b61a25eb1fc0b5410b7fec4992540f8e5b8a (diff)
downloadnixlib-9402a566206f855234f3bdd90983974ea96f6e07.tar
nixlib-9402a566206f855234f3bdd90983974ea96f6e07.tar.gz
nixlib-9402a566206f855234f3bdd90983974ea96f6e07.tar.bz2
nixlib-9402a566206f855234f3bdd90983974ea96f6e07.tar.lz
nixlib-9402a566206f855234f3bdd90983974ea96f6e07.tar.xz
nixlib-9402a566206f855234f3bdd90983974ea96f6e07.tar.zst
nixlib-9402a566206f855234f3bdd90983974ea96f6e07.zip
coq_8_5: New expression
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/logic/coq/8.5.nix68
1 files changed, 68 insertions, 0 deletions
diff --git a/pkgs/applications/science/logic/coq/8.5.nix b/pkgs/applications/science/logic/coq/8.5.nix
new file mode 100644
index 000000000000..87b476249f44
--- /dev/null
+++ b/pkgs/applications/science/logic/coq/8.5.nix
@@ -0,0 +1,68 @@
+# - coqide compilation can be disabled by setting lablgtk to null;
+
+{stdenv, fetchurl, writeText, pkgconfig, ocaml, findlib, camlp5, ncurses, lablgtk ? null}:
+
+let
+  version = "8.5b2";
+  coq-version = "8.5";
+  buildIde = lablgtk != null;
+  ideFlags = if buildIde then "-lablgtkdir ${lablgtk}/lib/ocaml/*/site-lib/lablgtk2 -coqide opt" else "";
+in
+
+stdenv.mkDerivation {
+  name = "coq-${version}";
+
+  inherit coq-version;
+  inherit ocaml camlp5;
+
+  src = fetchurl {
+    url = https://coq.inria.fr/distrib/V8.5beta2/files/coq-8.5beta2.tar.gz;
+    sha256 = "1z34ch56lld86srgsjdwdq3girz0k0wqmvyxsa7jwvvxn3qmmq2v";
+  };
+
+  buildInputs = [ pkgconfig ocaml findlib camlp5 ncurses lablgtk ];
+
+  postPatch = ''
+    UNAME=$(type -tp uname)
+    RM=$(type -tp rm)
+    substituteInPlace configure --replace "/bin/uname" "$UNAME"
+    substituteInPlace tools/beautify-archive --replace "/bin/rm" "$RM"
+    substituteInPlace Makefile.build --replace "ifeq (\$(ARCH),Darwin)" "ifeq (\$(ARCH),Darwinx)"
+  '';
+
+  setupHook = writeText "setupHook.sh" ''
+    addCoqPath () {
+      if test -d "''$1/lib/coq/${coq-version}/user-contrib"; then
+        export COQPATH="''${COQPATH}''${COQPATH:+:}''$1/lib/coq/${coq-version}/user-contrib/"
+      fi
+    }
+
+    envHooks=(''${envHooks[@]} addCoqPath)
+  '';
+
+  preConfigure = ''
+    configureFlagsArray=(
+      -opt
+      ${ideFlags}
+    )
+  '';
+
+  prefixKey = "-prefix ";
+
+  buildFlags = "revision coq coqide";
+
+  meta = with stdenv.lib; {
+    description = "Coq proof assistant";
+    longDescription = ''
+      Coq is a formal proof management system.  It provides a formal language
+      to write mathematical definitions, executable algorithms and theorems
+      together with an environment for semi-interactive development of
+      machine-checked proofs.
+    '';
+    homepage = "http://coq.inria.fr";
+    license = licenses.lgpl21;
+    branch = coq-version;
+    maintainers = with maintainers; [ roconnor thoughtpolice vbgl ];
+    platforms = platforms.unix;
+  };
+}