summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorYuriy Taraday <yorik.sar@gmail.com>2018-05-31 00:25:22 +0400
committerYuriy Taraday <yorik.sar@gmail.com>2018-05-31 00:28:51 +0400
commit88007f819d87c21a7be5e3c801f8f319f4515474 (patch)
tree13f85798ed2b02dfacf41111de14ccf8dd437325 /pkgs/applications
parent7acec162261a574e75a0c4e1e11e781923407a2f (diff)
downloadnixlib-88007f819d87c21a7be5e3c801f8f319f4515474.tar
nixlib-88007f819d87c21a7be5e3c801f8f319f4515474.tar.gz
nixlib-88007f819d87c21a7be5e3c801f8f319f4515474.tar.bz2
nixlib-88007f819d87c21a7be5e3c801f8f319f4515474.tar.lz
nixlib-88007f819d87c21a7be5e3c801f8f319f4515474.tar.xz
nixlib-88007f819d87c21a7be5e3c801f8f319f4515474.tar.zst
nixlib-88007f819d87c21a7be5e3c801f8f319f4515474.zip
chromium: remove outdated patches
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix16
-rw-r--r--pkgs/applications/networking/browsers/chromium/patches/neon_buildfix.patch21
-rw-r--r--pkgs/applications/networking/browsers/chromium/patches/skia_buildfix.patch22
3 files changed, 1 insertions, 58 deletions
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index 4718cc6c1ede..8ab141b5a337 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -145,23 +145,9 @@ let
     # (gentooPatch "<patch>" "0000000000000000000000000000000000000000000000000000000000000000")
     ]  ++ optionals (versionRange "66" "68") [
       ./patches/nix_plugin_paths_52.patch
-    ]  ++ optionals (versionRange "66" "67") [
-      (gentooPatch "chromium-webrtc-r0.patch" "0wp4zivbv2wpgiwmiznbq1aw4w98mvwjvdy36cpfmnvr8yw430pd")
-      (gentooPatch "chromium-ffmpeg-r1.patch" "1k8agaqsvg0w0s6s5wh346ih02cc86vr0vwyshw2q9vafa0jvmq4")
-      # GCC 7 fixes
-      (githubPatch "f64fadcd79aebe5ed893ecbf258d1123609d28f8" "1h255w1v327r08cnifs19s4bwmkinqjmdmbwihddc5dyl43sjnvv")
-      (githubPatch "ede5178322ccd297b0ad82ae4c59119ceaab9ea5" "0rsal0dy0yhgs4lhn8h1vy1s77xcssy4f5wals7hvrz5m08jqizj")
-      (githubPatch "7d721f438acb38db556ae9a9e6e8b718bd503216" "13lzvxm63zq3rd8p387ylq4bm9wr4r09vk2w4p81f838pf0v1kbj")
-      (githubPatch "ba4141e451f4e0b1b19410b1b503bd32e150df06" "1cjxw1f9fin6z12b0mcxnxf2mdjb0n3chwz7mgvmp9yij8qhqnxj")
-      (githubPatch "b34ed1e6524479d61ee944ebf6ca7389ea47e563" "1s13zw93nsyr259dzck6gbhg4x46qg5sg14djf4bvrrc6hlkiczw")
-      (githubPatch "4f2b52281ce1649ea8347489443965ad33262ecc" "1g59izkicn9cpcphamdgrijs306h5b9i7i4pmy134asn1ifiax5z")
     ]  ++ optionals (versionAtLeast version "68") [
       ./patches/nix_plugin_paths_68.patch
-    ] ++ optional enableWideVine ./patches/widevine.patch
-      ++ optionals (stdenv.isAarch64 && versionRange "65" "67") [
-        ./patches/skia_buildfix.patch
-        ./patches/neon_buildfix.patch
-    ];
+    ] ++ optional enableWideVine ./patches/widevine.patch;
 
     postPatch = ''
       # We want to be able to specify where the sandbox is via CHROME_DEVEL_SANDBOX
diff --git a/pkgs/applications/networking/browsers/chromium/patches/neon_buildfix.patch b/pkgs/applications/networking/browsers/chromium/patches/neon_buildfix.patch
deleted file mode 100644
index b44487ca634c..000000000000
--- a/pkgs/applications/networking/browsers/chromium/patches/neon_buildfix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/skia/ext/convolver_neon.cc b/skia/ext/convolver_neon.cc
-index 26b91b9..cae6bc2 100644
---- a/skia/ext/convolver_neon.cc
-+++ b/skia/ext/convolver_neon.cc
-
-@@ -23,7 +23,7 @@
-     remainder[2] += coeff * pixels_left[i * 4 + 2];
-     remainder[3] += coeff * pixels_left[i * 4 + 3];
-   }
--  return {remainder[0], remainder[1], remainder[2], remainder[3]};
-+  return vld1q_s32(remainder);
- }
- 
- // Convolves horizontally along a single row. The row data is given in
-@@ -336,4 +336,4 @@
-   }
- }
- 
--}  // namespace skia
-\ No newline at end of file
-+}  // namespace skia
diff --git a/pkgs/applications/networking/browsers/chromium/patches/skia_buildfix.patch b/pkgs/applications/networking/browsers/chromium/patches/skia_buildfix.patch
deleted file mode 100644
index 5348b9ac905b..000000000000
--- a/pkgs/applications/networking/browsers/chromium/patches/skia_buildfix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: chromium-browser-65.0.3325.73/third_party/skia/src/jumper/SkJumper_stages.cpp
-===================================================================
---- chromium-browser-65.0.3325.73.orig/third_party/skia/src/jumper/SkJumper_stages.cpp
-+++ chromium-browser-65.0.3325.73/third_party/skia/src/jumper/SkJumper_stages.cpp
-@@ -666,7 +666,7 @@ SI F approx_powf(F x, F y) {
- }
- 
- SI F from_half(U16 h) {
--#if defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3)  // Temporary workaround for some Google3 builds.
-+#if defined(JUMPER_IS_NEON) && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3)  // Temporary workaround for some Google3 builds.
-     return vcvt_f32_f16(h);
- 
- #elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
-@@ -686,7 +686,7 @@ SI F from_half(U16 h) {
- }
- 
- SI U16 to_half(F f) {
--#if defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3)  // Temporary workaround for some Google3 builds.
-+#if defined(JUMPER_IS_NEON) && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3)  // Temporary workaround for some Google3 builds.
-     return vcvt_f16_f32(f);
- 
- #elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)