summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-09-05 04:44:51 +0400
committerGitHub <noreply@github.com>2016-09-05 04:44:51 +0400
commit845cb949fca5fdfc56749e092a67c22f0e4515f7 (patch)
tree5dd40f77e9856a33cc7758a0c06c7bdf5391539f /pkgs/applications
parent373afbd516de07d8e30e6e25be45700986f9ab1f (diff)
parentf0cf058c130cdd0716e56107ff40b3873ad7715f (diff)
downloadnixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.tar
nixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.tar.gz
nixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.tar.bz2
nixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.tar.lz
nixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.tar.xz
nixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.tar.zst
nixlib-845cb949fca5fdfc56749e092a67c22f0e4515f7.zip
Merge pull request #18306 from aske/speech
Speech synthesizer improvements
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/espeak-ng/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/applications/audio/espeak-ng/default.nix b/pkgs/applications/audio/espeak-ng/default.nix
new file mode 100644
index 000000000000..cb2e15bc5b23
--- /dev/null
+++ b/pkgs/applications/audio/espeak-ng/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, lib, fetchFromGitHub, autoconf, automake, which, libtool, pkgconfig
+, ronn
+, pcaudiolibSupport ? true, pcaudiolib
+, sonicSupport ? true, sonic }:
+
+stdenv.mkDerivation rec {
+  name = "espeak-ng-${version}";
+  version = "2016-08-28";
+
+  src = fetchFromGitHub {
+    owner = "espeak-ng";
+    repo = "espeak-ng";
+    rev = "b784e77c5708b61feed780d8f1113c4c8eb92200";
+    sha256 = "1whix4mv0qvsvifgpwwbdzhv621as3rxpn9ijqc2683h6k8pvcfk";
+  };
+
+  nativeBuildInputs = [ autoconf automake which libtool pkgconfig ronn ];
+
+  buildInputs = lib.optional pcaudiolibSupport pcaudiolib
+             ++ lib.optional sonicSupport sonic;
+
+  preConfigure = "./autogen.sh";
+
+  postInstall = ''
+    patchelf --set-rpath "$(patchelf --print-rpath $out/bin/espeak-ng)" $out/bin/speak-ng
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Open source speech synthesizer that supports over 70 languages, based on eSpeak";
+    homepage = "https://github.com/espeak-ng/espeak-ng";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ aske ];
+    platforms = platforms.linux;
+  };
+}