summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorBart Brouns <bart@magnetopon.nl>2015-05-25 03:12:07 +0200
committerBart Brouns <bart@magnetopon.nl>2015-05-25 21:38:39 +0200
commit7ad53157e071e4f3f2dbee560a9d9b4904072c1f (patch)
tree1adb4489fc69c73f0bb5b372587f770aa4f2b653 /pkgs/applications
parentd7de6dad5fc4de83ca4c8fac93bd1a0243c45f71 (diff)
downloadnixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.tar
nixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.tar.gz
nixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.tar.bz2
nixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.tar.lz
nixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.tar.xz
nixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.tar.zst
nixlib-7ad53157e071e4f3f2dbee560a9d9b4904072c1f.zip
add eq10q: LV2 EQ plugins and more, with 64 bit processing
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/eq10q/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/applications/audio/eq10q/default.nix b/pkgs/applications/audio/eq10q/default.nix
new file mode 100644
index 000000000000..61c979534229
--- /dev/null
+++ b/pkgs/applications/audio/eq10q/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchurl, cmake, fftw, gtkmm, libxcb, lv2, pkgconfig, xlibs }:
+stdenv.mkDerivation rec {
+  name = "eq10q-2-${version}";
+  version = "beta7.1";
+  src = fetchurl {
+    url = "http://downloads.sourceforge.net/project/eq10q/${name}.tar.gz";
+    sha256 = "1jmrcx4jlx8kgsy5n4jcxa6qkjqvx7d8l2p7dsmw4hj20s39lgyi";
+  };
+
+  buildInputs = [ cmake fftw gtkmm libxcb lv2 pkgconfig xlibs.libpthreadstubs xlibs.libXdmcp xlibs.libxshmfence ];
+
+  installFlags = ''
+    DESTDIR=$(out)
+  '';
+
+  fixupPhase = ''
+    cp -r $out/var/empty/local/lib $out
+    rm -R $out/var
+  '';
+
+  meta = {
+    description = "LV2 EQ plugins and more, with 64 bit processing";
+    longDescription = ''
+      Up to 10-Bands parametric equalizer with mono and stereo versions.
+      Versatile noise-gate plugin with mono and stereo versions.
+      Compressor plugin with mono and stereo versions.
+      BassUp plugin - Enhanceing the bass guitar sound or other low frequency sounding instruments.
+      Improved high frequency response for peaking filter (in equalizers).
+      64 bits floating point internal audio processing.
+      Nice GUI with powerful metering for every plugin.
+    '';
+    homepage = http://eq10q.sourceforge.net/;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.magnetophon ];
+    platforms = stdenv.lib.platforms.linux;
+  };
+}