summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-05-24 13:56:28 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-05-24 13:56:28 +0200
commit78ea189a6b1c59e7c331fe57d1eb035b8977bdac (patch)
tree67f04910c45d8bdd1a4540f7777791bd04e7dc26 /pkgs/applications
parent8004e794153b34507f81a26f88174bdfee975aa8 (diff)
parent760248360c1d3b2a0a648a76803180e7a6c13275 (diff)
downloadnixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.tar
nixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.tar.gz
nixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.tar.bz2
nixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.tar.lz
nixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.tar.xz
nixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.tar.zst
nixlib-78ea189a6b1c59e7c331fe57d1eb035b8977bdac.zip
Merge branch 'master' into staging
... to fix *some* of the evaluation problems.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/kodi/default.nix12
-rw-r--r--pkgs/applications/video/vlc/default.nix10
-rw-r--r--pkgs/applications/virtualization/lkl/default.nix30
3 files changed, 29 insertions, 23 deletions
diff --git a/pkgs/applications/video/kodi/default.nix b/pkgs/applications/video/kodi/default.nix
index 649dad0bb57f..4d3474a1db21 100644
--- a/pkgs/applications/video/kodi/default.nix
+++ b/pkgs/applications/video/kodi/default.nix
@@ -54,17 +54,16 @@ let
   };
 in stdenv.mkDerivation rec {
     name = "kodi-${version}";
-    version = "17.1";
+    version = "17.2";
 
     src = fetchurl {
       url = "https://github.com/xbmc/xbmc/archive/${version}-${rel}.tar.gz";
-      sha256 = "1vmvrq0qdjnphw34yils2b5jnm05cmsg777hc4lwqz5mrc1kjgrh";
+      sha256 = "1zmgw65dbdpv72xfimrh02m8sdg4cb9i3hbmqzgs8x00b9n27ndf";
     };
 
     buildInputs = [
-      makeWrapper libxml2 gnutls
-      pkgconfig cmake gnumake yasm python2
-      boost libmicrohttpd autoreconfHook
+      libxml2 gnutls yasm python2
+      boost libmicrohttpd
       gettext pcre-cpp yajl fribidi libva
       openssl gperf tinyxml2 taglib libssh swig jre
       libX11 xproto inputproto which
@@ -91,6 +90,9 @@ in stdenv.mkDerivation rec {
     ++ lib.optional rtmpSupport rtmpdump
     ++ lib.optional joystickSupport SDL2;
 
+    nativeBuildInputs = [
+      autoreconfHook cmake gnumake makeWrapper pkgconfig
+    ];
 
     dontUseCmakeConfigure = true;
 
diff --git a/pkgs/applications/video/vlc/default.nix b/pkgs/applications/video/vlc/default.nix
index c52d14390125..48e5af7162d0 100644
--- a/pkgs/applications/video/vlc/default.nix
+++ b/pkgs/applications/video/vlc/default.nix
@@ -20,19 +20,13 @@ assert (!withQt5 -> qt4 != null);
 
 stdenv.mkDerivation rec {
   name = "vlc-${version}";
-  version = "2.2.4";
+  version = "2.2.5.1";
 
   src = fetchurl {
     url = "http://get.videolan.org/vlc/${version}/${name}.tar.xz";
-    sha256 = "1gjkrwlg8ab3skzl67cxb9qzg4187ifckd1z9kpy11q058fyjchn";
+    sha256 = "1k51vm6piqlrnld7sxyg0s4kdkd3lan97lmy3v5wdh3qyll8m2xj";
   };
 
-  patches = optional withQt5 (fetchurl {
-    name = "Fix-build-using-old-GCC-intrinsics.patch";
-    url = "https://patches.videolan.org/patch/14061/raw/";
-    sha256 = "16v4k7378a590diz11bdvdaqi9cpf6333hp5wr6v5sfrsma8qvpx";
-  });
-
   # Comment-out the Qt 5.5 version check, as we do apply the relevant patch.
   # https://trac.videolan.org/vlc/ticket/16497
   postPatch = if (!withQt5) then null else
diff --git a/pkgs/applications/virtualization/lkl/default.nix b/pkgs/applications/virtualization/lkl/default.nix
index 134df59159b4..e40d054520f7 100644
--- a/pkgs/applications/virtualization/lkl/default.nix
+++ b/pkgs/applications/virtualization/lkl/default.nix
@@ -1,31 +1,35 @@
 { stdenv, fetchFromGitHub, bc, python, fuse, libarchive }:
 
 stdenv.mkDerivation rec {
-  name = "lkl-${stdenv.lib.substring 0 7 rev}";
-  rev  = "d74707304d4e4614081ae2a612a833aeb46622b5";
+  name = "lkl-2017-03-24";
+  rev  = "a063e1631db5e2b9b04f184c5e6d185c1cd645cb";
 
-  buildInputs = [ bc python fuse libarchive ];
+  outputs = [ "dev" "lib" "out" ];
+
+  nativeBuildInputs = [ bc python ];
+
+  buildInputs = [ fuse libarchive ];
 
   src = fetchFromGitHub {
     inherit rev;
     owner  = "lkl";
     repo   = "linux";
-    sha256 = "0x1hdjsrj6hfk1sgfw11ihm00fmp6g158sr2q3cgjy2b6jnsr4hp";
+    sha256 = "07dmira76i0ki577sra4fdl1wvzfzxzd75252lza0sc6jdzrrwvj";
   };
 
   # Fix a /usr/bin/env reference in here that breaks sandboxed builds
   prePatch = "patchShebangs arch/lkl/scripts";
 
   installPhase = ''
-    mkdir -p $out/{bin,lib}
+    mkdir -p $out/bin $lib/lib $dev
 
-    # This tool assumes a different directory structure so let's point it at the right location
     cp tools/lkl/bin/lkl-hijack.sh $out/bin
-    substituteInPlace $out/bin/lkl-hijack.sh --replace '/../' '/../lib'
+    sed -i $out/bin/lkl-hijack.sh \
+        -e "s,LD_LIBRARY_PATH=.*,LD_LIBRARY_PATH=$lib/lib,"
 
     cp tools/lkl/{cptofs,cpfromfs,fs2tar,lklfuse} $out/bin
-    cp -r tools/lkl/include $out
-    cp tools/lkl/liblkl*.{a,so} $out/lib
+    cp -r tools/lkl/include $dev/
+    cp tools/lkl/liblkl*.{a,so} $lib/lib
   '';
 
   # We turn off format and fortify because of these errors (fortify implies -O2, which breaks the jitter entropy code):
@@ -38,7 +42,13 @@ stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   meta = with stdenv.lib; {
-    description = "LKL (Linux Kernel Library) aims to allow reusing the Linux kernel code as extensively as possible with minimal effort and reduced maintenance overhead";
+    description = "The Linux kernel as a library";
+    longDescription = ''
+      LKL (Linux Kernel Library) aims to allow reusing the Linux kernel code as
+      extensively as possible with minimal effort and reduced maintenance
+      overhead
+    '';
+    homepage    = https://github.com/lkl/linux/;
     platforms   = [ "x86_64-linux" ]; # Darwin probably works too but I haven't tested it
     license     = licenses.gpl2;
     maintainers = with maintainers; [ copumpkin ];