summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-03-26 14:44:05 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-03-26 14:44:05 -0700
commit767c179a9440293f259433f6e8bf578176927d72 (patch)
tree1902b66023b85f0991d78f4f404bdce12ffb7503 /pkgs/applications
parent2c8cf45772862e7e2d77086bbaaa6ac0183ea0bf (diff)
parent5a2a71f2c2bbefe01f33c8f0542f57b770a065b2 (diff)
downloadnixlib-767c179a9440293f259433f6e8bf578176927d72.tar
nixlib-767c179a9440293f259433f6e8bf578176927d72.tar.gz
nixlib-767c179a9440293f259433f6e8bf578176927d72.tar.bz2
nixlib-767c179a9440293f259433f6e8bf578176927d72.tar.lz
nixlib-767c179a9440293f259433f6e8bf578176927d72.tar.xz
nixlib-767c179a9440293f259433f6e8bf578176927d72.tar.zst
nixlib-767c179a9440293f259433f6e8bf578176927d72.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/pavucontrol/default.nix4
-rw-r--r--pkgs/applications/audio/snd/default.nix4
-rw-r--r--pkgs/applications/audio/spotify/default.nix10
-rw-r--r--pkgs/applications/editors/idea/default.nix14
-rw-r--r--pkgs/applications/editors/nano/default.nix33
-rw-r--r--pkgs/applications/editors/rstudio/default.nix2
-rw-r--r--pkgs/applications/editors/rstudio/r-location.patch24
-rw-r--r--pkgs/applications/graphics/sxiv/default.nix6
-rw-r--r--pkgs/applications/misc/robomongo/default.nix2
-rw-r--r--pkgs/applications/networking/mailreaders/mutt-kz/default.nix64
-rw-r--r--pkgs/applications/science/logic/abella/default.nix38
-rw-r--r--pkgs/applications/science/logic/z3/default.nix7
-rw-r--r--pkgs/applications/science/math/pcalc/default.nix6
-rw-r--r--pkgs/applications/version-management/fossil/default.nix12
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/default.nix4
15 files changed, 184 insertions, 46 deletions
diff --git a/pkgs/applications/audio/pavucontrol/default.nix b/pkgs/applications/audio/pavucontrol/default.nix
index 8696b1c055d0..8e4c31302e26 100644
--- a/pkgs/applications/audio/pavucontrol/default.nix
+++ b/pkgs/applications/audio/pavucontrol/default.nix
@@ -2,11 +2,11 @@
 , libcanberra_gtk3, makeWrapper, gnome3 }:
 
 stdenv.mkDerivation rec {
-  name = "pavucontrol-2.0";
+  name = "pavucontrol-3.0";
 
   src = fetchurl {
     url = "http://freedesktop.org/software/pulseaudio/pavucontrol/${name}.tar.xz";
-    sha256 = "02s775m1531sshwlbvfddk3pz8zjmwkv1sgzggn386ja3gc9vwi2";
+    sha256 = "14486c6lmmirkhscbfygz114f6yzf97h35n3h3pdr27w4mdfmlmk";
   };
 
   preFixup = ''
diff --git a/pkgs/applications/audio/snd/default.nix b/pkgs/applications/audio/snd/default.nix
index 8f2e9e787b31..6048ff88c35a 100644
--- a/pkgs/applications/audio/snd/default.nix
+++ b/pkgs/applications/audio/snd/default.nix
@@ -4,11 +4,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "snd-15.2";
+  name = "snd-15.4";
 
   src = fetchurl {
     url = "mirror://sourceforge/snd/${name}.tar.gz";
-    sha256 = "0v2r7a6363aai726cywi7ai0qlwdc20bqdprs5fmyz8sbmksbqzr";
+    sha256 = "1dari02ind445h5hpb6dhi0kix1vmlk64lyxwv1zrqagw3ajmpwh";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/applications/audio/spotify/default.nix b/pkgs/applications/audio/spotify/default.nix
index 2a56e1095408..d66029199ce8 100644
--- a/pkgs/applications/audio/spotify/default.nix
+++ b/pkgs/applications/audio/spotify/default.nix
@@ -8,7 +8,7 @@ assert stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux";
 let
   version = if stdenv.system == "i686-linux"
     then "0.9.4.183.g644e24e.428"
-    else "0.9.11.27.g2b1a638.81";
+    else "0.9.17.1.g9b85d43.7";
 
   deps = [
     alsaLib
@@ -55,7 +55,7 @@ stdenv.mkDerivation {
     else if stdenv.system == "x86_64-linux" then
       fetchurl {
         url = "http://repository.spotify.com/pool/non-free/s/spotify/spotify-client_${version}-1_amd64.deb";
-        sha256 = "0yfljiw01kssj3qaz8m0ppgrpjs6xrhzlr2wccp64bsnmin7g4sg";
+        sha256 = "0x87q7gd2997sgppsm4lmdiz1cm11x5vnd5c34nqb5d4ry5qfyki";
       }
     else throw "Spotify not supported on this platform.";
 
@@ -90,8 +90,8 @@ stdenv.mkDerivation {
       ln -s ${nspr}/lib/libplc4.so $libdir/libplc4.so.0d
       ''}
 
-      # Work around Spotify trying to open libudev.so.0 (which we don't have)
-      ln -s ${udev}/lib/libudev.so.1 $libdir/libudev.so.0
+      # Work around Spotify trying to open libudev.so.1 (which we don't have)
+      ln -s ${udev}/lib/libudev.so.1 $libdir/libudev.so.1
 
       mkdir -p $out/bin
 
@@ -128,6 +128,6 @@ stdenv.mkDerivation {
     homepage = https://www.spotify.com/;
     description = "Play music from the Spotify music service";
     license = stdenv.lib.licenses.unfree;
-    maintainers = [ stdenv.lib.maintainers.eelco ];
+    maintainers = with stdenv.lib.maintainers; [ eelco ftrvxmtrx ];
   };
 }
diff --git a/pkgs/applications/editors/idea/default.nix b/pkgs/applications/editors/idea/default.nix
index 61d508936b8b..9c4683b8c9e0 100644
--- a/pkgs/applications/editors/idea/default.nix
+++ b/pkgs/applications/editors/idea/default.nix
@@ -205,14 +205,14 @@ in
   };
 
   clion = buildClion rec {
-    name = "clion-${version}";
+    name = "clion-${build}";
     version = "eap";
-    build = "140.1740.3";
+    build = "141.102.4";
     description  = "C/C++ IDE. New. Intelligent. Cross-platform.";
     license = stdenv.lib.licenses.unfree;
     src = fetchurl {
-      url = "https://download.jetbrains.com/cpp/${name}-${build}.tar.gz";
-      sha256 = "1hpsq37hq61id836wg5j6l3xapln6qdkqa10r3ig2p1rs2hq7i9y";
+      url = "https://download.jetbrains.com/cpp/${name}.tar.gz";
+      sha256 = "0qjm8wxqn171wfd7yqf5ys1g4mwl0iyhlbry29jkgkikxp7h9dym";
     };
   };
 
@@ -242,13 +242,13 @@ in
 
   ruby-mine = buildRubyMine rec {
     name = "ruby-mine-${version}";
-    version = "7.0";
-    build = "135.1104";
+    version = "7.0.4";
+    build = "139.1231";
     description = "The Most Intelligent Ruby and Rails IDE";
     license = stdenv.lib.licenses.unfree;
     src = fetchurl {
       url = "https://download.jetbrains.com/ruby/RubyMine-${version}.tar.gz";
-      sha256 = "0xsx44gaddarkw5k4yjidzwkayf2xvsxklfzdnzcck4rg4vyk4v4";
+      sha256 = "08b0iwccb5w9b1yk0kbs99r5mxkcyxqs9mkr57wb5j71an80yx38";
     };
   };
 
diff --git a/pkgs/applications/editors/nano/default.nix b/pkgs/applications/editors/nano/default.nix
index caea8758d958..3e777207fd02 100644
--- a/pkgs/applications/editors/nano/default.nix
+++ b/pkgs/applications/editors/nano/default.nix
@@ -1,22 +1,33 @@
-{ stdenv, fetchurl, ncurses, gettext }:
+{ stdenv, fetchurl
+, ncurses
+, gettext ? null
+, enableNls ? true
+, enableTiny ? false
+}:
 
-stdenv.mkDerivation (rec {
-  pname = "nano";
-  version = "2.3.6";
+assert enableNls -> (gettext != null);
 
-  name = "${pname}-${version}";
+with stdenv.lib;
 
+stdenv.mkDerivation rec {
+  name = "nano-${version}";
+  version = "2.4.0";
   src = fetchurl {
     url = "mirror://gnu/nano/${name}.tar.gz";
-    sha256 = "a74bf3f18b12c1c777ae737c0e463152439e381aba8720b4bc67449f36a09534";
+    sha256 = "1gbm9bcv4k55y01r5q8a8a9s3yrrgq3z5jxxiij3wl404r8gnxjh";
   };
-
-  buildInputs = [ ncurses gettext ];
-
-  configureFlags = "sysconfdir=/etc";
+  buildInputs = [ ncurses ] ++ optional enableNls gettext;
+  configureFlags = ''
+    --sysconfdir=/etc
+    ${optionalString (!enableNls) "--disable-nls"}
+    ${optionalString enableTiny "--enable-tiny"}
+  '';
 
   meta = {
     homepage = http://www.nano-editor.org/;
     description = "A small, user-friendly console text editor";
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ joachifm ];
+    platforms = platforms.all;
   };
-})
+}
diff --git a/pkgs/applications/editors/rstudio/default.nix b/pkgs/applications/editors/rstudio/default.nix
index c3ecbf0a60f5..fda51dc24019 100644
--- a/pkgs/applications/editors/rstudio/default.nix
+++ b/pkgs/applications/editors/rstudio/default.nix
@@ -51,7 +51,7 @@ stdenv.mkDerivation {
 
       mkdir dependencies/common/dictionaries
       for dict in $hunspellDicts; do
-          for i in $dict/share/hunspell/*
+          for i in "$dict/share/hunspell/"*
 	  do ln -sv $i dependencies/common/dictionaries/
 	  done
       done
diff --git a/pkgs/applications/editors/rstudio/r-location.patch b/pkgs/applications/editors/rstudio/r-location.patch
new file mode 100644
index 000000000000..a1ec84a5475c
--- /dev/null
+++ b/pkgs/applications/editors/rstudio/r-location.patch
@@ -0,0 +1,24 @@
+diff -ur rstudio-0.98.110-old/src/cpp/core/CMakeLists.txt rstudio-0.98.110-new/src/cpp/core/CMakeLists.txt
+--- rstudio-0.98.110-old/src/cpp/core/r_util/REnvironmentPosix.cpp	2013-04-28 10:02:14.000000000 -0400
++++ rstudio-0.98.110-new/src/cpp/core/r_util/REnvironmentPosix.cpp	2015-03-23 15:06:35.533400807 -0400
+@@ -84,9 +84,7 @@
+ {
+    // define potential paths
+    std::vector<std::string> rScriptPaths;
+-   rScriptPaths.push_back("/usr/bin/R");
+-   rScriptPaths.push_back("/usr/local/bin/R");
+-   rScriptPaths.push_back("/opt/local/bin/R");
++   rScriptPaths.push_back("@R@/bin/R");
+    return scanForRScript(rScriptPaths, pErrMsg);
+ }
+
+@@ -220,8 +218,7 @@
+       // scan in standard locations as a fallback
+       std::string scanErrMsg;
+       std::vector<std::string> rScriptPaths;
+-      rScriptPaths.push_back("/usr/local/bin/R");
+-      rScriptPaths.push_back("/usr/bin/R");
++      rScriptPaths.push_back("@R@/bin/R");
+       FilePath scriptPath = scanForRScript(rScriptPaths, &scanErrMsg);
+       if (scriptPath.empty())
+       {
diff --git a/pkgs/applications/graphics/sxiv/default.nix b/pkgs/applications/graphics/sxiv/default.nix
index d3caed5abe8e..45813bbdb204 100644
--- a/pkgs/applications/graphics/sxiv/default.nix
+++ b/pkgs/applications/graphics/sxiv/default.nix
@@ -1,12 +1,12 @@
 { stdenv, fetchgit, libX11, imlib2, giflib, libexif }:
 
 stdenv.mkDerivation {
-  name = "sxiv-1.3-git";
+  name = "sxiv-2015.03.25";
 
   src = fetchgit {
     url = "https://github.com/muennich/sxiv.git";
-    rev = "92e3b57816e999b46f8d0778984719227631e9a7";
-    sha256 = "0jbswh0k1xq5hgrv1pyvk7lpwbbj66p7gjsdm8zh6ah324apjr2b";
+    rev = "01ed483b50f506fcba928af43e2ca017897e7c77";
+    sha256 = "18s64l3dvibqg9biznzy4mdkkn9qmmpqxpdx7ljx7c0832aqy94k";
   };
 
   postUnpack = ''
diff --git a/pkgs/applications/misc/robomongo/default.nix b/pkgs/applications/misc/robomongo/default.nix
index 26c091a7aa96..80424a308d77 100644
--- a/pkgs/applications/misc/robomongo/default.nix
+++ b/pkgs/applications/misc/robomongo/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation {
   patches = [ ./robomongo.patch ];
 
   postPatch = ''
-    rm ./cmake/FindOpenSSL.cmake
+    rm ./cmake/FindOpenSSL.cmake # remove outdated bundled CMake file
   '';
 
   NIX_CFLAGS_COMPILE = "-fno-stack-protector";
diff --git a/pkgs/applications/networking/mailreaders/mutt-kz/default.nix b/pkgs/applications/networking/mailreaders/mutt-kz/default.nix
new file mode 100644
index 000000000000..a162df9f33b2
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/mutt-kz/default.nix
@@ -0,0 +1,64 @@
+{ stdenv, fetchurl, ncurses, which, perl, autoreconfHook, autoconf, automake, notmuch
+, sslSupport ? true
+, imapSupport ? true
+, headerCache ? true
+, saslSupport ? true
+, gpgmeSupport ? true
+, gdbm ? null
+, openssl ? null
+, cyrus_sasl ? null
+, gpgme ? null
+}:
+
+assert headerCache -> gdbm != null;
+assert sslSupport -> openssl != null;
+assert saslSupport -> cyrus_sasl != null;
+assert gpgmeSupport -> gpgme != null;
+
+let
+  version = "1.5.23.1-rc1";
+in
+stdenv.mkDerivation rec {
+  name = "mutt-kz-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/karelzak/mutt-kz/archive/v${version}.tar.gz";
+    sha256 = "1m4bnn8psyrx2wy8ribannmp5qf75lv1gz116plji2z37z015zny";
+  };
+
+  buildInputs = with stdenv.lib;
+    [ ncurses which perl autoreconfHook autoconf automake notmuch]
+    ++ optional headerCache gdbm
+    ++ optional sslSupport openssl
+    ++ optional saslSupport cyrus_sasl
+    ++ optional gpgmeSupport gpgme;
+
+configureFlags = [
+    "--with-mailpath=" "--enable-smtp"
+
+    # This allows calls with "-d N", that output debug info into ~/.muttdebug*
+    "--enable-debug"
+
+    "--enable-pop" "--enable-imap"
+
+    "--enable-notmuch"
+
+    # The next allows building mutt without having anything setgid
+    # set by the installer, and removing the need for the group 'mail'
+    # I set the value 'mailbox' because it is a default in the configure script
+    "--with-homespool=mailbox"
+    (if headerCache then "--enable-hcache" else "--disable-hcache")
+    (if sslSupport then "--with-ssl" else "--without-ssl")
+    (if imapSupport then "--enable-imap" else "--disable-imap")
+    (if saslSupport then "--with-sasl" else "--without-sasl")
+    (if gpgmeSupport then "--enable-gpgme" else "--disable-gpgme")
+  ];
+
+  meta = with stdenv.lib; {
+    description = "A small but very powerful text-based mail client, forked to support notmuch";
+    homepage = https://github.com/karelzak/mutt-kz/;
+    license = stdenv.lib.licenses.gpl2Plus;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ magnetophon ];
+  };
+}
diff --git a/pkgs/applications/science/logic/abella/default.nix b/pkgs/applications/science/logic/abella/default.nix
new file mode 100644
index 000000000000..1c3e8e412f80
--- /dev/null
+++ b/pkgs/applications/science/logic/abella/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchurl, rsync, ocaml }:
+
+stdenv.mkDerivation rec {
+  name = "abella-${version}";
+  version = "2.0.2";
+
+  src = fetchurl {
+    url = "http://abella-prover.org/distributions/${name}.tar.gz";
+    sha256 = "b56d865ebdb198111f1dcd5b6fbcc0d7fc6dd1294f7601903ba4e3c3322c099c";
+  };
+
+  buildInputs = [ rsync ocaml ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    rsync -av abella    $out/bin/
+
+    mkdir -p $out/share/emacs/site-lisp/abella/
+    rsync -av emacs/    $out/share/emacs/site-lisp/abella/
+
+    mkdir -p $out/share/abella/examples
+    rsync -av examples/ $out/share/abella/examples/
+  '';
+
+  meta = {
+    description = "Interactive theorem prover";
+    longDescription = ''
+      Abella is an interactive theorem prover based on lambda-tree syntax.
+      This means that Abella is well-suited for reasoning about the meta-theory
+      of programming languages and other logical systems which manipulate
+      objects with binding.
+    '';
+    homepage = http://abella-prover.org/;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = with stdenv.lib.maintainers; [ bcdarwin ];
+    platforms = stdenv.lib.platforms.unix;
+  };
+}
diff --git a/pkgs/applications/science/logic/z3/default.nix b/pkgs/applications/science/logic/z3/default.nix
index a213f6da37ed..1df4035c29ce 100644
--- a/pkgs/applications/science/logic/z3/default.nix
+++ b/pkgs/applications/science/logic/z3/default.nix
@@ -26,11 +26,8 @@ stdenv.mkDerivation rec {
   soext = if stdenv.system == "x86_64-darwin" then ".dylib" else ".so";
   installPhase = ''
     mkdir -p $out/bin $out/lib/${python.libPrefix}/site-packages $out/include
-    cp ../src/api/z3.h        $out/include
-    cp ../src/api/z3_api.h    $out/include
-    cp ../src/api/z3_v1.h     $out/include
-    cp ../src/api/z3_macros.h $out/include
-    cp ../src/api/c++/z3++.h  $out/include
+    cp ../src/api/z3*.h       $out/include
+    cp ../src/api/c++/z3*.h   $out/include
     cp z3                     $out/bin
     cp libz3${soext}          $out/lib
     cp libz3${soext}          $out/lib/${python.libPrefix}/site-packages
diff --git a/pkgs/applications/science/math/pcalc/default.nix b/pkgs/applications/science/math/pcalc/default.nix
index 8e68e455ef18..c291c0ce6e5b 100644
--- a/pkgs/applications/science/math/pcalc/default.nix
+++ b/pkgs/applications/science/math/pcalc/default.nix
@@ -4,12 +4,12 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "pcalc-${version}";
-  version = "20120812";
+  version = "20141224";
 
   src = fetchgit {
     url = git://git.code.sf.net/p/pcalc/code;
-    rev = "db5c5d587d4d24ff6b23405a92eeaad4c0f99618";
-    sha256 = "1bzmiz9rrss3xk0vzszbisjkph73zwgc0riqn9zdd2h1iv6dgq92";
+    rev = "181d60d3c880da4344fef7138065943eb3b9255f";
+    sha256 = "0n60m3p4kkqvvswjf50mnfaaacmzi1lss8vgy63mrgzwi9v6yb4l";
   };
 
   makeFlags = [ "DESTDIR= BINDIR=$(out)/bin" ];
diff --git a/pkgs/applications/version-management/fossil/default.nix b/pkgs/applications/version-management/fossil/default.nix
index 299819a8a28f..1093bbe0d028 100644
--- a/pkgs/applications/version-management/fossil/default.nix
+++ b/pkgs/applications/version-management/fossil/default.nix
@@ -1,11 +1,15 @@
 {stdenv, fetchurl, zlib, openssl, tcl, readline, sqlite, withJson ? true}:
 
-stdenv.mkDerivation {
-  name = "fossil-1.30";
+stdenv.mkDerivation rec {
+  name = "fossil-1.32";
 
   src = fetchurl {
-    url = http://www.fossil-scm.org/download/fossil-src-20150119112900.tar.gz;
-    sha256 = "1p4jxd67m2a5rl85hb9gl0vxcvvkxnj1hd8yjaci2qf115d9x5ip";
+    urls = 
+      [
+        "https://www.fossil-scm.org/fossil/tarball/Fossil-6c40678e.tar.gz?uuid=6c40678e9114c41a50f73cc43f6f942ace0408ec"
+        ];
+    name = "${name}.tar.gz";
+    sha256 = "0f1rvqiy630z2q1q8r3kgdd0c6sxjx8c8pm46yabn238xvf3bfnr";
   };
 
   buildInputs = [ zlib openssl readline sqlite ];
diff --git a/pkgs/applications/version-management/git-and-tools/git/default.nix b/pkgs/applications/version-management/git-and-tools/git/default.nix
index 123bb65da8d8..65a9679576e0 100644
--- a/pkgs/applications/version-management/git-and-tools/git/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/default.nix
@@ -9,7 +9,7 @@
 }:
 
 let
-  version = "2.3.3";
+  version = "2.3.4";
   svn = subversionClient.override { perlBindings = true; };
 in
 
@@ -18,7 +18,7 @@ stdenv.mkDerivation {
 
   src = fetchurl {
     url = "https://www.kernel.org/pub/software/scm/git/git-${version}.tar.xz";
-    sha256 = "11s6w6dsv9kfgpfa75sas4pi6spw75ph0b0b6b12xq37hl4l8ma7";
+    sha256 = "15fv155skjy80j7sv7x4kxlj3m8i334bic4q2qmb6zvr04hjpslp";
   };
 
   patches = [