summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRenaud <c0bw3b@users.noreply.github.com>2018-11-03 10:40:08 +0100
committerGitHub <noreply@github.com>2018-11-03 10:40:08 +0100
commit722fcbbb80b2142583e9266efe77992f8e32ac4c (patch)
tree680b842bf198ba008126a9bacfd7585f96b5e015 /pkgs/applications
parentd9fa1f9178f8b745cfe35d6b6e7dc510e3f69832 (diff)
parentc8c77476dc32afd42b6ac511c9895db7d93b1bc9 (diff)
downloadnixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.tar
nixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.tar.gz
nixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.tar.bz2
nixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.tar.lz
nixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.tar.xz
nixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.tar.zst
nixlib-722fcbbb80b2142583e9266efe77992f8e32ac4c.zip
Merge pull request #49467 from CharlesHD/submit/cmusfm
cmusfm: init at 2018-10-11
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/cmusfm/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/applications/audio/cmusfm/default.nix b/pkgs/applications/audio/cmusfm/default.nix
new file mode 100644
index 000000000000..e528e9699a73
--- /dev/null
+++ b/pkgs/applications/audio/cmusfm/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, curl, libnotify, gdk_pixbuf }:
+
+stdenv.mkDerivation rec {
+  version = "2018-10-11";
+  name = "cmusfm-unstable-${version}";
+  src = fetchFromGitHub {
+    owner = "Arkq";
+    repo = "cmusfm";
+    rev = "ad2fd0aad3f4f1a25add1b8c2f179e8859885873";
+    sha256 = "0wpwdwgyrp64nvwc6shy0n387p31j6aw6cnmfi9x2y1jhl5hbv6b";
+  };
+  # building
+  configureFlags = [ "--enable-libnotify" ];
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+  buildInputs = [ curl libnotify gdk_pixbuf ];
+
+  meta = with stdenv.lib; {
+    description = "Last.fm and Libre.fm standalone scrobbler for the cmus music player";
+    longDescription = ''
+      Features:
+      + Listening now notification support
+      + Off-line played track cache for later submission
+      + POSIX ERE-based file name parser
+      + Desktop notification support (optionally)
+      + Customizable scrobbling service
+      + Small memory footprint
+      Configuration:
+      + run `cmusfm init` to generate configuration file under ~/.config/cmus/cmusfm.conf
+      + Inside cmus run `:set status_display_program=cmusfm` to set up cmusfm
+    '';
+    homepage = https://github.com/Arkq/cmusfm/;
+    maintainers = with stdenv.lib.maintainers; [ CharlesHD ];
+    license = licenses.gpl3Plus;
+    platforms = platforms.linux ++ platforms.darwin;
+  };
+}