summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-10-10 19:01:42 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-11-05 17:10:53 -0500
commit70d91badf57bbe4cd884e5da22b14662dd36009c (patch)
tree9a69666a2218d4574dbaf8fb852371b8685ae3ec /pkgs/applications
parent5ae8f18f4d8216ec987e0f63b7d2b9a416a4ca82 (diff)
downloadnixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.gz
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.bz2
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.lz
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.xz
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.tar.zst
nixlib-70d91badf57bbe4cd884e5da22b14662dd36009c.zip
treewide: Depend on stdenv.cc.bintools instead of binutils directly
One should do this when needed executables at build time. It is more
honest and cross-friendly than refering to binutils directly.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/jucipp/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/editors/jucipp/default.nix b/pkgs/applications/editors/jucipp/default.nix
index ae4f1e6ad525..3d623d3f3bda 100644
--- a/pkgs/applications/editors/jucipp/default.nix
+++ b/pkgs/applications/editors/jucipp/default.nix
@@ -1,7 +1,7 @@
 { config, stdenv, fetchgit, makeWrapper, gnome3, at_spi2_core, libcxx,
   boost, epoxy, cmake, aspell, llvmPackages, libgit2, pkgconfig, pcre,
   libXdmcp, libxkbcommon, libpthreadstubs, wrapGAppsHook, aspellDicts,
-  coreutils, glibc, dbus_libs, openssl, libxml2, gnumake, binutils, ctags }:
+  coreutils, glibc, dbus_libs, openssl, libxml2, gnumake, ctags }:
 
 with stdenv.lib;
 
@@ -65,7 +65,7 @@ stdenv.mkDerivation rec {
   postInstall = ''
     mv $out/bin/juci $out/bin/.juci
     makeWrapper "$out/bin/.juci" "$out/bin/juci" \
-      --set PATH "${stdenv.lib.makeBinPath [ ctags coreutils llvmPackages.clang.cc cmake gnumake binutils llvmPackages.clang ]}" \
+      --set PATH "${stdenv.lib.makeBinPath [ ctags coreutils llvmPackages.clang.cc cmake gnumake llvmPackages.clang.bintools llvmPackages.clang ]}" \
       --set NO_AT_BRIDGE 1 \
       --set ASPELL_CONF "dict-dir ${aspellDicts.en}/lib/aspell"
   '';