summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-09-04 00:48:20 +0200
committerGitHub <noreply@github.com>2018-09-04 00:48:20 +0200
commit6f91e44b6a7f668f6eadf60e2dc4ed4770d21145 (patch)
treea9909dbf5a9ffbaeab4c594474c5bad5eff87500 /pkgs/applications
parent6c8cea6315d98881d6183ae0df0e41380eb36cc4 (diff)
parentd5b0c4d5c2fb59316ee85125e9df49cb30b85b74 (diff)
downloadnixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.tar
nixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.tar.gz
nixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.tar.bz2
nixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.tar.lz
nixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.tar.xz
nixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.tar.zst
nixlib-6f91e44b6a7f668f6eadf60e2dc4ed4770d21145.zip
Merge pull request #45976 from rnhmjoj/imv
imv: 2.1.3 -> 3.0.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/imv/default.nix25
1 files changed, 16 insertions, 9 deletions
diff --git a/pkgs/applications/graphics/imv/default.nix b/pkgs/applications/graphics/imv/default.nix
index e9a0dccd30a9..9def3f16ad03 100644
--- a/pkgs/applications/graphics/imv/default.nix
+++ b/pkgs/applications/graphics/imv/default.nix
@@ -1,25 +1,32 @@
-{ stdenv, fetchgit, SDL2, SDL2_ttf, freeimage, fontconfig }:
+{ stdenv, fetchFromGitHub, SDL2, SDL2_ttf
+, freeimage, fontconfig, pkgconfig
+, asciidoc, docbook_xsl, libxslt, cmocka
+}:
 
 stdenv.mkDerivation rec {
   name = "imv-${version}";
-  version = "2.1.3";
+  version = "3.0.0";
 
-  src = fetchgit {
-    url = "https://github.com/eXeC64/imv.git";
-    rev = "e59d0e9e120f1dbde9ab068748a190e93978e5b7";
-    sha256 = "0j48dk1bcbh5541522qkn487637wcx104zckrnxa5g3nirfqa7r7";
+  src = fetchFromGitHub {
+    owner  = "eXeC64";
+    repo   = "imv";
+    rev    = "v${version}";
+    sha256 = "0j5aykdkm1g518ism5y5flhwxvjvl92ksq989fhl2wpnv0la82jp";
   };
 
-  buildInputs = [ SDL2 SDL2_ttf freeimage fontconfig ];
+  buildInputs = [
+    SDL2 SDL2_ttf freeimage fontconfig pkgconfig
+    asciidoc docbook_xsl libxslt cmocka
+  ];
 
-  configurePhase = "substituteInPlace Makefile --replace /usr $out";
+  installFlags = [ "PREFIX=$(out)" "CONFIGPREFIX=$(out)/etc" ];
 
   meta = with stdenv.lib; {
     description = "A command line image viewer for tiling window managers";
     homepage    = https://github.com/eXeC64/imv; 
     license     = licenses.gpl2;
     maintainers = with maintainers; [ rnhmjoj ];
-    platforms   = platforms.unix;
+    platforms   = [ "x86_64-linux" ];
   };
 }