summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEric Seidel <gridaphobe@gmail.com>2015-03-05 13:22:45 -0800
committerEric Seidel <gridaphobe@gmail.com>2015-03-05 13:22:45 -0800
commit6b60f3dcad95e441c7860b27739600ef8ffdae02 (patch)
tree7b93f1a415f06f5bc1091c6d8830435cf3bb031d /pkgs/applications
parentb6a3fd396e318d3f687b719a0e6994c115dcd9b5 (diff)
parent6e59fa4941f9067bdaaf7aa63658aefb56b7f575 (diff)
downloadnixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.tar
nixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.tar.gz
nixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.tar.bz2
nixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.tar.lz
nixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.tar.xz
nixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.tar.zst
nixlib-6b60f3dcad95e441c7860b27739600ef8ffdae02.zip
Merge pull request #6641 from oxij/emacs-ng
Somewhat more generic emacs packages' builder and a bunch of new emacs packages and metas
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/nyan-mode/default.nix31
-rw-r--r--pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch13
2 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix b/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
new file mode 100644
index 000000000000..ab94dbae9501
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
@@ -0,0 +1,31 @@
+{trivialBuild, fetchFromGitHub}:
+
+trivialBuild rec {
+  pname    = "nyan-mode";
+  version  = "20150128";
+
+  src = fetchFromGitHub {
+    owner  = "TeMPOraL";
+    repo   = pname;
+    rev    = "41faa2c809da7b2cb3e6f8fadefae3f338ced3f2";
+    sha256 = "1idaac7sjc8hhbf5zif61ncg1pvg28c0qfihavdx61albww0ll7f";
+  };
+
+  patches = [ ./directory.patch ];
+
+  preBuild = ''
+    substituteInPlace nyan-mode.el \
+      --replace "@OUT@" "$out/"
+  '';
+
+  postInstall = ''
+    cp -r img $out
+    cp -r mus $out
+  '';
+
+  meta = {
+    description = "An analog indicator of the position in the buffer";
+    homepage = https://github.com/TeMPOraL/nyan-mode/;
+    license = "GPLv3+";
+  };
+}
diff --git a/pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch b/pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch
new file mode 100644
index 000000000000..b471531ec34c
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch
@@ -0,0 +1,13 @@
+diff --git a/nyan-mode.el b/nyan-mode.el
+index 939a25a..3d0b983 100644
+--- a/nyan-mode.el
++++ b/nyan-mode.el
+@@ -106,7 +106,7 @@ This can be t or nil."
+   :group 'nyan)

+ 

+ 

+-(defconst +nyan-directory+ (file-name-directory (or load-file-name buffer-file-name)))

++(defconst +nyan-directory+ "@OUT@")

+ 

+ (defconst +nyan-cat-size+ 3)

+