summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-03-07 19:33:52 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-03-07 19:33:52 +0100
commit674c51af3c0f3f1c65e1975893fdf6438bc57f28 (patch)
tree3020861cf515bc567e191361357d42e11ac817ee /pkgs/applications
parentda437144fa4f446e91b5f7f78b55faa4d12de58a (diff)
parentd742d26b0d8c7125fb29417fcb40e2665e10100d (diff)
downloadnixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.tar
nixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.tar.gz
nixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.tar.bz2
nixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.tar.lz
nixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.tar.xz
nixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.tar.zst
nixlib-674c51af3c0f3f1c65e1975893fdf6438bc57f28.zip
Merge remote-tracking branch 'origin/master' into stdenv-updates
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/drumkv1/default.nix21
-rw-r--r--pkgs/applications/audio/jack-oscrolloscope/default.nix26
-rw-r--r--pkgs/applications/audio/mopidy/default.nix2
-rw-r--r--pkgs/applications/audio/mopidy/git.nix2
-rw-r--r--pkgs/applications/audio/samplv1/default.nix21
-rw-r--r--pkgs/applications/audio/synthv1/default.nix21
-rw-r--r--pkgs/applications/graphics/mypaint/default.nix35
-rw-r--r--pkgs/applications/misc/zathura/builder.sh12
-rw-r--r--pkgs/applications/misc/zathura/core/default.nix11
-rw-r--r--pkgs/applications/misc/zathura/default.nix10
-rw-r--r--pkgs/applications/misc/zathura/icon.xpm120
-rw-r--r--pkgs/applications/networking/browsers/chromium/sources.nix18
-rw-r--r--pkgs/applications/networking/p2p/transmission/default.nix17
-rw-r--r--pkgs/applications/version-management/git-and-tools/github-backup/default.nix8
-rw-r--r--pkgs/applications/video/mkvtoolnix/default.nix7
-rw-r--r--pkgs/applications/video/mplayer/default.nix5
16 files changed, 305 insertions, 31 deletions
diff --git a/pkgs/applications/audio/drumkv1/default.nix b/pkgs/applications/audio/drumkv1/default.nix
new file mode 100644
index 000000000000..7fdd04ce96b8
--- /dev/null
+++ b/pkgs/applications/audio/drumkv1/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchurl, jackaudio, libsndfile, lv2, qt4 }:
+
+stdenv.mkDerivation rec {
+  name = "drumkv1-${version}";
+  version = "0.3.2";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/drumkv1/${name}.tar.gz";
+    sha256 = "0bafg06iavri9dmg7hpz554kpqf1iv9crcdq46y4n4wyyxd7kajl";
+  };
+
+  buildInputs = [ jackaudio libsndfile lv2 qt4 ];
+
+  meta = with stdenv.lib; {
+    description = "An old-school drum-kit sampler synthesizer with stereo fx";
+    homepage = http://drumkv1.sourceforge.net/;
+    license = licenses.gpl2Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.goibhniu ];
+  };
+}
\ No newline at end of file
diff --git a/pkgs/applications/audio/jack-oscrolloscope/default.nix b/pkgs/applications/audio/jack-oscrolloscope/default.nix
new file mode 100644
index 000000000000..dbceb0a336c5
--- /dev/null
+++ b/pkgs/applications/audio/jack-oscrolloscope/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchurl, SDL, jackaudio, mesa, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "jack_oscrolloscope-${version}";
+  version = "0.7";
+
+  src = fetchurl {
+    url = "http://das.nasophon.de/download/${name}.tar.gz";
+    sha256 = "1pl55in0sj7h5r06n1v91im7d18pplvhbjhjm1fdl39zwnyxiash";
+  };
+
+  buildInputs = [ SDL jackaudio mesa pkgconfig ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mv jack_oscrolloscope $out/bin/
+  '';
+
+  meta = with stdenv.lib; { 
+    description = "A simple waveform viewer for JACK";
+    homepage = http://das.nasophon.de/jack_oscrolloscope;
+    license = licenses.gpl2;
+    maintainers = [ maintainers.goibhniu ];
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
diff --git a/pkgs/applications/audio/mopidy/default.nix b/pkgs/applications/audio/mopidy/default.nix
index 934669f225c6..d285c4b0e237 100644
--- a/pkgs/applications/audio/mopidy/default.nix
+++ b/pkgs/applications/audio/mopidy/default.nix
@@ -14,7 +14,7 @@ pythonPackages.buildPythonPackage rec {
   };
 
   propagatedBuildInputs = with pythonPackages; [
-   gst_python pygobject pykka pyspotify pylast
+   gst_python pygobject pykka pyspotify pylast cherrypy ws4py
   ];
 
   # python zip complains about old timestamps
diff --git a/pkgs/applications/audio/mopidy/git.nix b/pkgs/applications/audio/mopidy/git.nix
index 81728e646c3e..2b5e1627ac63 100644
--- a/pkgs/applications/audio/mopidy/git.nix
+++ b/pkgs/applications/audio/mopidy/git.nix
@@ -14,7 +14,7 @@ pythonPackages.buildPythonPackage rec {
   };
 
   propagatedBuildInputs = with pythonPackages; [
-   gst_python pygobject pykka pyspotify pylast
+   gst_python pygobject pykka pyspotify pylast cherrypy ws4py
   ];
 
   # python zip complains about old timestamps
diff --git a/pkgs/applications/audio/samplv1/default.nix b/pkgs/applications/audio/samplv1/default.nix
new file mode 100644
index 000000000000..584b23b6a01c
--- /dev/null
+++ b/pkgs/applications/audio/samplv1/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchurl, jackaudio, libsndfile, lv2, qt4 }:
+
+stdenv.mkDerivation rec {
+  name = "samplv1-${version}";
+  version = "0.3.2";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/samplv1/${name}.tar.gz";
+    sha256 = "1j6q3ywbdsyhskc60p7k8ph058ylrrmjmri3q1wr2d2akcaqvb7m";
+  };
+
+  buildInputs = [ jackaudio libsndfile lv2 qt4 ];
+
+  meta = with stdenv.lib; {
+    description = "An old-school all-digital polyphonic sampler synthesizer with stereo fx";
+    homepage = http://samplv1.sourceforge.net/;
+    license = licenses.gpl2Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.goibhniu ];
+  };
+}
\ No newline at end of file
diff --git a/pkgs/applications/audio/synthv1/default.nix b/pkgs/applications/audio/synthv1/default.nix
new file mode 100644
index 000000000000..aadce32dda41
--- /dev/null
+++ b/pkgs/applications/audio/synthv1/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchurl, qt4, jackaudio, lv2 }:
+
+stdenv.mkDerivation rec {
+  name = "synthv1-${version}";
+  version = "0.3.2";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/synthv1/${name}.tar.gz";
+    sha256 = "1230yf49qfw540yvp5n7sh6mf3k8590pzwc5mragd3nd6k6apgw9";
+  };
+
+  buildInputs = [ qt4 jackaudio lv2 ];
+
+  meta = with stdenv.lib; {
+    description = "An old-school 4-oscillator subtractive polyphonic synthesizer with stereo fx";
+    homepage = http://synthv1.sourceforge.net/;
+    license = licenses.gpl2Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.goibhniu ];
+  };
+}
\ No newline at end of file
diff --git a/pkgs/applications/graphics/mypaint/default.nix b/pkgs/applications/graphics/mypaint/default.nix
new file mode 100644
index 000000000000..a59498b8f141
--- /dev/null
+++ b/pkgs/applications/graphics/mypaint/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchurl, gettext, glib, gtk, json_c, lcms2, libpng
+, makeWrapper, pkgconfig, pygtk, python, pythonPackages, scons, swig
+}:
+
+stdenv.mkDerivation rec {
+  name = "mypaint-${version}";
+  version = "1.1.0";
+
+  src = fetchurl {
+    url = "http://download.gna.org/mypaint/${name}.tar.bz2";
+    sha256 = "0f7848hr65h909c0jkcx616flc0r4qh53g3kd1cgs2nr1pjmf3bq";
+  };
+
+  buildInputs = [ 
+    gettext glib gtk json_c lcms2 libpng makeWrapper pkgconfig pygtk
+    python scons swig
+  ];
+ 
+  propagatedBuildInputs = [ pythonPackages.numpy ];
+
+  buildPhase = "scons prefix=$out";
+
+  installPhase = ''
+    scons prefix=$out install
+    wrapProgram $out/bin/mypaint --prefix PYTHONPATH : $PYTHONPATH
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A graphics application for digital painters";
+    homepage = http://mypaint.intilinux.com;
+    license = licenses.gpl2Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.goibhniu ];
+  };
+}
diff --git a/pkgs/applications/misc/zathura/builder.sh b/pkgs/applications/misc/zathura/builder.sh
index 9ca45b2cc992..149481367b42 100644
--- a/pkgs/applications/misc/zathura/builder.sh
+++ b/pkgs/applications/misc/zathura/builder.sh
@@ -1,11 +1,21 @@
 source $stdenv/setup
 
 mkdir -pv $out/bin/
+mkdir -pv $out/share/
+mkdir -pv $out/share/applications/
+mkdir -pv $out/share/pixmaps/
 
 cat > $out/bin/zathura <<EOF
 #!/bin/sh
-exec $zathura --plugins-dir=$plugins_path "\$@"
+exec $zathura_core/bin/zathura --plugins-dir=$plugins_path "\$@"
 EOF
 
+cp -rv $zathura_core/share/man $out/share
+cp -rv $zathura_core/share/locale $out/share
+cp -rv $icon $out/share/pixmaps/pwmt.xpm
+
+cat $zathura_core/share/applications/zathura.desktop > $out/share/applications/zathura.desktop
+echo "Icon=pwmt" >> $out/share/applications/zathura.desktop
+
 chmod 755 $out/bin/zathura
 
diff --git a/pkgs/applications/misc/zathura/core/default.nix b/pkgs/applications/misc/zathura/core/default.nix
index f56becf4512a..a3726fd460de 100644
--- a/pkgs/applications/misc/zathura/core/default.nix
+++ b/pkgs/applications/misc/zathura/core/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, gtk, girara, gettext }:
+{ stdenv, fetchurl, pkgconfig, gtk, girara, gettext, docutils }:
 
 stdenv.mkDerivation rec {
 
@@ -13,7 +13,14 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ pkgconfig gtk girara gettext ];
 
-  makeFlags = "PREFIX=$(out)";
+  # Bug in zathura build system: we should remove empty manfiles in order them
+  # to be compiled properly
+  preBuild = ''
+    rm zathura.1
+    rm zathurarc.5
+  '';
+
+  makeFlags = [ "PREFIX=$(out)" "RSTTOMAN=${docutils}/bin/rst2man.py" "VERBOSE=1" ];
 
   meta = {
     homepage = http://pwmt.org/projects/zathura/;
diff --git a/pkgs/applications/misc/zathura/default.nix b/pkgs/applications/misc/zathura/default.nix
index b5e0092975c2..8bdc7865832d 100644
--- a/pkgs/applications/misc/zathura/default.nix
+++ b/pkgs/applications/misc/zathura/default.nix
@@ -1,4 +1,4 @@
-{ callPackage, pkgs }:
+{ callPackage, pkgs, fetchurl }:
 
 rec {
   inherit (pkgs) stdenv;
@@ -11,7 +11,9 @@ rec {
 
   zathura_ps = callPackage ./ps { };
 
-  zathuraWrapper = stdenv.mkDerivation rec {
+  zathuraWrapper = stdenv.mkDerivation {
+
+    inherit zathura_core;
 
     name = "zathura-${zathura_core.version}";
 
@@ -21,7 +23,7 @@ rec {
       zathura_ps
     ];
 
-    zathura = "${zathura_core}/bin/zathura";
+    icon = ./icon.xpm;
 
     builder = ./builder.sh;
 
@@ -36,7 +38,7 @@ rec {
       '';
       license = stdenv.lib.licenses.zlib;
       platforms = stdenv.lib.platforms.linux;
-      maintainers = [ stdenv.lib.maintainers.garbas ];
+      maintainers = [ stdenv.lib.maintainers.garbas stdenv.lib.maintainers.smironov ];
     };
   };
 }
diff --git a/pkgs/applications/misc/zathura/icon.xpm b/pkgs/applications/misc/zathura/icon.xpm
new file mode 100644
index 000000000000..a863c5ddb090
--- /dev/null
+++ b/pkgs/applications/misc/zathura/icon.xpm
@@ -0,0 +1,120 @@
+/* XPM */
+static char *freeimage[] = {
+/* width height num_colors chars_per_pixel */
+"16 16 96 2",
+/* colors */
+"   c #1e1e1e",
+" . c #222222",
+" X c #212121",
+" o c #535353",
+" O c #a4a4a4",
+" + c #202020",
+" @ c #252525",
+" # c #3c3c3c",
+" $ c #292929",
+" % c #979797",
+" & c #cccccc",
+" * c #303030",
+" = c #1f1f1f",
+" - c #494949",
+" ; c #dddddd",
+" : c #696969",
+" > c #232323",
+" , c #262626",
+" < c #adadad",
+" 1 c #bbbbbb",
+" 2 c #1d1d1d",
+" 3 c #1c1c1c",
+" 4 c #5e5e5e",
+" 5 c #e8e8e8",
+" 6 c #9c9c9c",
+" 7 c #242424",
+" 8 c #b1b1b1",
+" 9 c #b3b3b3",
+" 0 c #090909",
+" q c #161616",
+" w c #131313",
+" e c #4d4d4d",
+" r c #dedede",
+" t c #afafaf",
+" y c #282828",
+" u c #393939",
+" i c #c4c4c4",
+" p c #dcdcdc",
+" a c #9a9a9a",
+" s c #a2a2a2",
+" d c #ababab",
+" f c #313131",
+" g c #a7a7a7",
+" h c #e4e4e4",
+" j c #f2f2f2",
+" k c #eaeaea",
+" l c #e2e2e2",
+" z c #f0f0f0",
+" x c #d5d5d5",
+" c c #737373",
+" v c #323232",
+" b c #808080",
+" n c #7a7a7a",
+" m c #d3d3d3",
+" M c #e5e5e5",
+" N c #8a8a8a",
+" B c #cbcbcb",
+" V c #b5b5b5",
+" C c #b9b9b9",
+" Z c #272727",
+" A c #b4b4b4",
+" S c #bababa",
+" D c #2d2d2d",
+" F c #414141",
+" G c #444444",
+" H c #f4f4f4",
+" J c #838383",
+" K c #cfcfcf",
+" L c #fafafa",
+" P c #efefef",
+" I c #e3e3e3",
+" U c #8d8d8d",
+" Y c #656565",
+" T c #ffffff",
+" R c #fbfbfb",
+" E c #e9e9e9",
+" W c #bdbdbd",
+" Q c #e1e1e1",
+" ! c #dfdfdf",
+" ~ c #646464",
+" ^ c #3a3a3a",
+" / c #a1a1a1",
+" ( c #999999",
+" ) c #c0c0c0",
+" _ c #3b3b3b",
+" ` c #acacac",
+" ' c #050505",
+" ] c #151515",
+" [ c #1b1b1b",
+" { c #1a1a1a",
+" } c #b2b2b2",
+" | c #a5a5a5",
+".  c #c5c5c5",
+".. c #a6a6a6",
+".X c #bfbfbf",
+".o c #747474",
+/* pixels */
+"                                ",
+"   . . . X X X X . o O + X . .  ",
+"   . . X @ # $ . @ % & * = . .  ",
+"   . .   - ; : > , < 1 2 X . .  ",
+"   . . 3 4 5 6 7 7 8 9 0 q q 3  ",
+"   . + w e r t y u i p a s d 4  ",
+"   X f g h j k p l z z x g c v  ",
+"   X f b n m M N c B V 3 , > X  ",
+"   X X   w V C $ Z A S + $ , .  ",
+"   D F G u S H 1 J K L P I U @  ",
+"   Y T T T R E & W Q ! d g ~ 7  ",
+"   ^ / 6 ( ; ) _ 2 ` 8 ' ] [ X  ",
+"   + > 7 { A } 7 @ |.  $ + . .  ",
+"   X X X ].. 8 Z 7 n.X + X . .  ",
+"   . . . { n.o 7 . @ y X X . .  ",
+"                                "
+};
+
diff --git a/pkgs/applications/networking/browsers/chromium/sources.nix b/pkgs/applications/networking/browsers/chromium/sources.nix
index 9c483aa17029..a14b10fcfde7 100644
--- a/pkgs/applications/networking/browsers/chromium/sources.nix
+++ b/pkgs/applications/networking/browsers/chromium/sources.nix
@@ -1,18 +1,18 @@
 # This file is autogenerated from update.sh in the same directory.
 {
   dev = {
-    version = "26.0.1410.12";
-    url = "http://commondatastorage.googleapis.com/chromium-browser-official/chromium-26.0.1410.12.tar.xz";
-    sha256 = "1cfzvlldzgm53jwys5zbrd4rszkinsr4n5ky5rcg6p6nw73b4hmj";
+    version = "26.0.1410.28";
+    url = "http://commondatastorage.googleapis.com/chromium-browser-official/chromium-26.0.1410.28.tar.xz";
+    sha256 = "1g32xyh06xsqkli0g83flqr1qvx2yxb7vaqshf9wcyqgkyzvy7il";
   };
   beta = {
-    version = "26.0.1410.12";
-    url = "http://commondatastorage.googleapis.com/chromium-browser-official/chromium-26.0.1410.12.tar.xz";
-    sha256 = "1cfzvlldzgm53jwys5zbrd4rszkinsr4n5ky5rcg6p6nw73b4hmj";
+    version = "26.0.1410.28";
+    url = "http://commondatastorage.googleapis.com/chromium-browser-official/chromium-26.0.1410.28.tar.xz";
+    sha256 = "1g32xyh06xsqkli0g83flqr1qvx2yxb7vaqshf9wcyqgkyzvy7il";
   };
   stable = {
-    version = "25.0.1364.97";
-    url = "http://commondatastorage.googleapis.com/chromium-browser-official/chromium-25.0.1364.97.tar.bz2";
-    sha256 = "1r8khcic82m6g5i7669q8fxsfhjrlvp99iggqc5qpihljsz33ghm";
+    version = "25.0.1364.152";
+    url = "http://commondatastorage.googleapis.com/chromium-browser-official/chromium-25.0.1364.152.tar.bz2";
+    sha256 = "1v8zpqk3q21d5hars1clss75n187hlg4zxbr68jj1ysmqclzbni8";
   };
 }
diff --git a/pkgs/applications/networking/p2p/transmission/default.nix b/pkgs/applications/networking/p2p/transmission/default.nix
index 0a86e140347d..c59fddf6364b 100644
--- a/pkgs/applications/networking/p2p/transmission/default.nix
+++ b/pkgs/applications/networking/p2p/transmission/default.nix
@@ -1,20 +1,23 @@
-{ stdenv, fetchurl, pkgconfig, openssl, curl, intltool, libevent, gtkClient ? true, gtk }:
+{ stdenv, fetchurl, pkgconfig, openssl, curl, intltool, libevent,
+  file, inotifyTools, gtk ? null }:
 
 stdenv.mkDerivation rec {
-  name = "transmission-2.52";
+  name = "transmission-2.60"; # transmission >= 2.61 requires gtk3
 
   src = fetchurl {
     url = "http://download.transmissionbt.com/files/${name}.tar.xz";
-    sha256 = "05sfq5h3731xc9a1k5r1q4gbs9yk0dr229asfxjjgg0lw1xzppdw";
+    sha256 = "1ramdliyy8j7qqpkxg643lda11ynxwfhq6qcs31fr3h9x72l0rg4";
   };
 
-  buildInputs = [ pkgconfig openssl curl intltool libevent ] ++
-                stdenv.lib.optional gtkClient gtk;
+  buildInputs = [ pkgconfig openssl curl intltool libevent
+                  file inotifyTools gtk ];
 
-  configureFlags = if gtkClient then "--enable-gtk" else "--disable-gtk";
+  preConfigure = ''
+    sed -i -e 's|/usr/bin/file|${file}/bin/file|g' configure
+  '';
 
   postInstall = ''
-    rm $out/share/icons/hicolor/icon-theme.cache
+    rm -f $out/share/icons/hicolor/icon-theme.cache
   '';
 
   meta = {
diff --git a/pkgs/applications/version-management/git-and-tools/github-backup/default.nix b/pkgs/applications/version-management/git-and-tools/github-backup/default.nix
index a2489dbc6281..6897ef003ad5 100644
--- a/pkgs/applications/version-management/git-and-tools/github-backup/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/github-backup/default.nix
@@ -1,11 +1,15 @@
-{ cabal, extensibleExceptions, filepath, github, hslogger, IfElse
+{ cabal, fetchurl, extensibleExceptions, filepath, github, hslogger, IfElse
 , MissingH, mtl, network, prettyShow
 }:
 
 cabal.mkDerivation (self: {
   pname = "github-backup";
   version = "1.20120314";
-  sha256 = "07ilb6cg1kbz4id53l4m46wjxzs7yxcmpz6280ym6k885dras5v2";
+  src = fetchurl {
+    url = "https://github.com/joeyh/github-backup/archive/1.20120314.tar.gz";
+    sha256 = "0rmgkylsnxbry02g5bxq5af03azgydfz6dzyvqzbhnkwavhqdlqy";
+    name = "github-backup-${self.pname}.tar.gz";
+  };
   isLibrary = false;
   isExecutable = true;
   buildDepends = [
diff --git a/pkgs/applications/video/mkvtoolnix/default.nix b/pkgs/applications/video/mkvtoolnix/default.nix
index 1dc58607de06..c2563b5e298e 100644
--- a/pkgs/applications/video/mkvtoolnix/default.nix
+++ b/pkgs/applications/video/mkvtoolnix/default.nix
@@ -16,11 +16,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "mkvtoolnix-5.9.0";
+  name = "mkvtoolnix-6.1.0";
 
   src = fetchurl {
-    url = "http://www.bunkus.org/videotools/mkvtoolnix/sources/${name}.tar.bz2";
-    sha256 = "1qdxzi72w5p77brlpp7y7llsgzlvl4p8fk1kzg934cqw6cqza4yr";
+    url = "http://www.bunkus.org/videotools/mkvtoolnix/sources/${name}.tar.xz";
+    sha256 = "01k5al3886cyi97kynx5hf98z5p7mb8vd2m057gbp1k10zblcb9x";
   };
 
   buildInputs = [ libmatroska flac libvorbis file boost lzo xdg_utils expat wxGTK zlib ruby gettext pkgconfig curl ];
@@ -39,4 +39,3 @@ stdenv.mkDerivation rec {
     homepage = http://www.bunkus.org/videotools/mkvtoolnix/;
   };
 }
-
diff --git a/pkgs/applications/video/mplayer/default.nix b/pkgs/applications/video/mplayer/default.nix
index 0c22379c577e..d86b81be7563 100644
--- a/pkgs/applications/video/mplayer/default.nix
+++ b/pkgs/applications/video/mplayer/default.nix
@@ -152,6 +152,8 @@ stdenv.mkDerivation rec {
 
   NIX_LDFLAGS = stdenv.lib.optionalString x11Support "-lX11 -lXext";
 
+  installTargets = [ "install" ] ++ stdenv.lib.optional x11Support "install-gui";
+
   enableParallelBuilding = true;
 
   # Provide a reasonable standard font.  Maybe we should symlink here.
@@ -159,6 +161,9 @@ stdenv.mkDerivation rec {
     ''
       mkdir -p $out/share/mplayer
       cp ${freefont_ttf}/share/fonts/truetype/FreeSans.ttf $out/share/mplayer/subfont.ttf
+      if test -f $out/share/applications/mplayer.desktop ; then
+        echo "NoDisplay=True" >> $out/share/applications/mplayer.desktop
+      fi
     '';
 
   crossAttrs = {