summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authormarkuskowa <markus.kowalewski.uu@gmail.com>2017-12-09 01:45:29 -0800
committerJörg Thalheim <Mic92@users.noreply.github.com>2017-12-09 09:45:29 +0000
commit66da9b9f8fdfdb691d931afd975d7f2d8af7e32c (patch)
tree2f30e886a87817244ea0995b85c3aceb8c590808 /pkgs/applications
parentf0f64fb8f04d5ae235001f79e5f5907ad4a4f788 (diff)
downloadnixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.tar
nixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.tar.gz
nixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.tar.bz2
nixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.tar.lz
nixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.tar.xz
nixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.tar.zst
nixlib-66da9b9f8fdfdb691d931afd975d7f2d8af7e32c.zip
gpredict: init at 1.3 (#32436)
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/astronomy/gpredict/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/applications/science/astronomy/gpredict/default.nix b/pkgs/applications/science/astronomy/gpredict/default.nix
new file mode 100644
index 000000000000..148963d64c08
--- /dev/null
+++ b/pkgs/applications/science/astronomy/gpredict/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl, pkgconfig
+, gtk2-x11, glib, curl, goocanvas, intltool
+}:
+
+let
+  version = "1.3";
+in
+stdenv.mkDerivation {
+  name = "gpredict-${version}";
+
+  src = fetchurl {
+    url = "https://sourceforge.net/projects/gpredict/files/Gpredict/${version}/gpredict-${version}.tar.gz";
+    sha256 = "18ym71r2f5mwpnjcnrpwrk3py2f6jlqmj8hzp89wbcm1ipnvxxmh";
+  };
+
+  buildInputs = [ curl glib gtk2-x11 goocanvas ];
+  nativeBuildInputs = [ pkgconfig intltool ];
+
+  meta = with stdenv.lib; {
+    description = "Real time satellite tracking and orbit prediction";
+    longDescription = ''
+      Gpredict is a real time satellite tracking and orbit prediction program
+      written using the Gtk+ widgets. Gpredict is targetted mainly towards ham radio
+      operators but others interested in satellite tracking may find it useful as
+      well. Gpredict uses the SGP4/SDP4 algorithms, which are compatible with the
+      NORAD Keplerian elements.
+    '';
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    homepage = "https://sourceforge.net/projects/gpredict/";
+    maintainers = [ maintainers.markuskowa ];
+  };
+}