summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2014-04-21 10:11:48 +0200
committeraszlig <aszlig@redmoonstudios.org>2014-04-22 06:14:01 +0200
commit65fcb8d503f6be6a42fc55434b6608b866f12cfc (patch)
tree1ba31f6ea657e3cc244c3c8a4a53ddf3fed34cbb /pkgs/applications
parent28229d8ef13fdbdb82ffa46eae8badae9de7ac56 (diff)
downloadnixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.tar
nixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.tar.gz
nixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.tar.bz2
nixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.tar.lz
nixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.tar.xz
nixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.tar.zst
nixlib-65fcb8d503f6be6a42fc55434b6608b866f12cfc.zip
miro: Fix parsing of youtube feeds.
Youtube feeds now don't append a "sig" query string argument anymore, so
all those feeds would fail without this patch. For the latter, a pull
request already exists on upstream at pculture/miro#428, so I guess we
can drop our patch upon release of the next new upstream bugfix release.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/miro/default.nix2
-rw-r--r--pkgs/applications/video/miro/youtube-feeds.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/applications/video/miro/default.nix b/pkgs/applications/video/miro/default.nix
index 528eeff7e239..9c4b603095dc 100644
--- a/pkgs/applications/video/miro/default.nix
+++ b/pkgs/applications/video/miro/default.nix
@@ -22,6 +22,8 @@ buildPythonPackage rec {
   patches = [ ./gconf.patch ];
 
   postPatch = ''
+    patch -p1 -d .. < "${./youtube-feeds.patch}"
+
     sed -i -e 's/\$(shell which python)/python/' Makefile
     sed -i -e 's|/usr/bin/||' -e 's|/usr||' \
            -e 's/BUILD_TIME[^,]*/BUILD_TIME=0/' setup.py
diff --git a/pkgs/applications/video/miro/youtube-feeds.patch b/pkgs/applications/video/miro/youtube-feeds.patch
new file mode 100644
index 000000000000..1527fa6a5b62
--- /dev/null
+++ b/pkgs/applications/video/miro/youtube-feeds.patch
@@ -0,0 +1,15 @@
+diff --git a/lib/flashscraper.py b/lib/flashscraper.py
+index 323dbe4..d203b78 100644
+--- a/lib/flashscraper.py
++++ b/lib/flashscraper.py
+@@ -134,9 +134,7 @@ def _youtube_callback_step2(info, video_id, callback):
+         # strip url= from url=xxxxxx, strip trailer.  Strip duplicate params.
+         for fmt, stream_map_data in zip(fmt_list, stream_map):
+             stream_map = cgi.parse_qs(stream_map_data)
+-            url_base = stream_map['url'][0]
+-            sig_part = '&signature=' + stream_map['sig'][0]
+-            fmt_url_map[fmt] = url_base + sig_part
++            fmt_url_map[fmt] = stream_map['url'][0]
+ 
+         title = params.get("title", ["No title"])[0]
+         try: