summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2018-08-17 23:53:33 +0000
committerOrivej Desh <orivej@gmx.fr>2018-08-18 23:19:54 +0000
commit65663f883c4debc2067a11f202725759cedb4fd5 (patch)
tree55d207e980e0531786a9c90a8f6b70c0775b1743 /pkgs/applications
parent0ad3721616039fa009e487908d16bf7984302cbb (diff)
downloadnixlib-65663f883c4debc2067a11f202725759cedb4fd5.tar
nixlib-65663f883c4debc2067a11f202725759cedb4fd5.tar.gz
nixlib-65663f883c4debc2067a11f202725759cedb4fd5.tar.bz2
nixlib-65663f883c4debc2067a11f202725759cedb4fd5.tar.lz
nixlib-65663f883c4debc2067a11f202725759cedb4fd5.tar.xz
nixlib-65663f883c4debc2067a11f202725759cedb4fd5.tar.zst
nixlib-65663f883c4debc2067a11f202725759cedb4fd5.zip
msgpack: rename from libmsgpack
The project does not use the name "libmsgpack". It variously uses "msgpack" and
"msgpack-c", and "msgpackc" for the name of the library.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/neovim/default.nix4
-rw-r--r--pkgs/applications/editors/neovim/qt.nix10
-rw-r--r--pkgs/applications/networking/instant-messengers/ring-daemon/default.nix4
-rw-r--r--pkgs/applications/science/chemistry/pymol/default.nix4
4 files changed, 11 insertions, 11 deletions
diff --git a/pkgs/applications/editors/neovim/default.nix b/pkgs/applications/editors/neovim/default.nix
index a0a14e89860b..6690e4c9c1b9 100644
--- a/pkgs/applications/editors/neovim/default.nix
+++ b/pkgs/applications/editors/neovim/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, cmake, gettext, libmsgpack, libtermkey, libiconv
+{ stdenv, fetchFromGitHub, cmake, gettext, msgpack, libtermkey, libiconv
 , libuv, luaPackages, ncurses, pkgconfig
 , unibilium, xsel, gperf
 , libvterm-neovim
@@ -25,7 +25,7 @@ let
     buildInputs = [
       libtermkey
       libuv
-      libmsgpack
+      msgpack
       ncurses
       libvterm-neovim
       unibilium
diff --git a/pkgs/applications/editors/neovim/qt.nix b/pkgs/applications/editors/neovim/qt.nix
index 48f7b29f407f..de217cb60f3f 100644
--- a/pkgs/applications/editors/neovim/qt.nix
+++ b/pkgs/applications/editors/neovim/qt.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, cmake, doxygen, makeWrapper
-, libmsgpack, neovim, pythonPackages, qtbase }:
+, msgpack, neovim, pythonPackages, qtbase }:
 
 stdenv.mkDerivation rec {
   name = "neovim-qt-${version}";
@@ -13,12 +13,12 @@ stdenv.mkDerivation rec {
   };
 
   cmakeFlags = [
-    "-DMSGPACK_INCLUDE_DIRS=${libmsgpack}/include"
-    "-DMSGPACK_LIBRARIES=${libmsgpack}/lib/libmsgpackc.so"
+    "-DMSGPACK_INCLUDE_DIRS=${msgpack}/include"
+    "-DMSGPACK_LIBRARIES=${msgpack}/lib/msgpackc.so"
   ];
 
   buildInputs = with pythonPackages; [
-    neovim qtbase libmsgpack
+    neovim qtbase msgpack
   ] ++ (with pythonPackages; [
     jinja2 msgpack python
   ]);
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   preConfigure = ''
-    # avoid cmake trying to download libmsgpack
+    # avoid cmake trying to download msgpack
     echo "" > third-party/CMakeLists.txt
     # we rip out a number of tests that fail in the build env
     # the GUI tests will never work but the others should - they did before neovim 0.2.0
diff --git a/pkgs/applications/networking/instant-messengers/ring-daemon/default.nix b/pkgs/applications/networking/instant-messengers/ring-daemon/default.nix
index f858bb38dd19..168719bf0e4c 100644
--- a/pkgs/applications/networking/instant-messengers/ring-daemon/default.nix
+++ b/pkgs/applications/networking/instant-messengers/ring-daemon/default.nix
@@ -20,7 +20,7 @@
 , speex
 , boost
 , opendht
-, libmsgpack
+, msgpack
 , gnutls
 , zlib
 , jsoncpp
@@ -108,7 +108,7 @@ stdenv.mkDerivation rec {
     speex
     boost
     opendht
-    libmsgpack
+    msgpack
     gnutls
     zlib
     jsoncpp
diff --git a/pkgs/applications/science/chemistry/pymol/default.nix b/pkgs/applications/science/chemistry/pymol/default.nix
index e7dd04377be7..7b482d82e2fa 100644
--- a/pkgs/applications/science/chemistry/pymol/default.nix
+++ b/pkgs/applications/science/chemistry/pymol/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, makeDesktopItem
 , python3, python3Packages
-, glew, freeglut, libpng, libxml2, tk, freetype, libmsgpack }:
+, glew, freeglut, libpng, libxml2, tk, freetype, msgpack }:
 
 
 with stdenv.lib;
@@ -29,7 +29,7 @@ python3Packages.buildPythonApplication {
     sha256 = "1qpacd5w4r9a0nm5iqmkd92ym3ai00dp7v61cwd6jgakk6wfps3s";
   };
 
-  buildInputs = [ python3Packages.numpy glew freeglut libpng libxml2 tk freetype libmsgpack ];
+  buildInputs = [ python3Packages.numpy glew freeglut libpng libxml2 tk freetype msgpack ];
   NIX_CFLAGS_COMPILE = "-I ${libxml2.dev}/include/libxml2";
 
   installPhase = ''