summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorKevin Quick <quick@sparq.org>2017-07-06 21:31:38 -0700
committerKevin Quick <quick@sparq.org>2017-07-06 21:31:38 -0700
commit6387a7ec8bd626ffae610bc08d4bc441f9afef15 (patch)
tree581d14de56175fb9034582fdbd45d4156bcb92f8 /pkgs/applications
parent8ff05c85ee89bbb3241a194d85db2f37b057d178 (diff)
downloadnixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.tar
nixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.tar.gz
nixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.tar.bz2
nixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.tar.lz
nixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.tar.xz
nixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.tar.zst
nixlib-6387a7ec8bd626ffae610bc08d4bc441f9afef15.zip
Update yices to add libpoly/mcsat functionality and add soname target.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/logic/yices/default.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/pkgs/applications/science/logic/yices/default.nix b/pkgs/applications/science/logic/yices/default.nix
index cf5114b4a417..0ec7f93d26f5 100644
--- a/pkgs/applications/science/logic/yices/default.nix
+++ b/pkgs/applications/science/logic/yices/default.nix
@@ -1,12 +1,12 @@
-{ stdenv, fetchurl, gmp-static, gperf, autoreconfHook }:
+{ stdenv, fetchurl, gmp-static, gperf, autoreconfHook, libpoly }:
 
 stdenv.mkDerivation rec {
   name    = "yices-${version}";
   version = "2.5.1";
 
   src = fetchurl {
-    url = "http://yices.csl.sri.com/cgi-bin/yices2-newnewdownload.cgi?file=yices-${version}-src.tar.gz&accept=I+Agree";
-    name = "yices-${version}-src.tar.gz";
+    url = "http://yices.csl.sri.com/cgi-bin/yices2-newnewdownload.cgi?file=${name}-src.tar.gz&accept=I+Agree";
+    name = "${name}-src.tar.gz";
     sha256 = "1wfq6hcm54h0mqmbs1ip63i0ywlwnciav86sbzk3gafxyzg1nd0c";
   };
 
@@ -14,13 +14,19 @@ stdenv.mkDerivation rec {
 
   configureFlags = [ "--with-static-gmp=${gmp-static.out}/lib/libgmp.a"
                      "--with-static-gmp-include-dir=${gmp-static.dev}/include"
+                     "--enable-mcsat"
                    ];
-  buildInputs = [ gmp-static gperf autoreconfHook ];
+  buildInputs = [ gmp-static gperf autoreconfHook libpoly ];
 
   enableParallelBuilding = true;
   doCheck = true;
 
-  installPhase = ''make install LDCONFIG=true'';
+  # Includes a fix for the embedded soname being libyices.so.2.5, but
+  # only installing the libyices.so.2.5.1 file.
+  installPhase = ''
+      make install LDCONFIG=true
+      (cd $out/lib && ln -s -f libyices.so.2.5.1 libyices.so.2.5)
+  '';
 
   meta = with stdenv.lib; {
     description = "A high-performance theorem prover and SMT solver";