summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-03-27 01:27:32 -0500
committerWill Dietz <w@wdtz.org>2018-03-27 15:14:23 -0500
commit5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc (patch)
treec1d90ef5e690036ee00fca08d950c10147798c5e /pkgs/applications
parentdddf0314bc0b08e863628ab756ffe37c20f1985a (diff)
downloadnixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.tar
nixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.tar.gz
nixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.tar.bz2
nixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.tar.lz
nixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.tar.xz
nixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.tar.zst
nixlib-5ed0ae686b7fca2718076ef7c5ad58c9a44aefcc.zip
slim: musl patch
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/display-managers/slim/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/applications/display-managers/slim/default.nix b/pkgs/applications/display-managers/slim/default.nix
index 5d06c2221b34..5160e02963f2 100644
--- a/pkgs/applications/display-managers/slim/default.nix
+++ b/pkgs/applications/display-managers/slim/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, cmake, pkgconfig, xorg, libjpeg, libpng
+{ stdenv, fetchurl, fetchpatch, cmake, pkgconfig, xorg, libjpeg, libpng
 , fontconfig, freetype, pam, dbus_libs, makeWrapper }:
 
 stdenv.mkDerivation rec {
@@ -26,7 +26,10 @@ stdenv.mkDerivation rec {
       # Allow to set logfile to a special "/dev/stderr" in order to continue
       # logging to stderr and thus to the journal.
       ./no-logfile.patch
-    ];
+    ] ++ stdenv.lib.optional stdenv.hostPlatform.isMusl (fetchpatch {
+      url = "https://raw.githubusercontent.com/gentoo/musl/8eddda8072add075ebf56cf6d288bc1450d6b5f8/x11-misc/slim/files/slim-1.3.6-add-missing-libgen_h.patch";
+      sha256 = "0f82672s2r2cmdqfn2mbg3di76mbla9n0ik20p2gv4igi6p866xm";
+    });
 
   preConfigure = "substituteInPlace CMakeLists.txt --replace /lib $out/lib";