summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorvbgl <vbgl@users.noreply.github.com>2015-06-25 23:54:13 +0200
committervbgl <vbgl@users.noreply.github.com>2015-06-25 23:54:13 +0200
commit5c537f3bdd4542e5aaf979cef41b33bb2bb1116d (patch)
tree06273e3fb57666ec3fe6d639a73f7a3fcb6e9ff4 /pkgs/applications
parentacd978515b9c351abfa73bdc841355dd87ad07f9 (diff)
parent1d72ce49cf8d6c4d68360b113513d1d87ce66d61 (diff)
downloadnixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.tar
nixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.tar.gz
nixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.tar.bz2
nixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.tar.lz
nixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.tar.xz
nixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.tar.zst
nixlib-5c537f3bdd4542e5aaf979cef41b33bb2bb1116d.zip
Merge pull request #8296 from vbgl/ocamlp4
OCaml-4.02: fix ocamlbuild rules for camlp4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/logic/acgtk/default.nix9
-rw-r--r--pkgs/applications/science/logic/coq/8.3.nix4
-rw-r--r--pkgs/applications/science/math/glsurf/default.nix6
3 files changed, 12 insertions, 7 deletions
diff --git a/pkgs/applications/science/logic/acgtk/default.nix b/pkgs/applications/science/logic/acgtk/default.nix
index 41c6cf75f325..0fd90ac13b6e 100644
--- a/pkgs/applications/science/logic/acgtk/default.nix
+++ b/pkgs/applications/science/logic/acgtk/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, ocaml, findlib, dypgen, bolt, ansiterminal,
+{ stdenv, fetchurl, ocaml, findlib, dypgen, bolt, ansiterminal, camlp4,
   buildBytecode ? true,
   buildNative ? true,
   installExamples ? true,
@@ -22,11 +22,16 @@ stdenv.mkDerivation {
     sha256 = "1k1ldqg34bwmgdpmi9gry9czlsk85ycjxnkd25fhlf3mmgg4n9p6";
   };
 
-  buildInputs = [ ocaml findlib dypgen bolt ansiterminal ];
+  buildInputs = [ ocaml findlib dypgen bolt ansiterminal camlp4 ];
 
   patches = [ ./install-emacs-to-site-lisp.patch
               ./use-nix-ocaml-byteflags.patch ];
 
+  postPatch = stdenv.lib.optionalString (camlp4 != null) ''
+    substituteInPlace src/Makefile.master.in \
+      --replace "+camlp4" "${camlp4}/lib/ocaml/${getVersion ocaml}/site-lib/camlp4/"
+  '';
+
   # The bytecode executable is dependent on the dynamic library provided by
   # ANSITerminal. We can use the -dllpath flag of ocamlc (analogous to
   # -rpath) to make sure that ocamlrun is able to link the library at
diff --git a/pkgs/applications/science/logic/coq/8.3.nix b/pkgs/applications/science/logic/coq/8.3.nix
index 63aaa02e67a3..c59c4b062708 100644
--- a/pkgs/applications/science/logic/coq/8.3.nix
+++ b/pkgs/applications/science/logic/coq/8.3.nix
@@ -1,6 +1,6 @@
 # - coqide compilation can be disabled by setting lablgtk to null;
 
-{stdenv, fetchurl, ocaml, findlib, camlp5, ncurses, lablgtk ? null}:
+{ stdenv, make, fetchurl, ocaml, findlib, camlp5, ncurses, lablgtk ? null }:
 
 let 
   version = "8.3pl4";
@@ -21,7 +21,7 @@ stdenv.mkDerivation {
     sha256 = "17d3lmchmqir1rawnr52g78srg4wkd7clzpzfsivxc4y1zp6rwkr";
   };
 
-  buildInputs = [ ocaml findlib camlp5 ncurses lablgtk ];
+  buildInputs = [ make ocaml findlib camlp5 ncurses lablgtk ];
 
   prefixKey = "-prefix ";
 
diff --git a/pkgs/applications/science/math/glsurf/default.nix b/pkgs/applications/science/math/glsurf/default.nix
index 1439d327d6ec..2c09f572d125 100644
--- a/pkgs/applications/science/math/glsurf/default.nix
+++ b/pkgs/applications/science/math/glsurf/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchdarcs, ocaml, findlib,  lablgl, camlimages, mesa, freeglut, ocaml_mysql, mlgmp, mpfr, gmp, libtiff, libjpeg, libpng, giflib }:
+{ stdenv, fetchdarcs, ocaml, findlib,  lablgl, camlimages, mesa, freeglut, ocaml_mysql, mysql, mlgmp, mpfr, gmp, libtiff, libjpeg, libpng, giflib }:
 
 let
   ocaml_version = (builtins.parseDrvName ocaml.name).version;
@@ -10,11 +10,11 @@ stdenv.mkDerivation {
   src = fetchdarcs {
     url = "http://lama.univ-savoie.fr/~raffalli/GlSurf";
     rev = "3.3";
-    sha256 = ""; md5="";
+    sha256 = "0ljvvzz31j7l8rvsv63x1kj70nhw3al3k294m79hpmwjvym1mzfa";
   };
 
   buildInputs = [ ocaml findlib freeglut mesa
-  	          lablgl camlimages ocaml_mysql mlgmp mpfr gmp
+  	          lablgl camlimages ocaml_mysql mysql.lib mlgmp mpfr gmp
 		  libtiff libjpeg libpng giflib ];
 
   installPhase = ''