summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2014-01-21 00:12:55 +0000
committerJan Malakhovski <oxij@oxij.org>2015-03-03 16:02:17 +0000
commit59ebcccc59eea028494334e9a8c04de62ac80c13 (patch)
treec19945c8cd949f7223e353c4fecbd17cddbe7b7c /pkgs/applications
parent34e69a2572c7a09fb53fb4033cbfe2d7ef47ee66 (diff)
downloadnixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.tar
nixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.tar.gz
nixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.tar.bz2
nixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.tar.lz
nixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.tar.xz
nixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.tar.zst
nixlib-59ebcccc59eea028494334e9a8c04de62ac80c13.zip
add nyan-mode emacs package
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/nyan-mode/default.nix31
-rw-r--r--pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch13
2 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix b/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
new file mode 100644
index 000000000000..ab94dbae9501
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/nyan-mode/default.nix
@@ -0,0 +1,31 @@
+{trivialBuild, fetchFromGitHub}:
+
+trivialBuild rec {
+  pname    = "nyan-mode";
+  version  = "20150128";
+
+  src = fetchFromGitHub {
+    owner  = "TeMPOraL";
+    repo   = pname;
+    rev    = "41faa2c809da7b2cb3e6f8fadefae3f338ced3f2";
+    sha256 = "1idaac7sjc8hhbf5zif61ncg1pvg28c0qfihavdx61albww0ll7f";
+  };
+
+  patches = [ ./directory.patch ];
+
+  preBuild = ''
+    substituteInPlace nyan-mode.el \
+      --replace "@OUT@" "$out/"
+  '';
+
+  postInstall = ''
+    cp -r img $out
+    cp -r mus $out
+  '';
+
+  meta = {
+    description = "An analog indicator of the position in the buffer";
+    homepage = https://github.com/TeMPOraL/nyan-mode/;
+    license = "GPLv3+";
+  };
+}
diff --git a/pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch b/pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch
new file mode 100644
index 000000000000..b471531ec34c
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/nyan-mode/directory.patch
@@ -0,0 +1,13 @@
+diff --git a/nyan-mode.el b/nyan-mode.el
+index 939a25a..3d0b983 100644
+--- a/nyan-mode.el
++++ b/nyan-mode.el
+@@ -106,7 +106,7 @@ This can be t or nil."
+   :group 'nyan)

+ 

+ 

+-(defconst +nyan-directory+ (file-name-directory (or load-file-name buffer-file-name)))

++(defconst +nyan-directory+ "@OUT@")

+ 

+ (defconst +nyan-cat-size+ 3)

+