summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2015-07-31 15:28:26 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2015-07-31 15:28:26 +0300
commit5945655fd6fecaff19df5ad9f8946d2b764809c7 (patch)
tree4c36b0f6ed79f0abad773411cb9b7e35e13dcb9c /pkgs/applications
parent2ed604e566f40c3f379b932de339da8101d0c5a3 (diff)
parent219debbedd1609b6365bac1e381fdf55606cbbf6 (diff)
downloadnixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.tar
nixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.tar.gz
nixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.tar.bz2
nixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.tar.lz
nixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.tar.xz
nixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.tar.zst
nixlib-5945655fd6fecaff19df5ad9f8946d2b764809c7.zip
Merge pull request #9049 from AndersonTorres/cmatrix
cmatrix: init at 1.2a
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/cmatrix/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/applications/misc/cmatrix/default.nix b/pkgs/applications/misc/cmatrix/default.nix
new file mode 100644
index 000000000000..c7a76ef00a6a
--- /dev/null
+++ b/pkgs/applications/misc/cmatrix/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl, pkgconfig, ncurses }:
+
+let
+  version = "1.2a";
+in with stdenv.lib;
+stdenv.mkDerivation rec {
+
+  name = "cmatrix-${version}";
+
+  src = fetchurl{
+    url = "http://www.asty.org/cmatrix/dist/${name}.tar.gz";
+    sha256 = "0k06fw2n8nzp1pcdynhajp5prba03gfgsbj91bknyjr5xb5fd9hz";
+  };
+
+  buildInputs = [ pkgconfig ncurses ];
+
+  meta = {
+    description = "Simulates the falling characters theme from The Matrix movie";
+    longDescription = ''
+      CMatrix simulates the display from "The Matrix" and is based
+      on the screensaver from the movie's website.  
+    '';
+    homepage = http://www.asty.org/cmatrix/;
+    platforms = ncurses.meta.platforms;
+    maintainers = [ maintainers.AndersonTorres ];
+  };
+}