summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2017-12-19 04:38:26 +0100
committerJan Tojnar <jtojnar@gmail.com>2017-12-19 17:25:49 +0100
commit527f07586052eb2f1e318b67b3031afe8b5fec2b (patch)
tree58b55afbee7f451cc50abc7e79c7f15131dc087c /pkgs/applications
parent8eb81aa8305f38015e9f88b27a50528c516d6f7d (diff)
downloadnixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.tar
nixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.tar.gz
nixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.tar.bz2
nixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.tar.lz
nixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.tar.xz
nixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.tar.zst
nixlib-527f07586052eb2f1e318b67b3031afe8b5fec2b.zip
deepin-terminal: 2.6.1 → 2.9.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/deepin-terminal/default.nix35
1 files changed, 23 insertions, 12 deletions
diff --git a/pkgs/applications/misc/deepin-terminal/default.nix b/pkgs/applications/misc/deepin-terminal/default.nix
index 7f38e801c4cb..e08a2827b83a 100644
--- a/pkgs/applications/misc/deepin-terminal/default.nix
+++ b/pkgs/applications/misc/deepin-terminal/default.nix
@@ -1,31 +1,42 @@
-{ stdenv, unzip, fetchFromGitHub, pkgconfig, gtk3, vala, cmake, vte, libgee, wnck, gettext, libsecret, json_glib }:
+{ stdenv, fetchurl, fetchFromGitHub, pkgconfig, gtk3, vala, cmake, vte, libgee, wnck, zssh, gettext, librsvg, libsecret, json_glib }:
 
 stdenv.mkDerivation rec {
   name = "deepin-terminal-${version}";
-  version = "2.6.1";
+  version = "2.9.2";
 
   src = fetchFromGitHub {
     owner = "linuxdeepin";
     repo = "deepin-terminal";
     rev = version;
-    sha256 = "11lylkrv69k2jvwparnxymr7z3x9cs82q9p0lr2wrfr48hnfwp8b";
+    sha256 = "1pmg1acs44c30hz9rpr6x1l6lyvlylc2pz5lv4ai0rhv37n51yn2";
   };
 
-  patchPhase = ''
-  substituteInPlace project_path.c --replace __FILE__ \"$out/share/deepin-terminal/\"
+  patches = [
+    # Do not build vendored zssh and vte
+    (fetchurl {
+      name = "remove-vendor.patch";
+      url = https://git.archlinux.org/svntogit/community.git/plain/trunk/remove-vendor.patch?h=packages/deepin-terminal&id=5baa756e8e6ac8ce43fb122fce270756cc55086c;
+      sha256 = "0zrq004malphpy7xv5z502bpq30ybyj1rr4hlq4k5m4fpk29dlw6";
+    })
+  ];
+
+  postPatch = ''
+    substituteInPlace project_path.c --replace __FILE__ \"$out/share/deepin-terminal/\"
+    substituteInPlace ssh_login.sh --replace /usr/lib/deepin-terminal/zssh "${zssh}/bin/zssh"
   '';
 
-  nativeBuildInputs = [ pkgconfig vala cmake gettext unzip ];
-  buildInputs = [ gtk3 vte libgee wnck libsecret json_glib ];
+  nativeBuildInputs = [ pkgconfig vala cmake gettext ];
+  buildInputs = [ gtk3 vte libgee wnck librsvg libsecret json_glib ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "The default terminal emulation for Deepin";
     longDescription = ''
-        Deepin terminal, it sharpens your focus in the world of command line!
-        It is an advanced terminal emulator with workspace, multiple windows, remote management, quake mode and other features.
+      Deepin terminal, it sharpens your focus in the world of command line!
+      It is an advanced terminal emulator with workspace, multiple windows, remote management, quake mode and other features.
      '';
     homepage = https://github.com/linuxdeepin/deepin-terminal/;
-    license = stdenv.lib.licenses.gpl3;
-    platforms = stdenv.lib.platforms.linux;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ ];
+    platforms = platforms.linux;
   };
 }