summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArvin Moezzi <moezzia@gmail.com>2013-10-25 18:56:40 +0200
committerEvgeny Egorochkin <phreedom@yandex.ru>2013-10-26 12:48:08 +0300
commit4e604508584f534a11954cf1456f06bc2d29c9f6 (patch)
tree9c3c1b71931f21f2b31f2b035bce05944c5caedf /pkgs/applications
parent665c4882e8fb5df12ac6087ffd639c651790d5bb (diff)
downloadnixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.tar
nixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.tar.gz
nixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.tar.bz2
nixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.tar.lz
nixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.tar.xz
nixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.tar.zst
nixlib-4e604508584f534a11954cf1456f06bc2d29c9f6.zip
Package urlview 0.9-19
urlview extracts URLs from text.

Close #1118.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/urlview/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/applications/misc/urlview/default.nix b/pkgs/applications/misc/urlview/default.nix
new file mode 100644
index 000000000000..02d26f660019
--- /dev/null
+++ b/pkgs/applications/misc/urlview/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchurl, ncurses, automake111x, autoreconfHook }:
+
+stdenv.mkDerivation rec {
+  version    = "0.9";
+  patchLevel = "19";
+
+  name = "urlview-${version}-${patchLevel}";
+
+  urlBase = "mirror://debian/pool/main/u/urlview/";
+
+  src = fetchurl {
+    url = urlBase + "urlview_${version}.orig.tar.gz";
+    sha256 = "746ff540ccf601645f500ee7743f443caf987d6380e61e5249fc15f7a455ed42";
+  };
+
+  buildInputs = [ ncurses automake111x autoreconfHook ];
+
+  preAutoreconf = ''
+    touch NEWS
+  '';
+
+  preConfigure = ''
+    mkdir -p $out/share/man/man1
+  '';
+
+  debianPatches = fetchurl {
+    url = urlBase + "urlview_${version}-${patchLevel}.diff.gz";
+    sha256 = "056883c17756f849fb9235596d274fbc5bc0d944fcc072bdbb13d1e828301585";
+  };
+
+  patches = debianPatches;
+
+  meta = {
+    description = "Extract URLs from text";
+    homepage = http://packages.qa.debian.org/u/urlview.html;
+    licencse = stdenv.lib.licenses.gpl2;
+    platforms = stdenv.lib.platforms.linux;
+  };
+}