summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-01-16 04:56:08 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-01-16 04:56:08 +0100
commit4a860b8fbfb264d5a754f59113b23e4093a51b7a (patch)
tree4876af94f0b9e499dfd9c97754aee4547a6bd33e /pkgs/applications
parent8f793ce6bb050252e92a987cc3c5bd48d5423a42 (diff)
downloadnixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.tar
nixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.tar.gz
nixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.tar.bz2
nixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.tar.lz
nixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.tar.xz
nixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.tar.zst
nixlib-4a860b8fbfb264d5a754f59113b23e4093a51b7a.zip
copy-com: remove deprecated Nix-specific alias
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/copy-com/default.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/pkgs/applications/networking/copy-com/default.nix b/pkgs/applications/networking/copy-com/default.nix
index 968218309ed7..0ec2f5ac87a0 100644
--- a/pkgs/applications/networking/copy-com/default.nix
+++ b/pkgs/applications/networking/copy-com/default.nix
@@ -44,25 +44,19 @@ in stdenv.mkDerivation {
       patchelf --set-interpreter ${stdenv.glibc}/lib/${interpreter} "$binary"
     done
 
-    # Older versions of this package happily installed broken copies of
-    # anything other than CopyConsole - which was then also mangled to
-    # copy_console for some reason. Keep backwards compatibility (only
-    # for CopyConsole) for now; the NixOS service is already fixed.
-    ln -sv "$out/bin"/{CopyConsole,copy_console}
-
     RPATH=${libPaths}:$out/${appdir}
     echo "Updating rpaths to $RPATH in:"
     find "$out/${appdir}" -type f -a -perm -0100 \
       -print -exec patchelf --force-rpath --set-rpath "$RPATH" {} \;
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://copy.com;
     description = "Copy.com graphical & command-line clients";
     # Closed Source unfortunately.
-    license = stdenv.lib.licenses.unfree;
-    maintainers = with stdenv.lib.maintainers; [ nathan-gs nckx ];
+    license = licenses.unfree;
+    maintainers = with maintainers; [ nathan-gs nckx ];
     # NOTE: Copy.com itself only works on linux, so this is ok.
-    platforms = stdenv.lib.platforms.linux;
+    platforms = platforms.linux;
   };
 }