summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-06-22 13:20:37 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2018-06-22 13:20:37 +0200
commit48110c12956cdccc9aab638a489d2c96511fc41a (patch)
tree74e47861fc508c9f3ec7012c3fe5268572d5f6f2 /pkgs/applications
parent93a277ca60c024453982a0393f227e35f1374faf (diff)
parentdb0da282c374e0cf7ec9309cbb36bf7b5b5d8e54 (diff)
downloadnixlib-48110c12956cdccc9aab638a489d2c96511fc41a.tar
nixlib-48110c12956cdccc9aab638a489d2c96511fc41a.tar.gz
nixlib-48110c12956cdccc9aab638a489d2c96511fc41a.tar.bz2
nixlib-48110c12956cdccc9aab638a489d2c96511fc41a.tar.lz
nixlib-48110c12956cdccc9aab638a489d2c96511fc41a.tar.xz
nixlib-48110c12956cdccc9aab638a489d2c96511fc41a.tar.zst
nixlib-48110c12956cdccc9aab638a489d2c96511fc41a.zip
Merge staging into master
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/flent/default.nix7
-rw-r--r--pkgs/applications/networking/flent/http-getter.nix23
-rw-r--r--pkgs/applications/networking/instant-messengers/signal-desktop/default.nix4
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/default.nix1
-rw-r--r--pkgs/applications/version-management/git-and-tools/hub/default.nix39
-rw-r--r--pkgs/applications/virtualization/rancher-compose/default.nix44
-rw-r--r--pkgs/applications/window-managers/yabar/build.nix4
-rw-r--r--pkgs/applications/window-managers/yabar/default.nix14
8 files changed, 63 insertions, 73 deletions
diff --git a/pkgs/applications/networking/flent/default.nix b/pkgs/applications/networking/flent/default.nix
index 90ff868d6bec..2f97b39da60f 100644
--- a/pkgs/applications/networking/flent/default.nix
+++ b/pkgs/applications/networking/flent/default.nix
@@ -1,4 +1,6 @@
-{ stdenv, buildPythonApplication, fetchFromGitHub, matplotlib, netperf, procps, pyqt5 }:
+{ stdenv, buildPythonApplication, fetchFromGitHub, matplotlib, procps, pyqt5
+, sphinx
+}:
 
 buildPythonApplication rec {
   pname = "flent";
@@ -10,7 +12,8 @@ buildPythonApplication rec {
     sha256 = "1llcdakk0nk9xlpjjz7mv4a80yq4sjnbqhaqvyj9m6lbcxgssh2r";
   };
 
-  buildInputs = [ netperf ];
+  buildInputs = [ sphinx ];
+
   propagatedBuildInputs = [
     matplotlib
     procps
diff --git a/pkgs/applications/networking/flent/http-getter.nix b/pkgs/applications/networking/flent/http-getter.nix
new file mode 100644
index 000000000000..20557c18c52c
--- /dev/null
+++ b/pkgs/applications/networking/flent/http-getter.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchFromGitHub, cmake
+, curl, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "http-getter";
+  version = "20180606";
+
+  src = fetchFromGitHub {
+    owner = "tohojo";
+    repo = "http-getter";
+    rev = "79bcccce721825a745f089d0c347bbaf2e6e12f4";
+    sha256 = "1zxk52s1h5qx62idil237zdpj8agrry0w1xwkfx05wvv9sw4ld35";
+  };
+
+  buildInputs = [ cmake pkgconfig curl ];
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/tohojo/http-getter;
+    description = "Simple getter for HTTP URLs using cURL";
+    platforms = platforms.unix;
+    license = licenses.gpl3;
+  };
+}
diff --git a/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix b/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix
index 92a59fb31f10..89a3005b1279 100644
--- a/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix
+++ b/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix
@@ -40,11 +40,11 @@ let
 
 in stdenv.mkDerivation rec {
   name = "signal-desktop-${version}";
-  version = "1.12.1";
+  version = "1.13.0";
 
   src = fetchurl {
     url = "https://updates.signal.org/desktop/apt/pool/main/s/signal-desktop/signal-desktop_${version}_amd64.deb";
-    sha256 = "1p85hpk8kzzgncfm033bzpwm7hk6rrq8zdpwqlk5z2biarwjdqfx";
+    sha256 = "1iapkkfqssbjcksgic7i8x0cwp6gwcbbrfxlw7vp6k1cfvjwv9pf";
   };
 
   phases = [ "unpackPhase" "installPhase" ];
diff --git a/pkgs/applications/version-management/git-and-tools/git/default.nix b/pkgs/applications/version-management/git-and-tools/git/default.nix
index ceec9f1e75b6..4e9b7d2428de 100644
--- a/pkgs/applications/version-management/git-and-tools/git/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/default.nix
@@ -109,6 +109,7 @@ stdenv.mkDerivation {
   preInstall = stdenv.lib.optionalString stdenv.isDarwin ''
     mkdir -p $out/bin
     cp -a $PWD/contrib/credential/osxkeychain/git-credential-osxkeychain $out/bin
+    rm -f $PWD/contrib/credential/osxkeychain/git-credential-osxkeychain.o
   '';
 
   postInstall =
diff --git a/pkgs/applications/version-management/git-and-tools/hub/default.nix b/pkgs/applications/version-management/git-and-tools/hub/default.nix
index 1a6e8bc56f40..c9f666390b55 100644
--- a/pkgs/applications/version-management/git-and-tools/hub/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/hub/default.nix
@@ -1,38 +1,35 @@
-{ stdenv, fetchgit, go, ronn, groff, utillinux, Security }:
+{ stdenv, buildGoPackage, fetchFromGitHub, go, ronn, ruby, groff, Security, utillinux }:
 
-stdenv.mkDerivation rec {
+buildGoPackage rec {
   name = "hub-${version}";
   version = "2.4.0";
 
-  src = fetchgit {
-    url = https://github.com/github/hub.git;
-    rev = "refs/tags/v${version}";
+  goPackagePath = "github.com/github/hub";
+
+  src = fetchFromGitHub {
+    owner = "github";
+    repo = "hub";
+    rev = "v${version}";
     sha256 = "1lr6vg0zhg2air9bnzcl811g97jraxq05l3cs46wqqflwy57xpz2";
   };
 
+  buildInputs = [ groff ronn ruby utillinux ] ++
+    stdenv.lib.optional stdenv.isDarwin Security;
 
-  buildInputs = [ go ronn groff utillinux ]
-    ++ stdenv.lib.optional stdenv.isDarwin Security;
-
-  buildPhase = ''
+  postPatch = ''
     mkdir bin
     ln -s ${ronn}/bin/ronn bin/ronn
-
     patchShebangs .
-    make all man-pages
   '';
 
-  installPhase = ''
-    prefix=$out sh -x < script/install.sh
-
-    mkdir -p "$out/share/zsh/site-functions"
-    cp "etc/hub.zsh_completion" "$out/share/zsh/site-functions/_hub"
-
-    mkdir -p "$out/etc/bash_completion.d"
-    cp "etc/hub.bash_completion.sh" "$out/etc/bash_completion.d/"
+  postInstall = ''
+    cd go/src/${goPackagePath}
+    install -D etc/hub.zsh_completion "$bin/share/zsh/site-functions/_hub"
+    install -D etc/hub.bash_completion.sh "$bin/etc/bash_completion.d/hub.bash_completion.sh"
+    install -D etc/hub.fish_completion  "$bin/share/fish/vendor_completions.d/hub.fish"
 
-    # Should we also install provided git-hooks?
-    # And fish completion?
+    make man-pages
+    cp -r share/man $bin/share/man
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/virtualization/rancher-compose/default.nix b/pkgs/applications/virtualization/rancher-compose/default.nix
deleted file mode 100644
index 57aa6809d6c1..000000000000
--- a/pkgs/applications/virtualization/rancher-compose/default.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ lib, buildGoPackage, fetchFromGitHub }:
-
-let
-  generic = { version, sha256 }: buildGoPackage rec {
-    name = "rancher-compose-${version}";
-
-    goPackagePath = "github.com/rancher/rancher-compose";
-
-    src = fetchFromGitHub {
-      owner = "rancher";
-      repo = "rancher-compose";
-      rev = "v${version}";
-      inherit sha256;
-    };
-
-    buildFlagsArray = ''
-      -ldflags=
-          -X github.com/rancher/rancher-compose/version.VERSION=${version}
-    '';
-
-    excludedPackages = "scripts";
-
-    meta = with lib; {
-      description = "Docker compose compatible client to deploy to Rancher";
-      homepage = https://docs.rancher.com/rancher/rancher-compose/;
-      license = licenses.asl20;
-      platforms = platforms.unix;
-      maintainers = [maintainers.mic92];
-    };
-  };
-in {
-  # should point to a version compatible
-  # with the latest stable release of rancher
-  rancher-compose = generic {
-    version = "0.9.2";
-    sha256 = "1wlsdjaa4j2b3c034hb6zci5h900b1msimmshz5h4g5hiaqb3khq";
-  };
-
-  # for rancher v1.2.0-pre3+
-  rancher-compose_0_10 = generic {
-    version = "0.10.0";
-    sha256 = "17f3ya4qq0dzk4wvhgxp0lh9p8c87kpq7hmh3g21ashzqwmcflxl";
-  };
-}
diff --git a/pkgs/applications/window-managers/yabar/build.nix b/pkgs/applications/window-managers/yabar/build.nix
index a5d02093e3f6..6fc1797dd251 100644
--- a/pkgs/applications/window-managers/yabar/build.nix
+++ b/pkgs/applications/window-managers/yabar/build.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchFromGitHub, cairo, gdk_pixbuf, libconfig, pango, pkgconfig
 , xcbutilwm, alsaLib, wirelesstools, asciidoc, libxslt, makeWrapper, docbook_xsl
 , configFile ? null, lib
-, rev, sha256, version
+, rev, sha256, version, patches ? []
 }:
 
 stdenv.mkDerivation {
@@ -14,6 +14,8 @@ stdenv.mkDerivation {
     repo  = "yabar";
   };
 
+  inherit patches;
+
   hardeningDisable = [ "format" ];
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/applications/window-managers/yabar/default.nix b/pkgs/applications/window-managers/yabar/default.nix
index 4d42e3082f35..a33a75676ee9 100644
--- a/pkgs/applications/window-managers/yabar/default.nix
+++ b/pkgs/applications/window-managers/yabar/default.nix
@@ -1,10 +1,18 @@
-{ callPackage, attrs ? {} }:
+{ callPackage, attrs ? {}, fetchpatch }:
 
 let
-  overrides = {
+  overrides = rec {
     version = "0.4.0";
 
-    rev = "746387f0112f9b7aa2e2e27b3d69cb2892d8c63b";
+    rev = version;
     sha256 = "1nw9dar1caqln5fr0dqk7dg6naazbpfwwzxwlkxz42shsc3w30a6";
+
+    patches = [
+      (fetchpatch {
+        url = "https://github.com/geommer/yabar/commit/9779a5e04bd6e8cdc1c9fcf5d7ac31416af85a53.patch";
+        sha256 = "1szhr3k1kq6ixgnp74wnzgfvgxm6r4zpc3ny2x2wzy6lh2czc07s";
+      })
+    ];
+
   } // attrs;
 in callPackage ./build.nix overrides