summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2014-06-21 09:20:46 -0700
committerJohn Wiegley <johnw@newartisans.com>2014-06-21 09:20:46 -0700
commit476700d56f25122aaea0f2bc657b2d396e3b97bd (patch)
treedf48da5f55968387b2a7157c3017c983aa985502 /pkgs/applications
parenta9868357181a9e8c186d3f6e8c1dd860814586ee (diff)
downloadnixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.tar
nixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.tar.gz
nixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.tar.bz2
nixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.tar.lz
nixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.tar.xz
nixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.tar.zst
nixlib-476700d56f25122aaea0f2bc657b2d396e3b97bd.zip
git-annex: Build on Darwin, let Cabal determine proper flags
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-annex/default.nix25
1 files changed, 10 insertions, 15 deletions
diff --git a/pkgs/applications/version-management/git-and-tools/git-annex/default.nix b/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
index 72f00bbad2ef..8c2ee6a49448 100644
--- a/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git-annex/default.nix
@@ -11,6 +11,7 @@
 , tastyHunit, tastyQuickcheck, tastyRerun, text, time, transformers
 , unixCompat, utf8String, uuid, wai, waiExtra, warp, warpTls, which
 , xmlTypes, yesod, yesodCore, yesodDefault, yesodForm, yesodStatic
+, fsnotify
 }:
 
 cabal.mkDerivation (self: {
@@ -21,9 +22,9 @@ cabal.mkDerivation (self: {
   isExecutable = true;
   buildDepends = [
     aeson async blazeBuilder bloomfilter byteable caseInsensitive
-    clientsession cryptoApi cryptohash dataDefault dataenc DAV dbus
-    dlist dns editDistance exceptions extensibleExceptions fdoNotify
-    feed filepath gnutls hamlet hinotify hS3 hslogger HTTP httpClient
+    clientsession cryptoApi cryptohash dataDefault dataenc DAV
+    dlist dns editDistance exceptions extensibleExceptions
+    feed filepath gnutls hamlet hS3 hslogger HTTP httpClient
     httpConduit httpTypes IfElse json liftedBase MissingH monadControl
     mtl network networkConduit networkInfo networkMulticast
     networkProtocolXmpp optparseApplicative QuickCheck random regexTdfa
@@ -31,19 +32,13 @@ cabal.mkDerivation (self: {
     tastyQuickcheck tastyRerun text time transformers unixCompat
     utf8String uuid wai waiExtra warp warpTls xmlTypes yesod yesodCore
     yesodDefault yesodForm yesodStatic
-  ];
+  ] ++ (if (!self.stdenv.isDarwin) then [
+    dbus fdoNotify hinotify
+  ] else [
+    fsnotify
+  ]);
   buildTools = [ bup curl git gnupg1 lsof openssh perl rsync which ];
-  configureFlags = "-fS3
-                    -fWebDAV
-                    -fInotify
-                    -fDbus
-                    -fAssistant
-                    -fWebapp
-                    -fPairing
-                    -fXMPP
-                    -fDNS
-                    -fProduction
-                    -fTDFA";
+  configureFlags = "-fAssistant -fProduction";
   preConfigure = ''
     export HOME="$NIX_BUILD_TOP/tmp"
     mkdir "$HOME"