summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-25 00:41:55 -0500
committerGitHub <noreply@github.com>2018-04-25 00:41:55 -0500
commit42c87d4716ebab88db1e7bd388dc24c37689c73d (patch)
tree9ee0f7b2ceda8f44f64305f17e0076fd79569e46 /pkgs/applications
parent304c3ebc6d8f6db72035413c95dde6537465b640 (diff)
parenta4ba8c654403c1f1e6ba006533e3306dd32a638e (diff)
downloadnixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.tar
nixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.tar.gz
nixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.tar.bz2
nixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.tar.lz
nixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.tar.xz
nixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.tar.zst
nixlib-42c87d4716ebab88db1e7bd388dc24c37689c73d.zip
Merge pull request #39439 from Ma27/fix-free-clementine-plugin-path
clementine: each output should hav a wrapped `GST_PLUGIN_SYSTEM_PATH_1_0`
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/clementine/default.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/pkgs/applications/audio/clementine/default.nix b/pkgs/applications/audio/clementine/default.nix
index b8ff3daec606..6379975e951c 100644
--- a/pkgs/applications/audio/clementine/default.nix
+++ b/pkgs/applications/audio/clementine/default.nix
@@ -70,7 +70,9 @@ let
 
   free = stdenv.mkDerivation {
     name = "clementine-free-${version}";
-    inherit src patches nativeBuildInputs buildInputs postPatch;
+    inherit src patches nativeBuildInputs postPatch;
+
+    buildInputs = buildInputs ++ [ makeWrapper ];
 
     cmakeFlags = [ "-DUSE_SYSTEM_PROJECTM=ON" ];
 
@@ -78,6 +80,11 @@ let
 
     passthru.unfree = unfree;
 
+    postInstall = ''
+      wrapProgram $out/bin/clementine \
+        --prefix GST_PLUGIN_SYSTEM_PATH_1_0 : "$GST_PLUGIN_SYSTEM_PATH_1_0"
+    '';
+
     meta = with stdenv.lib; {
       homepage = http://www.clementine-player.org;
       description = "A multiplatform music player";
@@ -108,8 +115,7 @@ let
       rmdir $out/bin
 
       makeWrapper ${free}/bin/clementine $out/bin/clementine \
-        --set CLEMENTINE_SPOTIFYBLOB $out/libexec/clementine \
-        --prefix GST_PLUGIN_SYSTEM_PATH_1_0 : "$GST_PLUGIN_SYSTEM_PATH_1_0"
+        --set CLEMENTINE_SPOTIFYBLOB $out/libexec/clementine
 
       mkdir -p $out/share
       for dir in applications icons kde4; do