summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-09-25 14:24:24 -0500
committerWill Dietz <w@wdtz.org>2018-09-25 15:13:15 -0500
commit3ede6674a675fb05ad3b29bde28cd179c422a8e7 (patch)
treecc8d8012705d2a1b721a25c9babd6c07401ae6cd /pkgs/applications
parent332a7ec57f15876c73b8ddd7a5fc6d101f9f0105 (diff)
downloadnixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.tar
nixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.tar.gz
nixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.tar.bz2
nixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.tar.lz
nixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.tar.xz
nixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.tar.zst
nixlib-3ede6674a675fb05ad3b29bde28cd179c422a8e7.zip
spectral: init at 2018-09-24
* needs at least qtgraphicaleffects not mentioned in docs
* doesn't want to use our libqmatrixclient, so let it use bundled
* took a few runs (or perhaps just patience with one) to populate,
  when my profile icon appeared it seemed ready-- then click it
  to see list of rooms and such.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/spectral/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/applications/networking/instant-messengers/spectral/default.nix b/pkgs/applications/networking/instant-messengers/spectral/default.nix
new file mode 100644
index 000000000000..5dd8bf5f69ab
--- /dev/null
+++ b/pkgs/applications/networking/instant-messengers/spectral/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchgit
+, pkgconfig
+, qmake, qtbase, qtquickcontrols2, qtmultimedia
+, libpulseaudio
+# Not mentioned but seems needed
+, qtgraphicaleffects
+# Unsure but needed by similar
+, qtdeclarative, qtsvg
+}:
+
+stdenv.mkDerivation rec {
+  name = "spectral-${version}";
+  version = "2018-09-24";
+
+  src = fetchgit {
+    url = "https://gitlab.com/b0/spectral.git";
+    rev = "c9d1d6887722860a52b597a0f74d0ce39c8622e1";
+    sha256 = "1ym8jlqls4lcq5rd81vxw1dni79fc6ph00ip8nsydl6i16fngl4c";
+    fetchSubmodules = true;
+  };
+
+  nativeBuildInputs = [ pkgconfig qmake ];
+  buildInputs = [ qtbase qtquickcontrols2 qtmultimedia qtgraphicaleffects qtdeclarative qtsvg ]
+    ++ stdenv.lib.optional stdenv.hostPlatform.isLinux libpulseaudio;
+
+  meta = with stdenv.lib; {
+    description = "A glossy client for Matrix, written in QtQuick Controls 2 and C++";
+    homepage = https://gitlab.com/b0/spectral;
+    license = licenses.gpl3;
+    platforms = with platforms; linux ++ darwin;
+    maintainers = with maintainers; [ dtzWill ];
+  };
+}