summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-03-12 23:19:20 +0000
committerGitHub <noreply@github.com>2018-03-12 23:19:20 +0000
commit3c18afa091b75766251ecf085e0b1bc6ab371715 (patch)
tree1d1786a29968949bceb1a9e52fb80e8f94a9b661 /pkgs/applications
parentcede10322066634736735867a269fdcaa6ca8aba (diff)
parent58b7f17a0f9e21ac63d2b79736709d7a66701372 (diff)
downloadnixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.tar
nixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.tar.gz
nixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.tar.bz2
nixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.tar.lz
nixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.tar.xz
nixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.tar.zst
nixlib-3c18afa091b75766251ecf085e0b1bc6ab371715.zip
Merge pull request #36666 from xeji/codeblocks
codeblocks: 16.01 -> 17.12, fix build
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/codeblocks/default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/pkgs/applications/editors/codeblocks/default.nix b/pkgs/applications/editors/codeblocks/default.nix
index 20c2623e034c..72642cfbe63f 100644
--- a/pkgs/applications/editors/codeblocks/default.nix
+++ b/pkgs/applications/editors/codeblocks/default.nix
@@ -6,12 +6,12 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "${pname}-${stdenv.lib.optionalString contribPlugins "full-"}${version}";
-  version = "16.01";
+  version = "17.12";
   pname = "codeblocks";
 
   src = fetchurl {
-    url = "mirror://sourceforge/codeblocks/Sources/${version}/codeblocks_${version}.tar.gz";
-    sha256 = "00sskm91r20ywydwqwx6v7z3nwn9lyh5297c5wp3razldlh9vyrh";
+    url = "mirror://sourceforge/codeblocks/Sources/${version}/codeblocks_${version}.tar.xz";
+    sha256 = "1q2pph7md1p10i83rir2l4gvy7ym2iw8w6sk5vl995knf851m20k";
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig libtool file zip ];
@@ -22,11 +22,7 @@ stdenv.mkDerivation rec {
   preConfigure = "substituteInPlace ./configure --replace /usr/bin/file ${file}/bin/file";
   postConfigure = optionalString stdenv.isLinux "substituteInPlace libtool --replace ldconfig ${stdenv.cc.libc.bin}/bin/ldconfig";
   configureFlags = [ "--enable-pch=no" ]
-    ++ optional contribPlugins "--with-contrib-plugins";
-
-  # Fix boost 1.59 compat
-  # Try removing in the next version
-  #CPPFLAGS = "-DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED";
+    ++ optional contribPlugins [ "--with-contrib-plugins" "--with-boost-libdir=${boost}/lib" ];
 
   meta = {
     maintainers = [ maintainers.linquize ];