summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2014-06-21 09:22:29 -0700
committerJohn Wiegley <johnw@newartisans.com>2014-06-21 09:22:29 -0700
commit3b267d77a8fae04fa2cb1bad1da5461448cbcfaa (patch)
tree14761922b276f4c58fd495c60c080fd367b39d39 /pkgs/applications
parent476700d56f25122aaea0f2bc657b2d396e3b97bd (diff)
parent073933101e7aa47eb8756dc0b4385bd46a436c70 (diff)
downloadnixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.tar
nixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.tar.gz
nixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.tar.bz2
nixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.tar.lz
nixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.tar.xz
nixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.tar.zst
nixlib-3b267d77a8fae04fa2cb1bad1da5461448cbcfaa.zip
Merge pull request #3031 from jwiegley/proofgeneral
proofgeneral_4_3_pre: Add expression needed for current prooftree
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/proofgeneral/4.2.nix (renamed from pkgs/applications/editors/emacs-modes/proofgeneral/default.nix)2
-rw-r--r--pkgs/applications/editors/emacs-modes/proofgeneral/4.3pre.nix48
2 files changed, 49 insertions, 1 deletions
diff --git a/pkgs/applications/editors/emacs-modes/proofgeneral/default.nix b/pkgs/applications/editors/emacs-modes/proofgeneral/4.2.nix
index 3f974423fd70..0dea1a13977e 100644
--- a/pkgs/applications/editors/emacs-modes/proofgeneral/default.nix
+++ b/pkgs/applications/editors/emacs-modes/proofgeneral/4.2.nix
@@ -49,6 +49,6 @@ stdenv.mkDerivation (rec {
     '';
     homepage = http://proofgeneral.inf.ed.ac.uk;
     license = "GPLv2+";
-    platforms = stdenv.lib.platforms.gnu;  # arbitrary choice
+    platforms = stdenv.lib.platforms.unix;  # arbitrary choice
   };
 })
diff --git a/pkgs/applications/editors/emacs-modes/proofgeneral/4.3pre.nix b/pkgs/applications/editors/emacs-modes/proofgeneral/4.3pre.nix
new file mode 100644
index 000000000000..3a492dc0c7f4
--- /dev/null
+++ b/pkgs/applications/editors/emacs-modes/proofgeneral/4.3pre.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchurl, emacs, texinfo, texLive, perl, which, automake }:
+
+stdenv.mkDerivation (rec {
+  name = "ProofGeneral-4.3pre131011";
+
+  src = fetchurl {
+    url = http://proofgeneral.inf.ed.ac.uk/releases/ProofGeneral-4.3pre131011.tgz;
+    sha256 = "0104iy2xik5npkdg9p2ir6zqyrmdc93azrgm3ayvg0z76vmnb816";
+  };
+
+  sourceRoot = name;
+
+  buildInputs = [ emacs texinfo texLive perl which ];
+
+  prePatch =
+    '' sed -i "Makefile" \
+           -e "s|^\(\(DEST_\)\?PREFIX\)=.*$|\1=$out|g ; \
+               s|/sbin/install-info|install-info|g"
+
+
+       sed -i "bin/proofgeneral" -e's/which/type -p/g'
+
+       # @image{ProofGeneral} fails, so remove it.
+       sed -i '94d' doc/PG-adapting.texi
+       sed -i '96d' doc/ProofGeneral.texi
+    '';
+
+  preBuild = ''
+    make clean;
+  '';
+
+  installPhase =
+    # Copy `texinfo.tex' in the right place so that `texi2pdf' works.
+    '' cp -v "${automake}/share/"automake-*/texinfo.tex doc
+       make install install-doc
+    '';
+
+  meta = {
+    description = "Proof General, an Emacs front-end for proof assistants";
+    longDescription = ''
+      Proof General is a generic front-end for proof assistants (also known as
+      interactive theorem provers), based on the customizable text editor Emacs.
+    '';
+    homepage = http://proofgeneral.inf.ed.ac.uk;
+    license = "GPLv2+";
+    platforms = stdenv.lib.platforms.unix;  # arbitrary choice
+  };
+})