summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-09-30 13:11:17 +0000
committerLudovic Courtès <ludo@gnu.org>2009-09-30 13:11:17 +0000
commit3485bef00a0696378ac910c96805da306ed3b950 (patch)
treee5cec8336b9e42893b00d79aa8f24ad877447ee4 /pkgs/applications
parenta29f9b51d6e3a568c2d992ea32583e66654b129c (diff)
downloadnixlib-3485bef00a0696378ac910c96805da306ed3b950.tar
nixlib-3485bef00a0696378ac910c96805da306ed3b950.tar.gz
nixlib-3485bef00a0696378ac910c96805da306ed3b950.tar.bz2
nixlib-3485bef00a0696378ac910c96805da306ed3b950.tar.lz
nixlib-3485bef00a0696378ac910c96805da306ed3b950.tar.xz
nixlib-3485bef00a0696378ac910c96805da306ed3b950.tar.zst
nixlib-3485bef00a0696378ac910c96805da306ed3b950.zip
Add GnuCash.
svn path=/nixpkgs/trunk/; revision=17551
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/office/gnucash/default.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/pkgs/applications/office/gnucash/default.nix b/pkgs/applications/office/gnucash/default.nix
new file mode 100644
index 000000000000..213e3fd0a457
--- /dev/null
+++ b/pkgs/applications/office/gnucash/default.nix
@@ -0,0 +1,58 @@
+{ fetchurl, stdenv, pkgconfig, libxml2, gconf, glib, gtk
+, libglade, libgnomeui, libgtkhtml, gtkhtml, libgnomeprint, goffice, enchant
+, gettext, intltool, perl, guile, slibGuile, swig, isocodes, bzip2
+, makeWrapper }:
+
+stdenv.mkDerivation rec {
+  name = "gnucash-2.2.9";
+
+  src = fetchurl {
+    url = "http://ftp.at.gnucash.org/pub/gnucash/gnucash/sources/stable/${name}.tar.bz2";
+    sha256 = "0sj83mmshx50122n1i3y782p4b54k37n7sb4vldmqmhwww32925i";
+  };
+
+  buildInputs = [
+    pkgconfig libxml2 gconf glib gtk
+    libglade libgnomeui libgtkhtml gtkhtml libgnomeprint goffice enchant
+    gettext intltool perl guile slibGuile swig isocodes bzip2 makeWrapper
+  ];
+
+  preConfigure = ''
+    # The `.gnucash' directory, used by the test suite.
+    export GNC_DOT_DIR="$PWD/dot-gnucash"
+    echo "\$GNC_DOT_DIR set to \`$GNC_DOT_DIR'"
+  '';
+
+  postInstall = ''
+    for prog in "$out/bin/"*
+    do
+      wrapProgram "$prog"                                       \
+        --set SCHEME_LIBRARY_PATH "$SCHEME_LIBRARY_PATH"        \
+        --prefix GUILE_LOAD_PATH ":" "$GUILE_LOAD_PATH"
+    done
+  '';
+
+  doCheck = true;
+
+  meta = {
+    description = "GnuCash, a personal and small-business financial-accounting application";
+
+    longDescription = ''
+      GnuCash is personal and small-business financial-accounting software,
+      freely licensed under the GNU GPL and available for GNU/Linux, BSD,
+      Solaris, Mac OS X and Microsoft Windows.
+
+      Designed to be easy to use, yet powerful and flexible, GnuCash allows
+      you to track bank accounts, stocks, income and expenses.  As quick and
+      intuitive to use as a checkbook register, it is based on professional
+      accounting principles to ensure balanced books and accurate reports.
+    '';
+
+    license = "GPLv2+";
+
+    homepage = http://www.gnucash.org/;
+
+    maintainers = [ stdenv.lib.maintainers.ludo ];
+    platforms = stdenv.lib.platforms.gnu;
+  };
+}