summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDavid Pätzel <david.a.paetzel+github@gmail.com>2016-10-23 16:25:08 +0200
committerMichael Raskin <7c6f434c@mail.ru>2016-12-28 12:13:36 +0100
commit3414470d9d3ec273bfe255abef6c92febff308b3 (patch)
tree2e01ee271c2b0e66194c948843b61bfac119052c /pkgs/applications
parent88d61cce2848d0ebdc46f22c942f094da09d78c1 (diff)
downloadnixlib-3414470d9d3ec273bfe255abef6c92febff308b3.tar
nixlib-3414470d9d3ec273bfe255abef6c92febff308b3.tar.gz
nixlib-3414470d9d3ec273bfe255abef6c92febff308b3.tar.bz2
nixlib-3414470d9d3ec273bfe255abef6c92febff308b3.tar.lz
nixlib-3414470d9d3ec273bfe255abef6c92febff308b3.tar.xz
nixlib-3414470d9d3ec273bfe255abef6c92febff308b3.tar.zst
nixlib-3414470d9d3ec273bfe255abef6c92febff308b3.zip
urlscan: init at 0.8.3
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/urlscan/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/applications/misc/urlscan/default.nix b/pkgs/applications/misc/urlscan/default.nix
new file mode 100644
index 000000000000..2d01d203ba1e
--- /dev/null
+++ b/pkgs/applications/misc/urlscan/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, buildPythonPackage, isPy35, fetchFromGitHub, urwid }:
+
+buildPythonPackage rec {
+  name = "urlscan-${version}";
+  version = "0.8.3";
+
+  src = fetchFromGitHub {
+    owner = "firecat53";
+    repo = "urlscan";
+    rev = version;
+    # (equivalent but less nice(?): rev = "00333f6d03bf3151c9884ec778715fc605f58cc5")
+    sha256 = "0l40anfznam4d3q0q0jp2wwfrvfypz9ppbpjyzjdrhb3r2nizb0y";
+  };
+
+  propagatedBuildInputs = [ urwid ];
+
+  # FIXME doesn't work with 2.7; others than 2.7 and 3.5 were not tested (yet)
+  disabled = ! isPy35;
+
+  meta = with stdenv.lib; {
+    description = "Mutt and terminal url selector (similar to urlview)";
+    license = licenses.gpl2;
+    maintainers = [ maintainers.dpaetzel ];
+  };
+}