summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-09-13 10:36:29 +0100
committerGitHub <noreply@github.com>2017-09-13 10:36:29 +0100
commit2c01a6fc1fd11ee470ceac7477021a33644173da (patch)
tree1cad405fc4313ea8536fa135bbca1fa4cc8f7536 /pkgs/applications
parent8d4e37710f0b0a69984347b0c0f830df9dfe0ef6 (diff)
parent7cceee29fb712067cf00e4e14c9376b71df2248b (diff)
downloadnixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.tar
nixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.tar.gz
nixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.tar.bz2
nixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.tar.lz
nixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.tar.xz
nixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.tar.zst
nixlib-2c01a6fc1fd11ee470ceac7477021a33644173da.zip
Merge pull request #29025 from dotlambda/seafile-client
seafile-client: add optional Shibboleth support
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/seafile-client/default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/pkgs/applications/networking/seafile-client/default.nix b/pkgs/applications/networking/seafile-client/default.nix
index d930e24883ea..74f5ecb6b75f 100644
--- a/pkgs/applications/networking/seafile-client/default.nix
+++ b/pkgs/applications/networking/seafile-client/default.nix
@@ -1,5 +1,8 @@
 { stdenv, fetchurl, writeScript, pkgconfig, cmake, qtbase, qttools
-, seafile-shared, ccnet, makeWrapper }:
+, seafile-shared, ccnet, makeWrapper
+, withShibboleth ? true, qtwebengine }:
+
+with stdenv.lib;
 
 stdenv.mkDerivation rec {
   version = "6.1.0";
@@ -11,7 +14,11 @@ stdenv.mkDerivation rec {
   };
 
   nativeBuildInputs = [ pkgconfig cmake makeWrapper ];
-  buildInputs = [ qtbase qttools seafile-shared ];
+  buildInputs = [ qtbase qttools seafile-shared ]
+    ++ optional withShibboleth qtwebengine;
+
+  cmakeFlags = [ "-DCMAKE_BUILD_TYPE=Release" ]
+    ++ optional withShibboleth "-DBUILD_SHIBBOLETH_SUPPORT=ON";
 
   postInstall = ''
     wrapProgram $out/bin/seafile-applet \