summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
author_1126 <mail@elfsechsundzwanzig.de>2014-04-18 16:09:50 +0200
committer_1126 <mail@elfsechsundzwanzig.de>2014-04-18 16:09:50 +0200
commit25f7565657d267d9f566c215d77216cfc719e789 (patch)
tree1442e74e2ee39c5a3928a3913b4e7bf351b0de30 /pkgs/applications
parent1833b1a4cc6a77b5984542b0a73c3d1d6d9ad841 (diff)
parent96257ea486c70278e01e2739901a16c454f8085a (diff)
downloadnixlib-25f7565657d267d9f566c215d77216cfc719e789.tar
nixlib-25f7565657d267d9f566c215d77216cfc719e789.tar.gz
nixlib-25f7565657d267d9f566c215d77216cfc719e789.tar.bz2
nixlib-25f7565657d267d9f566c215d77216cfc719e789.tar.lz
nixlib-25f7565657d267d9f566c215d77216cfc719e789.tar.xz
nixlib-25f7565657d267d9f566c215d77216cfc719e789.tar.zst
nixlib-25f7565657d267d9f566c215d77216cfc719e789.zip
Merge branch 'pamixer'
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/pamixer/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/applications/audio/pamixer/default.nix b/pkgs/applications/audio/pamixer/default.nix
new file mode 100644
index 000000000000..4337164fe3a4
--- /dev/null
+++ b/pkgs/applications/audio/pamixer/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchgit, pulseaudio, boost }:
+
+let
+  tag = "1.1";
+in
+
+stdenv.mkDerivation rec {
+
+  name = "pamixer-${tag}";
+
+  src = fetchgit {
+    url = git://github.com/cdemoulins/pamixer;
+    rev = "refs/tags/${tag}";
+    sha256 = "03r0sbfj85wp6yxa87pjg69ivmk0mxxa2nykr8gf2c607igmb034";
+  };
+
+  buildInputs = [ pulseaudio boost ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp pamixer $out/bin
+  '';
+
+  meta = with stdenv.lib; {
+    description = "pamixer is like amixer but for pulseaudio.";
+    longDescription = "Features:
+      - Get the current volume of the default sink, the default source or a selected one by his id
+      - Set the volume for the default sink, the default source or any other device
+      - List the sinks
+      - List the sources
+      - Increase / Decrease the volume for a device
+      - Mute or unmute a device";
+    homepage = https://github.com/cdemoulins/pamixer;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = [ _1126 ];
+  };
+}
\ No newline at end of file