summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-09-30 06:22:56 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-09-30 06:22:56 -0500
commit246e306d2a5271341508883946d863482d17c706 (patch)
tree992f111d1983c7f7b69da70124e3f215f61833a4 /pkgs/applications
parent6b934c30d3eb8ff55b78f14214f15befa09859d8 (diff)
downloadnixlib-246e306d2a5271341508883946d863482d17c706.tar
nixlib-246e306d2a5271341508883946d863482d17c706.tar.gz
nixlib-246e306d2a5271341508883946d863482d17c706.tar.bz2
nixlib-246e306d2a5271341508883946d863482d17c706.tar.lz
nixlib-246e306d2a5271341508883946d863482d17c706.tar.xz
nixlib-246e306d2a5271341508883946d863482d17c706.tar.zst
nixlib-246e306d2a5271341508883946d863482d17c706.zip
kde-workspace: fix build with kdelibs-4.14.12
kdelibs-4.14.12 enables stricter CMake policies which break the
build. Patch to disable the offending test.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/kde-apps-15.04/default.nix1
-rw-r--r--pkgs/applications/kde-apps-15.04/kde-workspace/ksysguard-0001-disable-signalplottertest.patch36
2 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/applications/kde-apps-15.04/default.nix b/pkgs/applications/kde-apps-15.04/default.nix
index 6f05e8557591..4bae82976af2 100644
--- a/pkgs/applications/kde-apps-15.04/default.nix
+++ b/pkgs/applications/kde-apps-15.04/default.nix
@@ -289,6 +289,7 @@ let
       kde-wallpapers = kde4Package super.kde-wallpapers;
 
       kde-workspace = extendDerivation (kde4Package super.kde-workspace) {
+        patches = [ ./kde-workspace/ksysguard-0001-disable-signalplottertest.patch ];
         buildInputs = with scope.xorg; [
             libxkbfile libXcomposite xcbutilimage xcbutilkeysyms xcbutilrenderutil
         ];
diff --git a/pkgs/applications/kde-apps-15.04/kde-workspace/ksysguard-0001-disable-signalplottertest.patch b/pkgs/applications/kde-apps-15.04/kde-workspace/ksysguard-0001-disable-signalplottertest.patch
new file mode 100644
index 000000000000..cd19b7e2d72a
--- /dev/null
+++ b/pkgs/applications/kde-apps-15.04/kde-workspace/ksysguard-0001-disable-signalplottertest.patch
@@ -0,0 +1,36 @@
+From 38f35dcec38458f7192424b3d63bc0c614bb86e0 Mon Sep 17 00:00:00 2001
+From: Thomas Tuegel <ttuegel@gmail.com>
+Date: Mon, 7 Sep 2015 18:55:44 -0500
+Subject: [PATCH] ksysguard disable signalplottertest
+
+---
+ libs/ksysguard/tests/CMakeLists.txt | 16 ----------------
+ 1 file changed, 16 deletions(-)
+
+diff --git a/libs/ksysguard/tests/CMakeLists.txt b/libs/ksysguard/tests/CMakeLists.txt
+index d472fd7..f178b71 100644
+--- a/libs/ksysguard/tests/CMakeLists.txt
++++ b/libs/ksysguard/tests/CMakeLists.txt
+@@ -14,19 +14,3 @@ target_link_libraries(processtest processui ${KDE4_KDECORE_LIBS} ${QT_QTTEST_LIB
+ set( signalplotterbenchmark_SRCS signalplotterbenchmark.cpp ../signalplotter/ksignalplotter.cpp)
+ kde4_add_unit_test( signalplotterbenchmark TESTNAME ksysguard-signalplottertest ${signalplotterbenchmark_SRCS} )
+ target_link_libraries( signalplotterbenchmark ${KDE4_KDEUI_LIBS} ${QT_QTTEST_LIBRARY} ${QT_QTBENCHMARK_LIBRARY} )
+-
+-
+-# KGraphicsSignalPlotter benchmark
+-set( graphicssignalplotterbenchmark_SRCS graphicssignalplotterbenchmark.cpp ../signalplotter/kgraphicssignalplotter.cpp)
+-kde4_add_unit_test( graphicssignalplotterbenchmark TESTNAME ksysguard-signalplottertest ${graphicssignalplotterbenchmark_SRCS} )
+-target_link_libraries( graphicssignalplotterbenchmark ${KDE4_KDEUI_LIBS} ${QT_QTTEST_LIBRARY} ${QT_QTBENCHMARK_LIBRARY} )
+-
+-
+-# KSignalPlotter unit test
+-set( signalplottertest_SRCS signalplottertest.cpp ../signalplotter/ksignalplotter.cpp)
+-kde4_add_unit_test( signalplottertest TESTNAME ksysguard-signalplottertest ${signalplottertest_SRCS} )
+-target_link_libraries( signalplottertest ${KDE4_KDEUI_LIBS} ${QT_QTTEST_LIBRARY} )
+-
+-
+-
+-
+-- 
+2.5.0
+