summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorEric Sagnes <eric.sagnes@gmail.com>2015-07-28 01:52:53 +0900
committerEric Sagnes <eric.sagnes@gmail.com>2015-07-28 08:52:41 +0900
commit242c0d3e185b5343f8e3f2e3ffe09a4b4e454604 (patch)
tree134099841c7d34cbf2e2da9166ffc1330e1c1e19 /pkgs/applications
parent4d3434da9496dfd04f6df6c706e5d9c62554e1c0 (diff)
downloadnixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.tar
nixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.tar.gz
nixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.tar.bz2
nixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.tar.lz
nixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.tar.xz
nixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.tar.zst
nixlib-242c0d3e185b5343f8e3f2e3ffe09a4b4e454604.zip
ponymix: init at 4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/ponymix/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/applications/audio/ponymix/default.nix b/pkgs/applications/audio/ponymix/default.nix
new file mode 100644
index 000000000000..0b5947e16f40
--- /dev/null
+++ b/pkgs/applications/audio/ponymix/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchurl, libpulseaudio, libnotify, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "ponymix-${version}";
+  version = "4";
+  src = fetchurl {
+    url = "http://code.falconindy.com/archive/ponymix/${name}.tar.xz";
+    sha256 = "008pk3sqc8955k2f502z1syzv43a4q0yk5ws69lgpqfsy1mzki2d";
+  };
+
+  buildInputs = [ libpulseaudio libnotify ];
+  nativeBuildInputs = [ pkgconfig ];
+
+  postPatch = ''substituteInPlace Makefile --replace "\$(DESTDIR)/usr" "$out"'';
+
+  meta = {
+    description = "CLI PulseAudio Volume Control";
+    homepage = "http://github.com/falconindy/ponymix";
+    license = "mit";
+  };
+}