summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Alan Dorman <mdorman@ironicdesign.com>2017-12-18 13:44:36 -0500
committerMichael Alan Dorman <mdorman@ironicdesign.com>2017-12-18 13:54:17 -0500
commit21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5 (patch)
treeccbac5ecd6184a73b15b20f4e6b23719ab46377e /pkgs/applications
parente529c6fd1f6d74a6682c362c4c1cd529a164de5e (diff)
downloadnixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.tar
nixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.tar.gz
nixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.tar.bz2
nixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.tar.lz
nixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.tar.xz
nixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.tar.zst
nixlib-21bcd523ebff8486ce1184ab2c9efa0a1d8a87a5.zip
emacsPackagesNg: mark -rtags packages broken
They're all trying to use the same `configure` script that expects
/bin/bash.  This should be correctable.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-modes/melpa-packages.nix15
-rw-r--r--pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix15
2 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/applications/editors/emacs-modes/melpa-packages.nix b/pkgs/applications/editors/emacs-modes/melpa-packages.nix
index 6f9cc976da1e..90b885d683de 100644
--- a/pkgs/applications/editors/emacs-modes/melpa-packages.nix
+++ b/pkgs/applications/editors/emacs-modes/melpa-packages.nix
@@ -36,6 +36,9 @@ self:
     });
 
     overrides = {
+      # Expects bash to be at /bin/bash
+      ac-rtags = markBroken super.ac-rtags;
+
       # upstream issue: mismatched filename
       ack-menu = markBroken super.ack-menu;
 
@@ -53,6 +56,9 @@ self:
       # upstream issue: missing package version
       cmake-mode = markBroken (dontConfigure super.cmake-mode);
 
+      # Expects bash to be at /bin/bash
+      company-rtags = markBroken super.company-rtags;
+
       # upstream issue: missing file header
       connection = markBroken super.connection;
 
@@ -89,6 +95,9 @@ self:
       # missing OCaml
       flycheck-ocaml = markBroken super.flycheck-ocaml;
 
+      # Expects bash to be at /bin/bash
+      flycheck-rtags = markBroken super.flycheck-rtags;
+
       # upstream issue: missing file header
       fold-dwim = markBroken super.fold-dwim;
 
@@ -98,6 +107,9 @@ self:
       # upstream issue: mismatched filename
       helm-lobsters = markBroken super.helm-lobsters;
 
+      # Expects bash to be at /bin/bash
+      helm-rtags = markBroken super.helm-rtags;
+
       # upstream issue: missing file header
       helm-words = markBroken super.helm-words;
 
@@ -107,6 +119,9 @@ self:
       # upstream issue: missing file header
       initsplit = markBroken super.initsplit;
 
+      # Expects bash to be at /bin/bash
+      ivy-rtags = markBroken super.ivy-rtags;
+
       # upstream issue: missing file header
       jsfmt = markBroken super.jsfmt;
 
diff --git a/pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix b/pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix
index a2feba752bfa..b0ccf8349ca0 100644
--- a/pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix
+++ b/pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix
@@ -38,6 +38,9 @@ self:
       # upstream issue: mismatched filename
       ack-menu = markBroken super.ack-menu;
 
+      # Expects bash to be at /bin/bash
+      ac-rtags = markBroken super.ac-rtags;
+
       airline-themes = super.airline-themes.override {
         inherit (self.melpaPackages) powerline;
       };
@@ -52,6 +55,9 @@ self:
       # upstream issue: missing package version
       cmake-mode = markBroken (dontConfigure super.cmake-mode);
 
+      # Expects bash to be at /bin/bash
+      company-rtags = markBroken super.company-rtags;
+
       # upstream issue: missing file header
       connection = markBroken super.connection;
 
@@ -91,6 +97,9 @@ self:
       # missing OCaml
       flycheck-ocaml = markBroken super.flycheck-ocaml;
 
+      # Expects bash to be at /bin/bash
+      flycheck-rtags = markBroken super.flycheck-rtags;
+
       # upstream issue: missing file header
       fold-dwim = markBroken super.fold-dwim;
 
@@ -100,12 +109,18 @@ self:
       # upstream issue: mismatched filename
       helm-lobsters = markBroken super.helm-lobsters;
 
+      # Expects bash to be at /bin/bash
+      helm-rtags = markBroken super.helm-rtags;
+
       # upstream issue: missing file header
       ido-complete-space-or-hyphen = markBroken super.ido-complete-space-or-hyphen;
 
       # upstream issue: missing file header
       initsplit = markBroken super.initsplit;
 
+      # Expects bash to be at /bin/bash
+      ivy-rtags = markBroken super.ivy-rtags;
+
       # upstream issue: missing file header
       jsfmt = markBroken super.jsfmt;