summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-10-06 17:37:39 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-10-06 17:37:39 +0000
commit1ebd86987c49d973c98e1e4e49af42a69e815c2a (patch)
tree69f4745262631456c944a0402d8d9b0e66c8aa74 /pkgs/applications
parent1028742c3b6fe2453cf3b2bd6ab8e71e3f14b1cb (diff)
downloadnixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.tar
nixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.tar.gz
nixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.tar.bz2
nixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.tar.lz
nixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.tar.xz
nixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.tar.zst
nixlib-1ebd86987c49d973c98e1e4e49af42a69e815c2a.zip
Updating googleearth.
I had to use a newer patchelf (0.5), otherwise patchelf (0.4) died with an error at
setting the rpath for a lib.
("virtual address overrun" or something like that)

I still don't know of any stable url for a given version, so we will have this working
until they change the package file again updating.

svn path=/nixpkgs/trunk/; revision=17680
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/googleearth/default.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/pkgs/applications/misc/googleearth/default.nix b/pkgs/applications/misc/googleearth/default.nix
index 4aeb03ff6d7c..2bb4e15ba8b0 100644
--- a/pkgs/applications/misc/googleearth/default.nix
+++ b/pkgs/applications/misc/googleearth/default.nix
@@ -1,15 +1,16 @@
 { stdenv, fetchurl, glibc, mesa, freetype, glib, libSM, libICE, libXi, libXv,
-libXrender, libXrandr, libXfixes, libXcursor, libXinerama, libXext, libX11 }:
+libXrender, libXrandr, libXfixes, libXcursor, libXinerama, libXext, libX11,
+zlib, patchelf05 }:
 
 /* I haven't found any x86_64 package from them */
 assert stdenv.system == "i686-linux";
 
 stdenv.mkDerivation {
-  name = "googleearth-5.11337.1968";
+  name = "googleearth-5.1.3509.4636";
 
   src = fetchurl {
     url = http://dl.google.com/earth/client/current/GoogleEarthLinux.bin;
-    sha256 = "1h090rbdkp3pa97xkkjzj71k343ic8dlngj2cihw5cd1hh3f9idc";
+    sha256 = "6c948c64eed5f30adb67019c0d26c148b9ad7a821891018548da650fe812dca8";
   };
 
   buildInputs = [
@@ -29,6 +30,7 @@ stdenv.mkDerivation {
     freetype 
     libXext 
     libX11 
+    zlib
   ];
 
   phases = "unpackPhase installPhase";
@@ -40,8 +42,6 @@ stdenv.mkDerivation {
     ensureDir $out/{opt/googleearth/,bin};
     tar xf googleearth-data.tar -C $out/opt/googleearth
     tar xf googleearth-linux-x86.tar -C $out/opt/googleearth
-    rm $out/opt/googleearth/libstdc+*
-    rm $out/opt/googleearth/libgcc*
     cp bin/googleearth $out/opt/googleearth
     cat > $out/bin/googleearth << EOF
     #!/bin/sh
@@ -55,12 +55,12 @@ stdenv.mkDerivation {
       fullPath=$fullPath:$i/lib
     done
           
-    patchelf --interpreter "$(cat $NIX_GCC/nix-support/dynamic-linker)" \
+    ${patchelf05}/bin/patchelf --interpreter "$(cat $NIX_GCC/nix-support/dynamic-linker)" \
       --set-rpath $fullPath \
       $out/opt/googleearth/googleearth-bin
 
     for a in $out/opt/googleearth/*.so* ; do
-      patchelf --set-rpath $fullPath $a
+      ${patchelf05}/bin/patchelf --set-rpath $fullPath $a
     done
   '';