summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2014-08-03 11:25:10 +0200
committerVladimír Čunát <vcunat@gmail.com>2014-08-03 11:29:01 +0200
commit1b169722a3d09209835f96a14cb3feace2548220 (patch)
tree02f330e1dbab79ef1132099806d15ce1a8cf2c23 /pkgs/applications
parent7a4a1320859b3e4ba302b36b005b4aec1977dbc1 (diff)
parent6295a3ca36cc746e11c7b01fd47562fde3a703ec (diff)
downloadnixlib-1b169722a3d09209835f96a14cb3feace2548220.tar
nixlib-1b169722a3d09209835f96a14cb3feace2548220.tar.gz
nixlib-1b169722a3d09209835f96a14cb3feace2548220.tar.bz2
nixlib-1b169722a3d09209835f96a14cb3feace2548220.tar.lz
nixlib-1b169722a3d09209835f96a14cb3feace2548220.tar.xz
nixlib-1b169722a3d09209835f96a14cb3feace2548220.tar.zst
nixlib-1b169722a3d09209835f96a14cb3feace2548220.zip
Merge branch 'x-updates'
Close #3147.
The only major update is freetype-2.5, I think (it cost lots of work).
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/lmms/default.nix7
-rw-r--r--pkgs/applications/display-managers/slim/default.nix2
-rw-r--r--pkgs/applications/graphics/graphicsmagick/1.3.7.nix2
-rw-r--r--pkgs/applications/graphics/inkscape/default.nix17
-rw-r--r--pkgs/applications/graphics/inkscape/spuriouscomma.patch11
-rw-r--r--pkgs/applications/misc/llpp/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/telepathy/gabble/default.nix14
-rw-r--r--pkgs/applications/networking/instant-messengers/telepathy/mission-control/default.nix17
-rw-r--r--pkgs/applications/video/mpv/default.nix4
-rw-r--r--pkgs/applications/window-managers/weston/default.nix5
10 files changed, 49 insertions, 34 deletions
diff --git a/pkgs/applications/audio/lmms/default.nix b/pkgs/applications/audio/lmms/default.nix
index 540777473d41..dd0649811bbb 100644
--- a/pkgs/applications/audio/lmms/default.nix
+++ b/pkgs/applications/audio/lmms/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, SDL, alsaLib, cmake, fftwSinglePrec, jack2, libogg
-, libsamplerate, libsndfile, pkgconfig, pulseaudio, qt4
+, libsamplerate, libsndfile, pkgconfig, pulseaudio, qt4, freetype
 }:
 
 stdenv.mkDerivation  rec {
@@ -16,6 +16,11 @@ stdenv.mkDerivation  rec {
     libsndfile pkgconfig pulseaudio qt4
   ];
 
+  # work around broken build system of 0.4.*
+  NIX_CFLAGS_COMPILE = "-I${freetype}/include/freetype2";
+
+  enableParallelBuilding = true;
+
   meta = with stdenv.lib; {
     description = "Linux MultiMedia Studio";
     homepage = "http://lmms.sourceforge.net";
diff --git a/pkgs/applications/display-managers/slim/default.nix b/pkgs/applications/display-managers/slim/default.nix
index 26500939db81..42d2c777aea2 100644
--- a/pkgs/applications/display-managers/slim/default.nix
+++ b/pkgs/applications/display-managers/slim/default.nix
@@ -24,6 +24,8 @@ stdenv.mkDerivation rec {
 
   cmakeFlags = [ "-DUSE_PAM=1" ];
 
+  NIX_CFLAGS_COMPILE = "-I${freetype}/include/freetype";
+
   enableParallelBuilding = true;
 
   buildInputs =
diff --git a/pkgs/applications/graphics/graphicsmagick/1.3.7.nix b/pkgs/applications/graphics/graphicsmagick/1.3.7.nix
index 291d61d5f6f5..8b780647dfae 100644
--- a/pkgs/applications/graphics/graphicsmagick/1.3.7.nix
+++ b/pkgs/applications/graphics/graphicsmagick/1.3.7.nix
@@ -15,7 +15,7 @@ stdenv.mkDerivation {
   configureFlags = "--enable-shared";
 
   buildInputs =
-    [ bzip2 freetype ghostscript graphviz libjpeg libpng libtiff libX11 libxml2
+    [ libpng bzip2 freetype ghostscript graphviz libjpeg libtiff libX11 libxml2
       zlib libtool
     ];
 
diff --git a/pkgs/applications/graphics/inkscape/default.nix b/pkgs/applications/graphics/inkscape/default.nix
index 478a0ff7e50c..bc55b0ff6800 100644
--- a/pkgs/applications/graphics/inkscape/default.nix
+++ b/pkgs/applications/graphics/inkscape/default.nix
@@ -4,18 +4,17 @@
 , gsl, python, pyxml, lxml, poppler, imagemagick, libwpg }:
 
 stdenv.mkDerivation rec {
-  name = "inkscape-0.48.4";
+  name = "inkscape-0.48.5";
 
   src = fetchurl {
     url = "mirror://sourceforge/inkscape/${name}.tar.bz2";
-    sha256 = "17aiibgdwjqpjc38f0yr2sdlgwngg5ac9srlybjcx9aspf6ashc7";
+    sha256 = "0sfr7a1vr1066rrkkqbqvcqs3gawalj68ralnhd6k87jz62fcv1b";
   };
 
   patches = [ ./configure-python-libs.patch ];
 
-  postPatch = ''
-    patch -p0 < ${./spuriouscomma.patch}
-  '';
+  postPatch = stdenv.lib.optionalString doCheck
+    ''sed -i 's:#include "../../src:#include "src:' src/cxxtests.cpp'';
 
   propagatedBuildInputs = [
     # Python is used at run-time to execute scripts, e.g., those from
@@ -31,6 +30,10 @@ stdenv.mkDerivation rec {
 
   configureFlags = "--with-python";
 
+  enableParallelBuilding = true;
+  doCheck = true;
+  checkFlags = "-j1";
+
   postInstall = ''
     # Make sure PyXML modules can be found at run-time.
     for i in "$out/bin/"*
@@ -44,9 +47,11 @@ stdenv.mkDerivation rec {
 
   NIX_LDFLAGS = "-lX11";
 
-  meta = {
+  meta = with stdenv.lib; {
     license = "GPL";
     homepage = http://www.inkscape.org;
+    description = "Vector graphics editor";
+    platforms = platforms.all;
     longDescription = ''
       Inkscape is a feature-rich vector graphics editor that edits
       files in the W3C SVG (Scalable Vector Graphics) file format.
diff --git a/pkgs/applications/graphics/inkscape/spuriouscomma.patch b/pkgs/applications/graphics/inkscape/spuriouscomma.patch
deleted file mode 100644
index bc538068f9e3..000000000000
--- a/pkgs/applications/graphics/inkscape/spuriouscomma.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/widgets/desktop-widget.h~	2011-07-08 13:25:09.000000000 -0500
-+++ src/widgets/desktop-widget.h	2013-02-15 16:04:45.806910365 -0600
-@@ -239,7 +239,7 @@
- private:
-     GtkWidget *tool_toolbox;
-     GtkWidget *aux_toolbox;
--    GtkWidget *commands_toolbox,;
-+    GtkWidget *commands_toolbox;
-     GtkWidget *snap_toolbox;
- 
-     static void init(SPDesktopWidget *widget);
diff --git a/pkgs/applications/misc/llpp/default.nix b/pkgs/applications/misc/llpp/default.nix
index 81ca87af7076..e04898fba29f 100644
--- a/pkgs/applications/misc/llpp/default.nix
+++ b/pkgs/applications/misc/llpp/default.nix
@@ -20,11 +20,11 @@ stdenv.mkDerivation {
     ccopt="-O"
     ccopt="$ccopt -I ${jbig2dec}/include"
     ccopt="$ccopt -I ${libjpeg}/include"
-    ccopt="$ccopt -I ${freetype}/include"
+    ccopt="$ccopt -I ${freetype}/include/freetype2"
     ccopt="$ccopt -I ${openjpeg}/include"
     ccopt="$ccopt -I ${zlib}/include"
     ccopt="$ccopt -I ${mupdf}/include"
-    ccopt="$ccopt -include ${freetype}/include/ft2build.h"
+    ccopt="$ccopt -include ft2build.h"
     ccopt="$ccopt -D_GNU_SOURCE"
 
     cclib="$cclib -lmupdf"
diff --git a/pkgs/applications/networking/instant-messengers/telepathy/gabble/default.nix b/pkgs/applications/networking/instant-messengers/telepathy/gabble/default.nix
index 8a945bc7e2d0..e8e76c10ea5e 100644
--- a/pkgs/applications/networking/instant-messengers/telepathy/gabble/default.nix
+++ b/pkgs/applications/networking/instant-messengers/telepathy/gabble/default.nix
@@ -1,20 +1,24 @@
-{ stdenv, fetchurl, pkgconfig, libxslt, telepathy_glib, libxml2, dbus_glib
+{ stdenv, fetchurl, pkgconfig, libxslt, telepathy_glib, libxml2, dbus_glib, dbus_daemon
 , sqlite, libsoup, libnice, gnutls }:
 
 stdenv.mkDerivation rec {
-  name = "telepathy-gabble-0.17.2";
+  name = "telepathy-gabble-0.18.2";
 
   src = fetchurl {
     url = "${meta.homepage}/releases/telepathy-gabble/${name}.tar.gz";
-    sha256 = "137sslbgh0326lmwihcr2ybljgq9mzsx5wnciilpx884si22wpk8";
+    sha256 = "00ag32ccbj0hmy41rb0fg9gp40m7zbq45r4yijnyslk2mpkvg7c9";
   };
 
   nativeBuildInputs = [ pkgconfig libxslt ];
-  buildInputs = [ libxml2 dbus_glib sqlite libsoup libnice telepathy_glib gnutls ];
+  buildInputs = [ libxml2 dbus_glib sqlite libsoup libnice telepathy_glib gnutls ]
+    ++ stdenv.lib.optional doCheck dbus_daemon;
 
   configureFlags = "--with-ca-certificates=/etc/ssl/certs/ca-bundle.crt";
 
-  meta = {
+  enableParallelBuilding = true;
+  doCheck = true;
+
+  meta = with stdenv.lib; {
     homepage = http://telepathy.freedesktop.org;
     description = "Jabber/XMPP connection manager for the Telepathy framework";
     platforms = stdenv.lib.platforms.gnu;
diff --git a/pkgs/applications/networking/instant-messengers/telepathy/mission-control/default.nix b/pkgs/applications/networking/instant-messengers/telepathy/mission-control/default.nix
index a8142fc1e5cf..b463ff2f2307 100644
--- a/pkgs/applications/networking/instant-messengers/telepathy/mission-control/default.nix
+++ b/pkgs/applications/networking/instant-messengers/telepathy/mission-control/default.nix
@@ -1,20 +1,29 @@
-{ stdenv, fetchurl, pkgconfig, telepathy_glib, libxslt, makeWrapper }:
+{ stdenv, fetchurl, pkgconfig, telepathy_glib, libxslt, makeWrapper, upower }:
 
 stdenv.mkDerivation rec {
-  name = "${pname}-5.16.0";
+  name = "${pname}-5.16.2";
   pname = "telepathy-mission-control";
 
   src = fetchurl {
     url = "http://telepathy.freedesktop.org/releases/${pname}/${name}.tar.gz";
-    sha256 = "1l61w6j04mbrjsbcfrlc0safh9nlsjnj0z6lszal64r9bhkcghzd";
+    sha256 = "1sk8f9jfaxgbsniz0n5hmrcwvxla3x8axjcnjbppg7nidk9gijrx";
   };
 
-  buildInputs = [ telepathy_glib makeWrapper ];
+  buildInputs = [ telepathy_glib makeWrapper upower ]; # ToDo: optional stuff missing
 
   nativeBuildInputs = [ pkgconfig libxslt ];
 
+  doCheck = true;
+
   preFixup = ''
     wrapProgram "$out/libexec/mission-control-5" \
       --prefix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH"
   '';
+
+  meta = with stdenv.lib; {
+    description = "An account manager and channel dispatcher for the Telepathy framework";
+    homepage = http://telepathy.freedesktop.org/wiki/;
+    license = licenses.lgpl21;
+    platforms = platforms.unix;
+  };
 }
diff --git a/pkgs/applications/video/mpv/default.nix b/pkgs/applications/video/mpv/default.nix
index 3295640fa5ab..4eec9afdbf3d 100644
--- a/pkgs/applications/video/mpv/default.nix
+++ b/pkgs/applications/video/mpv/default.nix
@@ -57,11 +57,11 @@ in
 
 stdenv.mkDerivation rec {
   name = "mpv-${version}";
-  version = "0.3.8";
+  version = "0.4.1";
 
   src = fetchurl {
     url = "https://github.com/mpv-player/mpv/archive/v${version}.tar.gz";
-    sha256 = "0k77rq17mslpvvgr4mvkj9bd5s1yhsigwvzym8blr1brxkj9pk3b";
+    sha256 = "0wqjyzw3kk854zj263k7jyykzfaz1g27z50aqrd26hylg8k135cn";
   };
 
   buildInputs = with stdenv.lib;
diff --git a/pkgs/applications/window-managers/weston/default.nix b/pkgs/applications/window-managers/weston/default.nix
index 4880029119eb..73a6412afabc 100644
--- a/pkgs/applications/window-managers/weston/default.nix
+++ b/pkgs/applications/window-managers/weston/default.nix
@@ -2,16 +2,17 @@
 , cairo, libxcb, libXcursor, x11, udev, libdrm, mtdev
 , libjpeg, pam, autoconf, automake, libtool, dbus }:
 
-let version = "1.4.0"; in
+let version = "1.5.0"; in
 
 stdenv.mkDerivation rec {
   name = "weston-${version}";
 
   src = fetchurl {
     url = "http://wayland.freedesktop.org/releases/${name}.tar.xz";
-    sha256 = "0r7dz72ys9p3f697ajgmihkar2da36bnjna6yanb3kg9k2fk38kl";
+    sha256 = "113nig2dmbgrjhi79k0zw77vicnx8vkaihawd0nsg6n79ah8nf06";
   };
 
+  #ToDo: libinput can be split away
   buildInputs = [
     pkgconfig wayland mesa libxkbcommon
     cairo libxcb libXcursor x11 udev libdrm mtdev libjpeg pam dbus.libs