summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2015-03-25 23:17:51 +0100
committerJoachim Fasting <joachifm@fastmail.fm>2015-03-25 23:31:20 +0100
commit1533a9aef5ff0cedce866600c9bb8327c4373f99 (patch)
tree828472f025eae20c39d25d818e9b80201c8d094e /pkgs/applications
parenta00e19ceb96ed8ae2910b009c1ed79dff7167517 (diff)
downloadnixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.tar
nixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.tar.gz
nixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.tar.bz2
nixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.tar.lz
nixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.tar.xz
nixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.tar.zst
nixlib-1533a9aef5ff0cedce866600c9bb8327c4373f99.zip
nano: bump to 2.4.0
Also set license, platforms, and add myself as maintainer.

Changes in this version include a fully functional undo system,
vim-compatible file locking, linter support, formatter support,
and improved highlighter flexibility.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/nano/default.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/pkgs/applications/editors/nano/default.nix b/pkgs/applications/editors/nano/default.nix
index caea8758d958..2e48eadb0a23 100644
--- a/pkgs/applications/editors/nano/default.nix
+++ b/pkgs/applications/editors/nano/default.nix
@@ -1,22 +1,22 @@
 { stdenv, fetchurl, ncurses, gettext }:
 
-stdenv.mkDerivation (rec {
-  pname = "nano";
-  version = "2.3.6";
-
-  name = "${pname}-${version}";
-
+stdenv.mkDerivation rec {
+  name = "nano-${version}";
+  version = "2.4.0";
   src = fetchurl {
     url = "mirror://gnu/nano/${name}.tar.gz";
-    sha256 = "a74bf3f18b12c1c777ae737c0e463152439e381aba8720b4bc67449f36a09534";
+    sha256 = "1gbm9bcv4k55y01r5q8a8a9s3yrrgq3z5jxxiij3wl404r8gnxjh";
   };
-
   buildInputs = [ ncurses gettext ];
+  configureFlags = ''
+    --sysconfdir=/etc
+  '';
 
-  configureFlags = "sysconfdir=/etc";
-
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.nano-editor.org/;
     description = "A small, user-friendly console text editor";
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ joachifm ];
+    platforms = platforms.all;
   };
-})
+}