summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRahul Gopinath <rahul@gopinath.org>2016-06-21 22:29:59 -0700
committerRahul Gopinath <rahul@gopinath.org>2016-06-22 09:27:30 -0700
commit1329375b253be2e9996b23355ce3a54294b7740d (patch)
tree12ad70f7d2b267931b10c26a465295573087d26e /pkgs/applications
parentf5fec0410c572ecd6d23d8968f660fac5687322b (diff)
downloadnixlib-1329375b253be2e9996b23355ce3a54294b7740d.tar
nixlib-1329375b253be2e9996b23355ce3a54294b7740d.tar.gz
nixlib-1329375b253be2e9996b23355ce3a54294b7740d.tar.bz2
nixlib-1329375b253be2e9996b23355ce3a54294b7740d.tar.lz
nixlib-1329375b253be2e9996b23355ce3a54294b7740d.tar.xz
nixlib-1329375b253be2e9996b23355ce3a54294b7740d.tar.zst
nixlib-1329375b253be2e9996b23355ce3a54294b7740d.zip
netsurf-libcss: init at 0.6.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/netsurf/libcss/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/applications/misc/netsurf/libcss/default.nix b/pkgs/applications/misc/netsurf/libcss/default.nix
new file mode 100644
index 000000000000..9db681bf5c19
--- /dev/null
+++ b/pkgs/applications/misc/netsurf/libcss/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, pkgconfig, perl
+, buildsystem
+, libwapcaplet
+, libparserutils
+}:
+
+stdenv.mkDerivation rec {
+
+  name = "netsurf-${libname}-${version}";
+  libname = "libcss";
+  version = "0.6.0";
+
+  src = fetchurl {
+    url = "http://download.netsurf-browser.org/libs/releases/${libname}-${version}-src.tar.gz";
+    sha256 = "0qp4p1q1dwgdra4pkrzd081zjzisxkgwx650ijx323j8bj725daf";
+  };
+
+  buildInputs = [ pkgconfig perl
+    buildsystem
+    libwapcaplet
+    libparserutils
+  ];
+
+  makeFlags = [
+    "PREFIX=$(out)"
+    "NSSHARED=${buildsystem}/share/netsurf-buildsystem"
+  ];
+
+  meta = with stdenv.lib; {
+    homepage = "http://www.netsurf-browser.org/";
+    description = "Cascading Style Sheets library for netsurf browser";
+    license = licenses.gpl2;
+    maintainers = [ maintainers.vrthra ];
+    platforms = platforms.linux;
+  };
+}