summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorBart Brouns <bart@magnetopon.nl>2015-05-30 22:17:03 +0200
committerBart Brouns <bart@magnetopon.nl>2015-05-31 14:58:49 +0200
commit0eca39174b8b52e87ec25a2e55425cdb055b0948 (patch)
tree11b26369b9af5401844dd8010db5a0ee9bf2f713 /pkgs/applications
parent7c09d9d2915317580e14733cde839f88b08a5718 (diff)
downloadnixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.tar
nixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.tar.gz
nixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.tar.bz2
nixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.tar.lz
nixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.tar.xz
nixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.tar.zst
nixlib-0eca39174b8b52e87ec25a2e55425cdb055b0948.zip
init CharacterCompressor CompBus RhythmDelay constant-detune-chorus
Basically the same pkg,but with different sources
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/CharacterCompressor/default.nix33
-rw-r--r--pkgs/applications/audio/CompBus/default.nix39
-rw-r--r--pkgs/applications/audio/RhythmDelay/default.nix33
-rw-r--r--pkgs/applications/audio/constant-detune-chorus/default.nix33
4 files changed, 138 insertions, 0 deletions
diff --git a/pkgs/applications/audio/CharacterCompressor/default.nix b/pkgs/applications/audio/CharacterCompressor/default.nix
new file mode 100644
index 000000000000..3501e04aa97d
--- /dev/null
+++ b/pkgs/applications/audio/CharacterCompressor/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, faust2jack, faust2lv2 }:
+stdenv.mkDerivation rec {
+  name = "CharacterCompressor-${version}";
+  version = "0.2";
+
+  src = fetchFromGitHub {
+    owner = "magnetophon";
+    repo = "CharacterCompressor";
+    rev = "v${version}";
+    sha256 = "0fvi8m4nshcxypn4jgxhnh7pxp68wshhav3k8wn3il7qpw71pdxi";
+  };
+
+  buildInputs = [ faust2jack faust2lv2 ];
+
+  buildPhase = ''
+    faust2jack -t 99999 CharacterCompressor.dsp
+    faust2lv2 -t 99999 CharacterCompressor.dsp
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp CharacterCompressor $out/bin/
+    mkdir -p $out/lib/lv2
+    cp -r CharacterCompressor.lv2/ $out/lib/lv2
+  '';
+
+  meta = {
+    description = "A compressor with character. For jack and lv2";
+    homepage = https://github.com/magnetophon/CharacterCompressor;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.magnetophon ];
+  };
+}
diff --git a/pkgs/applications/audio/CompBus/default.nix b/pkgs/applications/audio/CompBus/default.nix
new file mode 100644
index 000000000000..497d1ef5243f
--- /dev/null
+++ b/pkgs/applications/audio/CompBus/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchFromGitHub, faust2jack, faust2lv2 }:
+stdenv.mkDerivation rec {
+  name = "CompBus-${version}";
+  version = "1.1.02";
+
+  src = fetchFromGitHub {
+    owner = "magnetophon";
+    repo = "CompBus";
+    rev = "v${version}";
+    sha256 = "025vi60caxk3j2vxxrgbc59xlyr88vgn7k3127s271zvpyy7apwh";
+  };
+
+  buildInputs = [ faust2jack faust2lv2 ];
+
+  buildPhase = ''
+    for f in *.dsp;
+    do
+      faust2jack -t 99999 $f
+      faust2lv2 -t 99999 $f
+    done
+  '';
+
+  installPhase = ''
+    mkdir -p $out/lib/lv2
+    mv *.lv2/ $out/lib/lv2
+    mkdir -p $out/bin
+    for f in $(find . -executable -type f);
+    do
+      cp $f $out/bin/
+    done
+  '';
+
+  meta = {
+    description = "A group of compressors mixed into a bus, sidechained from that mix bus. For jack and lv2";
+    homepage = https://github.com/magnetophon/CompBus;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.magnetophon ];
+  };
+}
diff --git a/pkgs/applications/audio/RhythmDelay/default.nix b/pkgs/applications/audio/RhythmDelay/default.nix
new file mode 100644
index 000000000000..e0cfff7c906e
--- /dev/null
+++ b/pkgs/applications/audio/RhythmDelay/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, faust2jack, faust2lv2 }:
+stdenv.mkDerivation rec {
+  name = "RhythmDelay-${version}";
+  version = "2.0";
+
+  src = fetchFromGitHub {
+    owner = "magnetophon";
+    repo = "RhythmDelay";
+    rev = "v${version}";
+    sha256 = "0n938nm08mf3lz92k6v07k1469xxzmfkgclw40jgdssfcfa16bn7";
+  };
+
+  buildInputs = [ faust2jack faust2lv2 ];
+
+  buildPhase = ''
+    faust2jack -t 99999 RhythmDelay.dsp
+    faust2lv2 -t 99999 RhythmDelay.dsp
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp RhythmDelay $out/bin/
+    mkdir -p $out/lib/lv2
+    cp -r RhythmDelay.lv2/ $out/lib/lv2
+  '';
+
+  meta = {
+    description = "Tap a rhythm into your delay! For jack and lv2";
+    homepage = https://github.com/magnetophon/RhythmDelay;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.magnetophon ];
+  };
+}
diff --git a/pkgs/applications/audio/constant-detune-chorus/default.nix b/pkgs/applications/audio/constant-detune-chorus/default.nix
new file mode 100644
index 000000000000..54fe4c866d50
--- /dev/null
+++ b/pkgs/applications/audio/constant-detune-chorus/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, faust2jack, faust2lv2 }:
+stdenv.mkDerivation rec {
+  name = "constant-detune-chorus-${version}";
+  version = "0.1.01";
+
+  src = fetchFromGitHub {
+    owner = "magnetophon";
+    repo = "constant-detune-chorus";
+    rev = "v${version}";
+    sha256 = "1z8aj1a36ix9jizk9wl06b3i98hrkg47qxqp8vx930r624pc5z86";
+  };
+
+  buildInputs = [ faust2jack faust2lv2 ];
+
+  buildPhase = ''
+    faust2jack -t 99999 constant-detune-chorus.dsp
+    faust2lv2 -t 99999 constant-detune-chorus.dsp
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp constant-detune-chorus $out/bin/
+    mkdir -p $out/lib/lv2
+    cp -r constant-detune-chorus.lv2/ $out/lib/lv2
+  '';
+
+  meta = {
+    description = "A chorus algorithm that maintains constant and symmetric detuning depth (in cents), regardless of modulation rate. For jack and lv2";
+    homepage = https://github.com/magnetophon/constant-detune-chorus;
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.magnetophon ];
+  };
+}