summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-07-30 00:15:04 +0100
committerGitHub <noreply@github.com>2017-07-30 00:15:04 +0100
commit0e210f142cdbe8cce49eaa4e049b50c71c3194a8 (patch)
treec4dddc136daa24822bcae2d6b8fc7d30cea95380 /pkgs/applications
parenta5e8ef5a744e31a0f2c2069aafd47acf015d97ed (diff)
parent06bcac90bb156dd732e0f233e9aeea923fb67a92 (diff)
downloadnixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.tar
nixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.tar.gz
nixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.tar.bz2
nixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.tar.lz
nixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.tar.xz
nixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.tar.zst
nixlib-0e210f142cdbe8cce49eaa4e049b50c71c3194a8.zip
Merge pull request #27737 from puffnfresh/bug/alacritty-ld-library-path
alacritty: use patchelf instead of LD_LIBRARY_PATH
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/alacritty/default.nix26
1 files changed, 16 insertions, 10 deletions
diff --git a/pkgs/applications/misc/alacritty/default.nix b/pkgs/applications/misc/alacritty/default.nix
index a00e0ec8a48b..e84ee7ee16ba 100644
--- a/pkgs/applications/misc/alacritty/default.nix
+++ b/pkgs/applications/misc/alacritty/default.nix
@@ -16,6 +16,18 @@
 
 with rustPlatform;
 
+let
+  rpathLibs = [
+    expat
+    freetype
+    fontconfig
+    libX11
+    libXcursor
+    libXxf86vm
+    libXi
+  ];
+in
+
 buildRustPackage rec {
   name = "alacritty-unstable-2017-07-25";
 
@@ -31,31 +43,25 @@ buildRustPackage rec {
   buildInputs = [
     cmake
     makeWrapper
-    freetype
-    fontconfig
     xclip
     pkgconfig
-    expat
-    libX11
-    libXcursor
-    libXxf86vm
-    libXi
-  ];
+  ] ++ rpathLibs;
 
   installPhase = ''
     mkdir -p $out/bin
     for f in $(find target/release -maxdepth 1 -type f); do
       cp $f $out/bin
     done;
-    wrapProgram $out/bin/alacritty --prefix LD_LIBRARY_PATH : "${stdenv.lib.makeLibraryPath buildInputs}"
+    patchelf --set-rpath "${stdenv.lib.makeLibraryPath rpathLibs}" $out/bin/alacritty
   '';
 
+  dontPatchELF = true;
 
   meta = with stdenv.lib; {
     description = "GPU-accelerated terminal emulator";
     homepage = https://github.com/jwilm/alacritty;
     license = with licenses; [ asl20 ];
     maintainers = with maintainers; [ mic92 ];
-    platforms = platforms.all;
+    platforms = platforms.linux;
   };
 }