summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2015-01-05 08:33:11 +0100
committeraszlig <aszlig@redmoonstudios.org>2015-01-05 08:33:11 +0100
commit0d12020a3f65d553a1476b9321c10bc104729583 (patch)
treea82e057f8b3e9388638e5224aefa50acac71747a /pkgs/applications
parentb721c27277be32b43015752accb4534378d83a95 (diff)
parentf1f5a7f6c5099511d7f3c2e8b590d5744f2f8b2e (diff)
downloadnixlib-0d12020a3f65d553a1476b9321c10bc104729583.tar
nixlib-0d12020a3f65d553a1476b9321c10bc104729583.tar.gz
nixlib-0d12020a3f65d553a1476b9321c10bc104729583.tar.bz2
nixlib-0d12020a3f65d553a1476b9321c10bc104729583.tar.lz
nixlib-0d12020a3f65d553a1476b9321c10bc104729583.tar.xz
nixlib-0d12020a3f65d553a1476b9321c10bc104729583.tar.zst
nixlib-0d12020a3f65d553a1476b9321c10bc104729583.zip
Merge pull request #5582 from devhell/profanity.
This add profanity and dependencies and a few cleanups from me for the
profanity package expression.

Thanks to @devhell and apologies for pestering him with my nitpicking.

* Commit summary:
  profanity: Add option for autoAwaySupport.
  profanity: Clean up package expression file.
  profanity: Add libnotifySupport config option
  all-packages: Add libnotify option to profanity
  profanity: Add "platforms" meta information
  profanity: Add libXScrnSaver and libX11 buildInputs
  libstrophe: Add "platforms" meta information
  libstrophe: Fix typo
  profanity: Add profanity, a ncurses XMPP client
  libstrophe: Add new package
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/instant-messengers/profanity/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/applications/networking/instant-messengers/profanity/default.nix b/pkgs/applications/networking/instant-messengers/profanity/default.nix
new file mode 100644
index 000000000000..bd934b6cf737
--- /dev/null
+++ b/pkgs/applications/networking/instant-messengers/profanity/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchurl, automake, autoconf, pkgconfig, glib, openssl, expat
+, ncurses, libotr, curl, libstrophe
+
+, autoAwaySupport ? false, libXScrnSaver ? null, libX11 ? null
+, notifySupport ? false,   libnotify ? null, gdk_pixbuf ? null
+}:
+
+assert autoAwaySupport -> libXScrnSaver != null && libX11 != null;
+assert notifySupport   -> libnotify != null && gdk_pixbuf != null;
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+  name = "profanity-${version}";
+  version = "0.4.5";
+
+  src = fetchurl {
+    url = "http://www.profanity.im/profanity-${version}.tar.gz";
+    sha256 = "0qzwqxcxf695z3gf94psd2x619vlp4hkkjmkrpsla1ns0f6v6dkl";
+  };
+
+  buildInputs = [
+    automake autoconf pkgconfig
+    glib openssl expat ncurses libotr curl libstrophe
+  ] ++ optionals autoAwaySupport [ libXScrnSaver libX11 ]
+    ++ optionals notifySupport   [ libnotify gdk_pixbuf ];
+
+  preConfigure = "sh bootstrap.sh";
+
+  meta = {
+    description = "A console based XMPP client";
+    longDescription = ''
+      Profanity is a console based XMPP client written in C using ncurses and
+      libstrophe, inspired by Irssi.
+    '';
+    homepage = http://profanity.im/;
+    license = licenses.gpl3Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.devhell ];
+  };
+}