summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-08-14 22:34:46 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2018-08-14 22:34:46 -0500
commit0c633ccf2649738c654f04e780d7bebe1b288653 (patch)
treee0ddb2e31ebc68b10f3ae1a306dfc137116e4e0d /pkgs/applications
parentea1542e9ee337281cd32c7d4295b63eacbeb9983 (diff)
downloadnixlib-0c633ccf2649738c654f04e780d7bebe1b288653.tar
nixlib-0c633ccf2649738c654f04e780d7bebe1b288653.tar.gz
nixlib-0c633ccf2649738c654f04e780d7bebe1b288653.tar.bz2
nixlib-0c633ccf2649738c654f04e780d7bebe1b288653.tar.lz
nixlib-0c633ccf2649738c654f04e780d7bebe1b288653.tar.xz
nixlib-0c633ccf2649738c654f04e780d7bebe1b288653.tar.zst
nixlib-0c633ccf2649738c654f04e780d7bebe1b288653.zip
firefox: add default for execdir
not all of the browsers have this set
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/firefox/wrapper.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/applications/networking/browsers/firefox/wrapper.nix b/pkgs/applications/networking/browsers/firefox/wrapper.nix
index a60d533c5a58..827dd520e364 100644
--- a/pkgs/applications/networking/browsers/firefox/wrapper.nix
+++ b/pkgs/applications/networking/browsers/firefox/wrapper.nix
@@ -104,22 +104,22 @@ let
       buildCommand = lib.optionalString stdenv.isDarwin ''
         mkdir -p $out/Applications
         cp -R --no-preserve=mode,ownership ${browser}/Applications/${browserName}.app $out/Applications
-        rm -f $out${browser.execdir}/${browserName}
+        rm -f $out${browser.execdir or "/bin"}/${browserName}
       '' + ''
-        if [ ! -x "${browser}${browser.execdir}/${browserName}" ]
+        if [ ! -x "${browser}${browser.execdir or "/bin"}/${browserName}" ]
         then
             echo "cannot find executable file \`${browser}${browser.execdir}/${browserName}'"
             exit 1
         fi
 
         makeWrapper "$(readlink -v --canonicalize-existing "${browser}${browser.execdir}/${browserName}")" \
-          "$out${browser.execdir}/${browserName}${nameSuffix}" \
+          "$out${browser.execdir or "/bin"}/${browserName}${nameSuffix}" \
             --suffix-each MOZ_PLUGIN_PATH ':' "$plugins" \
             --suffix LD_LIBRARY_PATH ':' "$libs" \
             --suffix-each GTK_PATH ':' "$gtk_modules" \
             --suffix-each LD_PRELOAD ':' "$(cat $(filterExisting $(addSuffix /extra-ld-preload $plugins)))" \
             --prefix-contents PATH ':' "$(filterExisting $(addSuffix /extra-bin-path $plugins))" \
-            --suffix PATH ':' "$out${browser.execdir}" \
+            --suffix PATH ':' "$out${browser.execdir or "/bin"}" \
             --set MOZ_APP_LAUNCHER "${browserName}${nameSuffix}" \
             --set MOZ_SYSTEM_DIR "$out/lib/mozilla" \
             ${lib.optionalString (browser ? gtk3)