summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-08-08 21:14:59 -0400
committerMatthew Bauer <mjbauer95@gmail.com>2018-08-11 22:54:48 -0500
commit08655b16f29e559bf6a4b10a6577e61febbf641f (patch)
tree376da3f55bbadbea73090add118e21faef8ac665 /pkgs/applications
parentc391bd3dd31cec6662995bfe6cea7a36fa3e0b5a (diff)
downloadnixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.tar
nixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.tar.gz
nixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.tar.bz2
nixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.tar.lz
nixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.tar.xz
nixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.tar.zst
nixlib-08655b16f29e559bf6a4b10a6577e61febbf641f.zip
firefox: fix darwin wrapper
- add execdir passthru
  usually this is /bin on macOS it is different.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/firefox-bin/default.nix1
-rw-r--r--pkgs/applications/networking/browsers/firefox/common.nix2
-rw-r--r--pkgs/applications/networking/browsers/firefox/wrapper.nix6
-rw-r--r--pkgs/applications/networking/browsers/tor-browser-bundle/default.nix1
4 files changed, 8 insertions, 2 deletions
diff --git a/pkgs/applications/networking/browsers/firefox-bin/default.nix b/pkgs/applications/networking/browsers/firefox-bin/default.nix
index 570180d4c4df..1fbcb3d97143 100644
--- a/pkgs/applications/networking/browsers/firefox-bin/default.nix
+++ b/pkgs/applications/networking/browsers/firefox-bin/default.nix
@@ -174,6 +174,7 @@ stdenv.mkDerivation {
       gappsWrapperArgs+=(--argv0 "$out/bin/.firefox-wrapped")
     '';
 
+  passthru.execdir = "/bin";
   passthru.ffmpegSupport = true;
   passthru.gssSupport = true;
   # update with:
diff --git a/pkgs/applications/networking/browsers/firefox/common.nix b/pkgs/applications/networking/browsers/firefox/common.nix
index 15486fc82e97..e2a3d4430df7 100644
--- a/pkgs/applications/networking/browsers/firefox/common.nix
+++ b/pkgs/applications/networking/browsers/firefox/common.nix
@@ -263,7 +263,7 @@ stdenv.mkDerivation (rec {
 
   installPhase = if stdenv.isDarwin then ''
     mkdir -p $out/Applications
-    cp -RL Firefox.app $out/Applications
+    cp -LR dist/Firefox.app $out/Applications
   '' else null;
 
   postInstall = lib.optionalString stdenv.isLinux ''
diff --git a/pkgs/applications/networking/browsers/firefox/wrapper.nix b/pkgs/applications/networking/browsers/firefox/wrapper.nix
index 313d1b1d8c82..a60d533c5a58 100644
--- a/pkgs/applications/networking/browsers/firefox/wrapper.nix
+++ b/pkgs/applications/networking/browsers/firefox/wrapper.nix
@@ -101,7 +101,11 @@ let
       nativeBuildInputs = [ makeWrapper lndir ];
       buildInputs = lib.optional (browser ? gtk3) browser.gtk3;
 
-      buildCommand = ''
+      buildCommand = lib.optionalString stdenv.isDarwin ''
+        mkdir -p $out/Applications
+        cp -R --no-preserve=mode,ownership ${browser}/Applications/${browserName}.app $out/Applications
+        rm -f $out${browser.execdir}/${browserName}
+      '' + ''
         if [ ! -x "${browser}${browser.execdir}/${browserName}" ]
         then
             echo "cannot find executable file \`${browser}${browser.execdir}/${browserName}'"
diff --git a/pkgs/applications/networking/browsers/tor-browser-bundle/default.nix b/pkgs/applications/networking/browsers/tor-browser-bundle/default.nix
index 031c520275fe..50b992253cea 100644
--- a/pkgs/applications/networking/browsers/tor-browser-bundle/default.nix
+++ b/pkgs/applications/networking/browsers/tor-browser-bundle/default.nix
@@ -337,6 +337,7 @@ stdenv.mkDerivation rec {
     $out/bin/tor-browser -version >/dev/null
   '';
 
+  passthru.execdir = "/bin";
   meta = with stdenv.lib; {
     description = "An unofficial version of the tor browser bundle, built from source";
     homepage = https://torproject.org/;