summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-08-29 01:47:38 +0000
committerRobin Gloster <mail@glob.in>2016-08-29 01:47:38 +0000
commit06d63f6652863e492838f8f2aed8c380e559a4ee (patch)
tree5212188f0a4bed81d1a10b0c481274cee2d977af /pkgs/applications
parentdf935b01e770682c02d73d114742fc2f498f0347 (diff)
downloadnixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.tar
nixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.tar.gz
nixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.tar.bz2
nixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.tar.lz
nixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.tar.xz
nixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.tar.zst
nixlib-06d63f6652863e492838f8f2aed8c380e559a4ee.zip
ipfs: build with generic go; mark as broken
This does not build after the binutils update due to go 1.5 failing and
ifps needs an upgrade to build with newer go.

cc packager @kamilchm
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/ipfs/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/applications/networking/ipfs/default.nix b/pkgs/applications/networking/ipfs/default.nix
index a08a347ab284..79e2185f04e6 100644
--- a/pkgs/applications/networking/ipfs/default.nix
+++ b/pkgs/applications/networking/ipfs/default.nix
@@ -1,6 +1,6 @@
-{ stdenv, buildGo15Package, fetchFromGitHub }:
+{ stdenv, buildGoPackage, fetchFromGitHub }:
 
-buildGo15Package rec {
+buildGoPackage rec {
   name = "ipfs-${version}";
   version = "i20160112--${stdenv.lib.strings.substring 0 7 rev}";
   rev = "7070b4d878baad57dcc8da80080dd293aa46cabd";
@@ -17,5 +17,6 @@ buildGo15Package rec {
   meta = with stdenv.lib; {
     description = "A global, versioned, peer-to-peer filesystem";
     license = licenses.mit;
+    broken = true;
   };
 }