summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-11-08 14:20:48 -0500
committerGitHub <noreply@github.com>2017-11-08 14:20:48 -0500
commit01018567653aaa58bedf6f7ca6a02c6d50910075 (patch)
tree89dcb477933b3f439ef9f43e22e01a2ed360cfb7 /pkgs/applications
parent999bcd098da0fc6b16ae769dde95573e6b110844 (diff)
parent4d4f94cde4d3806ca063ebf7e6ba448b0feae355 (diff)
downloadnixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.tar
nixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.tar.gz
nixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.tar.bz2
nixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.tar.lz
nixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.tar.xz
nixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.tar.zst
nixlib-01018567653aaa58bedf6f7ca6a02c6d50910075.zip
Merge pull request #30549 from obsidiansystems/bintools
treewide: Introduce stdenv.cc.bintools
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/jucipp/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/editors/jucipp/default.nix b/pkgs/applications/editors/jucipp/default.nix
index ae4f1e6ad525..3d623d3f3bda 100644
--- a/pkgs/applications/editors/jucipp/default.nix
+++ b/pkgs/applications/editors/jucipp/default.nix
@@ -1,7 +1,7 @@
 { config, stdenv, fetchgit, makeWrapper, gnome3, at_spi2_core, libcxx,
   boost, epoxy, cmake, aspell, llvmPackages, libgit2, pkgconfig, pcre,
   libXdmcp, libxkbcommon, libpthreadstubs, wrapGAppsHook, aspellDicts,
-  coreutils, glibc, dbus_libs, openssl, libxml2, gnumake, binutils, ctags }:
+  coreutils, glibc, dbus_libs, openssl, libxml2, gnumake, ctags }:
 
 with stdenv.lib;
 
@@ -65,7 +65,7 @@ stdenv.mkDerivation rec {
   postInstall = ''
     mv $out/bin/juci $out/bin/.juci
     makeWrapper "$out/bin/.juci" "$out/bin/juci" \
-      --set PATH "${stdenv.lib.makeBinPath [ ctags coreutils llvmPackages.clang.cc cmake gnumake binutils llvmPackages.clang ]}" \
+      --set PATH "${stdenv.lib.makeBinPath [ ctags coreutils llvmPackages.clang.cc cmake gnumake llvmPackages.clang.bintools llvmPackages.clang ]}" \
       --set NO_AT_BRIDGE 1 \
       --set ASPELL_CONF "dict-dir ${aspellDicts.en}/lib/aspell"
   '';