summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2018-06-14 08:22:54 +0900
committerMatthieu Coudron <mattator@gmail.com>2018-06-14 08:28:10 +0900
commit0080fe93fcaf18f390696f9c4e715b5ac6952d4a (patch)
tree2d6e2e9197f8871b14180fdd1dfe2c8a8b3411da /pkgs/applications
parente96ce01e766a1f142d9aed5ee01bc51cbc9b093b (diff)
downloadnixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.tar
nixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.tar.gz
nixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.tar.bz2
nixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.tar.lz
nixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.tar.xz
nixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.tar.zst
nixlib-0080fe93fcaf18f390696f9c4e715b5ac6952d4a.zip
http-getter: init at 20180606
Used by flent
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/flent/http-getter.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/applications/networking/flent/http-getter.nix b/pkgs/applications/networking/flent/http-getter.nix
new file mode 100644
index 000000000000..20557c18c52c
--- /dev/null
+++ b/pkgs/applications/networking/flent/http-getter.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchFromGitHub, cmake
+, curl, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "http-getter";
+  version = "20180606";
+
+  src = fetchFromGitHub {
+    owner = "tohojo";
+    repo = "http-getter";
+    rev = "79bcccce721825a745f089d0c347bbaf2e6e12f4";
+    sha256 = "1zxk52s1h5qx62idil237zdpj8agrry0w1xwkfx05wvv9sw4ld35";
+  };
+
+  buildInputs = [ cmake pkgconfig curl ];
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/tohojo/http-getter;
+    description = "Simple getter for HTTP URLs using cURL";
+    platforms = platforms.unix;
+    license = licenses.gpl3;
+  };
+}