summary refs log tree commit diff
path: root/nixos/tests/proxy.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-11 17:15:56 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-11 17:16:44 +0200
commit13185280fee4111dc07f794e528fa3a73f421f3a (patch)
tree40f813ae0cf436e9bbe3a8364b046c6f93ffc2fc /nixos/tests/proxy.nix
parent017408e048ae2419baf0adba424b51d85b063a30 (diff)
downloadnixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.gz
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.bz2
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.lz
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.xz
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.zst
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.zip
Fix tests broken due to the firewall being enabled by default
Diffstat (limited to 'nixos/tests/proxy.nix')
-rw-r--r--nixos/tests/proxy.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/nixos/tests/proxy.nix b/nixos/tests/proxy.nix
index 3b79c16ea2c4..dd64ca02e169 100644
--- a/nixos/tests/proxy.nix
+++ b/nixos/tests/proxy.nix
@@ -5,12 +5,10 @@ let
   backend =
     { config, pkgs, ... }:
 
-    {
-      services.openssh.enable = true;
-
-      services.httpd.enable = true;
+    { services.httpd.enable = true;
       services.httpd.adminAddr = "foo@example.org";
       services.httpd.documentRoot = "${pkgs.valgrind}/share/doc/valgrind/html";
+      networking.firewall.allowedTCPPorts = [ 80 ];
     };
 
 in
@@ -21,8 +19,7 @@ in
     { proxy =
         { config, pkgs, nodes, ... }:
 
-        {
-          services.httpd.enable = true;
+        { services.httpd.enable = true;
           services.httpd.adminAddr = "bar@example.org";
           services.httpd.extraModules = ["proxy_balancer"];
 
@@ -50,6 +47,8 @@ in
               # For testing; don't want to wait forever for dead backend servers.
               ProxyTimeout      5
             '';
+
+          networking.firewall.allowedTCPPorts = [ 80 ];
         };
 
       backend1 = backend;