summary refs log tree commit diff
path: root/nixos/tests/printing.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2018-03-15 22:30:56 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2018-03-15 22:30:56 +0200
commitef64208eba1a2b9052ce6d96b4539163d1aeda9f (patch)
treec4fc3d5a6b5512b0e11021e18237977440207ae1 /nixos/tests/printing.nix
parent208abe9ae3f4a3ced8942ebd3419496089e06453 (diff)
parent3ab2949e1fdfb6ef18c2935ab3e72ea1f9348ef5 (diff)
downloadnixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.gz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.bz2
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.lz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.xz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.zst
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.zip
Merge commit '3ab2949' from staging into master
Conflicts:
	pkgs/development/compilers/llvm/6/llvm.nix
	pkgs/servers/home-assistant/component-packages.nix
Diffstat (limited to 'nixos/tests/printing.nix')
-rw-r--r--nixos/tests/printing.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/tests/printing.nix b/nixos/tests/printing.nix
index 2d3ecaf94cfa..989008830613 100644
--- a/nixos/tests/printing.nix
+++ b/nixos/tests/printing.nix
@@ -39,7 +39,9 @@ import ./make-test.nix ({pkgs, ... }: {
       $client->waitForUnit("cups.service");
       $client->sleep(10); # wait until cups is fully initialized
       $client->succeed("lpstat -r") =~ /scheduler is running/ or die;
-      $client->succeed("lpstat -H") =~ "localhost:631" or die;
+      # Test that UNIX socket is used for connections.
+      $client->succeed("lpstat -H") =~ "/var/run/cups/cups.sock" or die;
+      # Test that HTTP server is available too.
       $client->succeed("curl --fail http://localhost:631/");
       $client->succeed("curl --fail http://server:631/");
       $server->fail("curl --fail --connect-timeout 2  http://client:631/");